summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-04-12 21:18:28 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-04-12 21:18:28 +0000
commit27c140bcfe3bd127fa3cd2692e1af6c5744a1fb1 (patch)
treea962451c9828300b1c82d83bc8dda8e9f7c8fa6c /sys-power
parentStable on sparc, bug #260063 (diff)
downloadgentoo-2-27c140bcfe3bd127fa3cd2692e1af6c5744a1fb1.tar.gz
gentoo-2-27c140bcfe3bd127fa3cd2692e1af6c5744a1fb1.tar.bz2
gentoo-2-27c140bcfe3bd127fa3cd2692e1af6c5744a1fb1.zip
Version bump per bug #261366. Fixes HAL support with new HAL per bug #195165. Fixes --as-needed compile per bug #231772.
(Portage version: 2.2_rc27/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/nut/ChangeLog9
-rw-r--r--sys-power/nut/files/nut-2.4.1-no-libdummy.patch18
-rw-r--r--sys-power/nut/nut-2.4.1.ebuild216
3 files changed, 242 insertions, 1 deletions
diff --git a/sys-power/nut/ChangeLog b/sys-power/nut/ChangeLog
index 5bacc4d11e9a..e70214512416 100644
--- a/sys-power/nut/ChangeLog
+++ b/sys-power/nut/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-power/nut
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/ChangeLog,v 1.60 2009/03/07 20:30:14 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/ChangeLog,v 1.61 2009/04/12 21:18:27 robbat2 Exp $
+
+*nut-2.4.1 (12 Apr 2009)
+
+ 12 Apr 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +files/nut-2.4.1-no-libdummy.patch, +nut-2.4.1.ebuild:
+ Version bump per bug #261366. Fixes HAL support with new HAL per bug
+ #195165. Fixes --as-needed compile per bug #231772.
07 Mar 2009; Petteri Räty <betelgeuse@gentoo.org> nut-2.2.2.ebuild:
Migrate to EAPI 2.
diff --git a/sys-power/nut/files/nut-2.4.1-no-libdummy.patch b/sys-power/nut/files/nut-2.4.1-no-libdummy.patch
new file mode 100644
index 000000000000..31a8e73e54f1
--- /dev/null
+++ b/sys-power/nut/files/nut-2.4.1-no-libdummy.patch
@@ -0,0 +1,18 @@
+diff -Nuar nut-2.4.1.orig/drivers/Makefile.am nut-2.4.1/drivers/Makefile.am
+--- nut-2.4.1.orig/drivers/Makefile.am 2008-07-04 20:12:38.201211819 -0700
++++ nut-2.4.1/drivers/Makefile.am 2008-07-04 20:12:59.829462787 -0700
+@@ -211,10 +211,12 @@
+ upscode2.h victronups.h powerpanel.h powerp-bin.h powerp-txt.h \
+ upshandler.h netxml-ups.h mge-xml.h
+
++EXTRA_LIBRARIES =
++
+ # Define a dummy library so that Automake builds rules for the
+ # corresponding object files. This library is not actually built,
+-EXTRA_LIBRARIES = libdummy.a
+-libdummy_a_SOURCES = main.c dstate.c serial.c
++#EXTRA_LIBRARIES += libdummy.a
++#libdummy_a_SOURCES = main.c dstate.c serial.c
+
+ # the nuthalmain library combines the code for main-hal.c and
+ # dstate-hal.c. It is necessary for Automake-technical reasons,
diff --git a/sys-power/nut/nut-2.4.1.ebuild b/sys-power/nut/nut-2.4.1.ebuild
new file mode 100644
index 000000000000..de2226a0891b
--- /dev/null
+++ b/sys-power/nut/nut-2.4.1.ebuild
@@ -0,0 +1,216 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.4.1.ebuild,v 1.1 2009/04/12 21:18:27 robbat2 Exp $
+
+EAPI="2"
+
+inherit eutils fixheadtails autotools bash-completion
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Network-UPS Tools"
+HOMEPAGE="http://www.networkupstools.org/"
+# Nut mirrors are presently broken
+SRC_URI="http://random.networkupstools.org/source/${PV%.*}/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="cgi snmp usb ssl hal xml"
+
+RDEPEND="cgi? ( >=media-libs/gd-2[png] )
+ snmp? ( net-analyzer/net-snmp )
+ usb? ( >=dev-libs/libusb-0.1.12 )
+ hal? ( >=sys-apps/hal-0.5.11 )
+ ssl? ( dev-libs/openssl )
+ xml? ( >=net-misc/neon-0.25.0 )
+ >=sys-fs/udev-114"
+DEPEND="$RDEPEND
+ >=sys-apps/sed-4
+ >=sys-devel/autoconf-2.58"
+
+# public files should be 644 root:root
+NUT_PUBLIC_FILES="/etc/nut/{{ups,upssched}.conf}"
+# private files should be 640 root:nut - readable by nut, writeable by root,
+NUT_PRIVATE_FILES="/etc/nut/{upsd.conf,upsd.users,upsmon.conf}"
+# public files should be 644 root:root, only installed if USE=cgi
+NUT_CGI_FILES="/etc/nut/{{hosts,upsset}.conf,upsstats{,-single}.html}"
+
+pkg_setup() {
+ enewgroup nut 84
+ enewuser nut 84 -1 /var/lib/nut nut,uucp
+ # As of udev-104, NUT must be in uucp and NOT in tty.
+ gpasswd -d nut tty 2>/dev/null
+ gpasswd -a nut uucp 2>/dev/null
+ use hal && gpasswd -a haldaemon nut 2>/dev/null
+ # in some cases on old systems it wasn't in the nut group either!
+ gpasswd -a nut nut 2>/dev/null
+ warningmsg ewarn
+}
+
+src_prepare() {
+ ht_fix_file configure.in
+
+ epatch "${FILESDIR}"/${PN}-2.4.1-no-libdummy.patch
+
+ sed -e "s:GD_LIBS.*=.*-L/usr/X11R6/lib \(.*\) -lXpm -lX11:GD_LIBS=\"\1:" \
+ -i configure.in || die "sed failed"
+
+ sed -e "s:52.nut-usbups.rules:70-nut-usbups.rules:" \
+ -i scripts/udev/Makefile.am || die "sed failed"
+
+ WANT_AUTOCONF=2.5 eautoreconf || die "autoconf failed"
+}
+
+src_configure() {
+ local myconf
+
+ if [ -n "${NUT_DRIVERS}" ]; then
+ myconf="${myconf} --with-drivers=${NUT_DRIVERS// /,}"
+ fi
+
+ econf \
+ --with-user=nut \
+ --with-group=nut \
+ --with-drvpath=/lib/nut \
+ --sysconfdir=/etc/nut \
+ --with-logfacility=LOG_DAEMON \
+ --with-statepath=/var/lib/nut \
+ --with-htmlpath=/usr/share/nut/html \
+ --datarootdir=/usr/share/nut \
+ --datadir=/usr/share/nut \
+ --with-dev \
+ $(use_with xml neonxml) \
+ $(use_with hal) \
+ $(use_with ssl) \
+ $(use_with usb) \
+ $(use_with snmp) \
+ $(use_with cgi) \
+ $(use_with cgi cgipath /usr/share/nut/cgi) \
+ ${myconf} || die "econf failed"
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodir /sbin
+ dosym /lib/nut/upsdrvctl /sbin/upsdrvctl
+ # This needs to exist for the scripts
+ dosym /lib/nut/upsdrvctl /usr/sbin/upsdrvctl
+
+ if use cgi; then
+ elog "CGI monitoring scripts are installed in /usr/share/nut/cgi."
+ elog "copy them to your web server's ScriptPath to activate (this is a"
+ elog "change from the old location)."
+ elog "If you use lighttpd, see lighttpd_nut.conf in the documentation."
+ fi
+
+ # this must be done after all of the install phases
+ for i in "${D}"/etc/nut/*.sample ; do
+ mv "${i}" "${i/.sample/}"
+ done
+
+ dodoc ChangeLog INSTALL MAINTAINERS NEWS README UPGRADING \
+ docs/{FAQ,*.txt} || die
+
+ newdoc lib/README README.lib || die
+
+ newdoc "${FILESDIR}"/lighttpd_nut.conf-2.2.0 lighttpd_nut.conf || die
+
+ docinto cables
+ dodoc docs/cables/* || die
+
+ newinitd "${FILESDIR}"/nut-2.2.2-init.d-upsd upsd
+ newinitd "${FILESDIR}"/nut-2.2.2-init.d-upsdrv upsdrv
+ newinitd "${FILESDIR}"/nut-2.2.2-init.d-upsmon upsmon
+
+ # This sets up permissions for nut to access a UPS
+ insinto /etc/udev/rules.d/
+ newins scripts/udev/nut-usbups.rules 70-nut-usbups.rules
+
+ keepdir /var/lib/nut
+
+ einfo "Setting up permissions on files and directories"
+ fperms 0700 /var/lib/nut
+ fowners nut:nut /var/lib/nut
+
+ # Do not remove eval here, because the variables contain shell expansions.
+ eval fperms 0640 ${NUT_PRIVATE_FILES}
+ eval fowners root:nut ${NUT_PRIVATE_FILES}
+
+ # Do not remove eval here, because the variables contain shell expansions.
+ eval fperms 0644 ${NUT_PUBLIC_FILES}
+ eval fowners root:root ${NUT_PUBLIC_FILES}
+
+ # Do not remove eval here, because the variables contain shell expansions.
+ if use cgi; then
+ eval fperms 0644 ${NUT_CGI_FILES}
+ eval fowners root:root ${NUT_CGI_FILES}
+ fi
+
+ # this is installed for 2.4 and fbsd guys
+ if ! has_version sys-fs/udev; then
+ einfo "Installing non-udev hotplug support"
+ insinto /etc/hotplug/usb
+ insopts -m 755
+ doins scripts/hotplug/nut-usbups.hotplug
+ fi
+
+ if use hal; then
+ einfo "Installing HAL support"
+ insinto /usr/share/hal/fdi/information/20thirdparty/
+ doins scripts/hal/20-ups-nut-device.fdi
+ insinto /usr/libexec
+ insopts -m 755
+ doins drivers/hald-addon-*
+ rm "${D}"/lib/nut/hald-addon-*
+ fi
+
+ dobashcompletion "${S}"/scripts/misc/nut.bash_completion
+}
+
+pkg_postinst() {
+ # this is to ensure that everybody that installed old versions still has
+ # correct permissions
+
+ chown nut:nut "${ROOT}"/var/lib/nut 2>/dev/null
+ chmod 0700 "${ROOT}"/var/lib/nut 2>/dev/null
+
+ # Do not remove eval here, because the variables contain shell expansions.
+ eval chown root:nut "${ROOT}"${NUT_PRIVATE_FILES} 2>/dev/null
+ eval chmod 0640 "${ROOT}"${NUT_PRIVATE_FILES} 2>/dev/null
+
+ # Do not remove eval here, because the variables contain shell expansions.
+ eval chown root:root "${ROOT}"${NUT_PUBLIC_FILES} 2>/dev/null
+ eval chmod 0644 "${ROOT}"${NUT_PUBLIC_FILES} 2>/dev/null
+
+ # Do not remove eval here, because the variables contain shell expansions.
+ if use cgi; then
+ eval chown root:root "${ROOT}"${NUT_CGI_FILES} 2>/dev/null
+ eval chmod 0644 "${ROOT}"${NUT_CGI_FILES} 2>/dev/null
+ fi
+
+ warningmsg elog
+}
+
+warningmsg() {
+ msgfunc="$1"
+ [ -z "$msgfunc" ] && die "msgfunc not specified in call to warningmsg!"
+ ${msgfunc} "Please note that NUT now runs under the 'nut' user."
+ ${msgfunc} "NUT is in the uucp group for access to RS-232 UPS."
+ ${msgfunc} "However if you use a USB UPS you may need to look at the udev or"
+ ${msgfunc} "hotplug rules that are installed, and alter them suitably."
+ echo
+ ${msgfunc} "If you use hald, you may be able to skip the normal init scripts."
+ echo
+ ${msgfunc} "You are strongly advised to read the UPGRADING file provided by upstream."
+ echo
+ ${msgfunc} "Please note that upsdrv is NOT automatically started by upsd anymore."
+ ${msgfunc} "If you have multiple UPS units, you can use their NUT names to"
+ ${msgfunc} "have a service per UPS:"
+ ${msgfunc} "ln -s /etc/init.d/upsdrv /etc/init.d/upsdrv.\$UPSNAME"
+}