summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-12-20 04:44:07 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-12-20 04:44:07 +0000
commit23399f00a5d71c4b41e27aba21a08ce08818ca3e (patch)
treea6715281c98125638d5496b2e7535a3a029ecf83 /sys-power
parentSwitch to global introspection flag. (diff)
downloadgentoo-2-23399f00a5d71c4b41e27aba21a08ce08818ca3e.tar.gz
gentoo-2-23399f00a5d71c4b41e27aba21a08ce08818ca3e.tar.bz2
gentoo-2-23399f00a5d71c4b41e27aba21a08ce08818ca3e.zip
added release version
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpi_call/ChangeLog8
-rw-r--r--sys-power/acpi_call/acpi_call-1.0.0.ebuild33
-rw-r--r--sys-power/acpi_call/acpi_call-9999.ebuild17
3 files changed, 52 insertions, 6 deletions
diff --git a/sys-power/acpi_call/ChangeLog b/sys-power/acpi_call/ChangeLog
index 0fc6740d029b..eac9c667bef0 100644
--- a/sys-power/acpi_call/ChangeLog
+++ b/sys-power/acpi_call/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/acpi_call
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpi_call/ChangeLog,v 1.3 2012/12/09 20:29:19 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpi_call/ChangeLog,v 1.4 2012/12/20 04:44:07 ottxor Exp $
+
+*acpi_call-1.0.0 (20 Dec 2012)
+
+ 20 Dec 2012; Christoph Junghans <ottxor@gentoo.org> +acpi_call-1.0.0.ebuild,
+ acpi_call-9999.ebuild:
+ added release version
09 Dec 2012; Christoph Junghans <ottxor@gentoo.org> acpi_call-9999.ebuild:
clean breaks sandbox (bug #436086)
diff --git a/sys-power/acpi_call/acpi_call-1.0.0.ebuild b/sys-power/acpi_call/acpi_call-1.0.0.ebuild
new file mode 100644
index 000000000000..d49a0bea0546
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-1.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpi_call/acpi_call-1.0.0.ebuild,v 1.1 2012/12/20 04:44:07 ottxor Exp $
+
+EAPI=5
+
+inherit linux-info linux-mod
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/mkottman/acpi_call.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/mkottman/acpi_call/tarball/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A kernel module that enables you to call ACPI methods"
+HOMEPAGE="http://github.com/mkottman/acpi_call"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+BUILD_TARGETS="default"
+
+src_compile(){
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ linux-mod_src_compile
+}
diff --git a/sys-power/acpi_call/acpi_call-9999.ebuild b/sys-power/acpi_call/acpi_call-9999.ebuild
index 2f25a0511e4b..e42951d3bea6 100644
--- a/sys-power/acpi_call/acpi_call-9999.ebuild
+++ b/sys-power/acpi_call/acpi_call-9999.ebuild
@@ -1,16 +1,23 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpi_call/acpi_call-9999.ebuild,v 1.3 2012/12/09 20:29:19 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpi_call/acpi_call-9999.ebuild,v 1.4 2012/12/20 04:44:07 ottxor Exp $
-EAPI=3
+EAPI=5
-EGIT_REPO_URI="git://github.com/mkottman/acpi_call.git"
+inherit linux-info linux-mod
-inherit git-2 linux-info linux-mod
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/mkottman/acpi_call.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/mkottman/acpi_call/tarball/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
DESCRIPTION="A kernel module that enables you to call ACPI methods"
HOMEPAGE="http://github.com/mkottman/acpi_call"
-SRC_URI=""
LICENSE="GPL-2"
SLOT="0"