summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-01-14 19:34:22 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-01-14 19:34:22 +0000
commit0c1ef6edf66adb1ba9d0d78c7d5224be901e4329 (patch)
tree588b1719a83be493b100e5b9beaf407ba092082b /sys-power
parentRestore fbsplash USE flag. (diff)
downloadgentoo-2-0c1ef6edf66adb1ba9d0d78c7d5224be901e4329.tar.gz
gentoo-2-0c1ef6edf66adb1ba9d0d78c7d5224be901e4329.tar.bz2
gentoo-2-0c1ef6edf66adb1ba9d0d78c7d5224be901e4329.zip
Move single patch from separate patches tarball into files/, blacklist sdhci modules (bug #254674).
(Portage version: 2.1.6.6/cvs/Linux 2.6.28-tuxonice x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/hibernate-script/ChangeLog10
-rw-r--r--sys-power/hibernate-script/files/hibernate-script-1.99-init.d.patch58
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.99-r1.ebuild71
3 files changed, 138 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index c4f3f277172e..10b57f87d7a8 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.79 2009/01/08 23:03:10 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.80 2009/01/14 19:34:21 nelchael Exp $
+
+*hibernate-script-1.99-r1 (14 Jan 2009)
+
+ 14 Jan 2009; <nelchael@gentoo.org>
+ +files/hibernate-script-1.99-init.d.patch,
+ +hibernate-script-1.99-r1.ebuild:
+ Move single patch from separate patches tarball into files/, blacklist
+ sdhci modules (bug #254674).
*hibernate-script-1.99 (08 Jan 2009)
diff --git a/sys-power/hibernate-script/files/hibernate-script-1.99-init.d.patch b/sys-power/hibernate-script/files/hibernate-script-1.99-init.d.patch
new file mode 100644
index 000000000000..5c887185e1ec
--- /dev/null
+++ b/sys-power/hibernate-script/files/hibernate-script-1.99-init.d.patch
@@ -0,0 +1,58 @@
+
+Gentoo layout.
+
+--- init.d/hibernate-cleanup.sh.org 2007-05-04 07:17:40.000000000 +0300
++++ init.d/hibernate-cleanup.sh 2007-05-04 07:22:25.000000000 +0300
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/sbin/runscript
+
+ # This script invalidates any stale swsusp and Software Suspend 2 images. It
+ # searches all swap partitions on your machine, as well as Suspend2's
+@@ -78,27 +78,30 @@ do_reload() {
+
+
+ msg_status() {
+- echo -n "$1"
++ einfon "$1"
+ }
+
+ msg() {
+- echo "$1"
++ einfo "$1"
+ }
+
+-case "$1" in
+-start)
+- msg_status "Invalidating stale software suspend images... "
++opts="reload"
++
++depend() {
++ after modules
++ before localmount
++}
++
++start() {
++ ebegin "Invalidating stale software suspend images"
+ do_start
+- msg "done."
+- ;;
+-stop)
++ eend $?
++}
++
++stop() {
+ do_stop
+- ;;
+-restart|force-reload)
+- do_reload
+- ;;
+-*)
+- msg "Usage: /etc/init.d/hibernate {start|stop|restart|force-reload}"
+-esac
++}
+
+-exit 0
++reload() {
++ do_reload
++}
diff --git a/sys-power/hibernate-script/hibernate-script-1.99-r1.ebuild b/sys-power/hibernate-script/hibernate-script-1.99-r1.ebuild
new file mode 100644
index 000000000000..0ccaae585513
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.99-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.99-r1.ebuild,v 1.1 2009/01/14 19:34:21 nelchael Exp $
+
+inherit eutils
+
+PATCH_VERSION="1"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.tuxonice.net/"
+SRC_URI="http://www.tuxonice.net/downloads/all/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND="!<media-gfx/splashutils-1.5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-init.d.patch"
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+
+ echo "# Bug #254674" >> "${D}/etc/hibernate/blacklisted-modules"
+ echo "sdhci_pci" >> "${D}/etc/hibernate/blacklisted-modules"
+ echo "sdhci" >> "${D}/etc/hibernate/blacklisted-modules"
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate suspend"
+ elog "images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+}