summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-10-18 09:45:31 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-10-18 09:45:31 +0000
commitd3f1b711f38f9120b962223e6be6557f39b1e748 (patch)
tree330b7c6cdd3ae41b9fc023e65ecb6662df80a700 /sys-power/upower
parentRespect LDFLAGS. Bug #334409 (diff)
downloadgentoo-2-d3f1b711f38f9120b962223e6be6557f39b1e748.tar.gz
gentoo-2-d3f1b711f38f9120b962223e6be6557f39b1e748.tar.bz2
gentoo-2-d3f1b711f38f9120b962223e6be6557f39b1e748.zip
Fix building with recent gobject-introspection wrt #341549 by Mike Auty.
(Portage version: 2.2_rc96/cvs/Linux x86_64)
Diffstat (limited to 'sys-power/upower')
-rw-r--r--sys-power/upower/ChangeLog7
-rw-r--r--sys-power/upower/files/upower-0.9.6-introspection-2.patch168
-rw-r--r--sys-power/upower/files/upower-0.9.6-introspection.patch30
-rw-r--r--sys-power/upower/upower-0.9.6.ebuild15
4 files changed, 215 insertions, 5 deletions
diff --git a/sys-power/upower/ChangeLog b/sys-power/upower/ChangeLog
index 51570f3905c4..d8955adc9c3e 100644
--- a/sys-power/upower/ChangeLog
+++ b/sys-power/upower/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/upower
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/upower/ChangeLog,v 1.23 2010/10/17 08:16:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/upower/ChangeLog,v 1.24 2010/10/18 09:45:31 ssuominen Exp $
+
+ 18 Oct 2010; Samuli Suominen <ssuominen@gentoo.org> upower-0.9.6.ebuild,
+ +files/upower-0.9.6-introspection.patch,
+ +files/upower-0.9.6-introspection-2.patch:
+ Fix building with recent gobject-introspection wrt #341549 by Mike Auty.
*upower-0.9.6 (17 Oct 2010)
diff --git a/sys-power/upower/files/upower-0.9.6-introspection-2.patch b/sys-power/upower/files/upower-0.9.6-introspection-2.patch
new file mode 100644
index 000000000000..7bdf57745494
--- /dev/null
+++ b/sys-power/upower/files/upower-0.9.6-introspection-2.patch
@@ -0,0 +1,168 @@
+From 58f3d9fbdff88173276f05e0d6da2cf864758381 Mon Sep 17 00:00:00 2001
+From: Richard Hughes <richard@hughsie.com>
+Date: Tue, 05 Oct 2010 10:13:09 +0000
+Subject: Fix up all the warnings when building with new versions of gobject-introspection
+
+---
+diff --git a/libupower-glib/up-client.c b/libupower-glib/up-client.c
+index 13d5bf7..01ceeb8 100644
+--- a/libupower-glib/up-client.c
++++ b/libupower-glib/up-client.c
+@@ -120,7 +120,7 @@ up_client_get_device (UpClient *client, const gchar *object_path)
+ * You must have called up_client_enumerate_devices_sync() before calling this
+ * function.
+ *
+- * Return value: an array of #UpDevice objects, free with g_ptr_array_unref()
++ * Return value: (transfer full): an array of #UpDevice objects, free with g_ptr_array_unref()
+ *
+ * Since: 0.9.0
+ **/
+diff --git a/libupower-glib/up-device.c b/libupower-glib/up-device.c
+index 41097b2..999f25b 100644
+--- a/libupower-glib/up-device.c
++++ b/libupower-glib/up-device.c
+@@ -568,7 +568,7 @@ out:
+ *
+ * Gets the device history.
+ *
+- * Return value: an array of #UpHistoryItem's, else #NULL and @error is used
++ * Return value: (transfer full): an array of #UpHistoryItem's, else #NULL and @error is used
+ *
+ * Since: 0.9.0
+ **/
+@@ -653,7 +653,7 @@ out:
+ *
+ * Gets the device current statistics.
+ *
+- * Return value: an array of #UpStatsItem's, else #NULL and @error is used
++ * Return value: (transfer full): an array of #UpStatsItem's, else #NULL and @error is used
+ *
+ * Since: 0.9.0
+ **/
+diff --git a/libupower-glib/up-wakeup-item.c b/libupower-glib/up-wakeup-item.c
+index 776473b..7060a3d 100644
+--- a/libupower-glib/up-wakeup-item.c
++++ b/libupower-glib/up-wakeup-item.c
+@@ -66,7 +66,7 @@ G_DEFINE_TYPE (UpWakeupItem, up_wakeup_item, G_TYPE_OBJECT)
+
+ /**
+ * up_wakeup_item_get_is_userspace:
+- * @history_item: #UpWakeupItem
++ * @wakeup_item: #UpWakeupItem
+ *
+ * Gets if the item is userspace.
+ *
+@@ -83,7 +83,7 @@ up_wakeup_item_get_is_userspace (UpWakeupItem *wakeup_item)
+
+ /**
+ * up_wakeup_item_set_is_userspace:
+- * @history_item: #UpWakeupItem
++ * @wakeup_item: #UpWakeupItem
+ * @is_userspace: the new value
+ *
+ * Sets if the item is userspace.
+@@ -100,7 +100,7 @@ up_wakeup_item_set_is_userspace (UpWakeupItem *wakeup_item, gboolean is_userspac
+
+ /**
+ * up_wakeup_item_get_id:
+- * @history_item: #UpWakeupItem
++ * @wakeup_item: #UpWakeupItem
+ *
+ * Gets the item id.
+ *
+@@ -117,7 +117,7 @@ up_wakeup_item_get_id (UpWakeupItem *wakeup_item)
+
+ /**
+ * up_wakeup_item_set_id:
+- * @history_item: #UpWakeupItem
++ * @wakeup_item: #UpWakeupItem
+ * @id: the new value
+ *
+ * Sets the item id.
+@@ -134,7 +134,7 @@ up_wakeup_item_set_id (UpWakeupItem *wakeup_item, guint id)
+
+ /**
+ * up_wakeup_item_get_old:
+- * @history_item: #UpWakeupItem
++ * @wakeup_item: #UpWakeupItem
+ *
+ * Gets the item old.
+ *
+@@ -151,7 +151,7 @@ up_wakeup_item_get_old (UpWakeupItem *wakeup_item)
+
+ /**
+ * up_wakeup_item_set_old:
+- * @history_item: #UpWakeupItem
++ * @wakeup_item: #UpWakeupItem
+ * @old: the new value
+ *
+ * Sets the item old.
+@@ -168,7 +168,7 @@ up_wakeup_item_set_old (UpWakeupItem *wakeup_item, guint old)
+
+ /**
+ * up_wakeup_item_get_value:
+- * @history_item: #UpWakeupItem
++ * @wakeup_item: #UpWakeupItem
+ *
+ * Gets the item value.
+ *
+@@ -185,7 +185,7 @@ up_wakeup_item_get_value (UpWakeupItem *wakeup_item)
+
+ /**
+ * up_wakeup_item_set_value:
+- * @history_item: #UpWakeupItem
++ * @wakeup_item: #UpWakeupItem
+ * @value: the new value
+ *
+ * Sets the item value.
+@@ -202,7 +202,7 @@ up_wakeup_item_set_value (UpWakeupItem *wakeup_item, gdouble value)
+
+ /**
+ * up_wakeup_item_get_cmdline:
+- * @history_item: #UpWakeupItem
++ * @wakeup_item: #UpWakeupItem
+ *
+ * Gets the item cmdline.
+ *
+@@ -219,7 +219,7 @@ up_wakeup_item_get_cmdline (UpWakeupItem *wakeup_item)
+
+ /**
+ * up_wakeup_item_set_cmdline:
+- * @history_item: #UpWakeupItem
++ * @wakeup_item: #UpWakeupItem
+ * @cmdline: the new value
+ *
+ * Sets the item cmdline.
+@@ -237,7 +237,7 @@ up_wakeup_item_set_cmdline (UpWakeupItem *wakeup_item, const gchar *cmdline)
+
+ /**
+ * up_wakeup_item_get_details:
+- * @history_item: #UpWakeupItem
++ * @wakeup_item: #UpWakeupItem
+ *
+ * Gets the item details.
+ *
+@@ -254,7 +254,7 @@ up_wakeup_item_get_details (UpWakeupItem *wakeup_item)
+
+ /**
+ * up_wakeup_item_set_details:
+- * @history_item: #UpWakeupItem
++ * @wakeup_item: #UpWakeupItem
+ * @details: the new value
+ *
+ * Sets the item details.
+diff --git a/libupower-glib/up-wakeups.c b/libupower-glib/up-wakeups.c
+index 1388eab..2843891 100644
+--- a/libupower-glib/up-wakeups.c
++++ b/libupower-glib/up-wakeups.c
+@@ -95,7 +95,7 @@ up_wakeups_get_total_sync (UpWakeups *wakeups, GCancellable *cancellable, GError
+ *
+ * Gets the wakeups data from the daemon.
+ *
+- * Return value: an array of %UpWakeupItem's
++ * Return value: (transfer full): an array of %UpWakeupItem's
+ *
+ * Since: 0.9.1
+ **/
+--
+cgit v0.8.3-6-g21f6
diff --git a/sys-power/upower/files/upower-0.9.6-introspection.patch b/sys-power/upower/files/upower-0.9.6-introspection.patch
new file mode 100644
index 000000000000..53dbe03f9d5d
--- /dev/null
+++ b/sys-power/upower/files/upower-0.9.6-introspection.patch
@@ -0,0 +1,30 @@
+From cfd3641501b23ae68beb9656489e8c3077c3dad5 Mon Sep 17 00:00:00 2001
+From: Edward Sheldrake <ejsheldrake@gmail.com>
+Date: Tue, 05 Oct 2010 10:03:42 +0000
+Subject: Fix building with gobject-introspection 0.9.10
+
+---
+diff --git a/libupower-glib/Makefile.am b/libupower-glib/Makefile.am
+index 83322c4..652f2de 100644
+--- a/libupower-glib/Makefile.am
++++ b/libupower-glib/Makefile.am
+@@ -60,14 +60,15 @@ EXTRA_DIST = \
+ CLEANFILES = $(BUILT_SOURCES)
+
+ if HAVE_INTROSPECTION
+-introspection_sources = $(libupower_glib_la_SOURCES)
++introspection_sources = $(libupower_glib_include_HEADERS) $(libupower_glib_la_SOURCES)
+
+ UPowerGlib-1.0.gir: libupower-glib.la
+ UPowerGlib_1_0_gir_INCLUDES = GObject-2.0 Gio-2.0
+ UPowerGlib_1_0_gir_CFLAGS = $(INCLUDES)
+-PackageKitGlib_1_0_gir_SCANNERFLAGS = --identifier-prefix=Up --warn-all --add-include-path=$(srcdir)
++UPowerGlib_1_0_gir_SCANNERFLAGS = --identifier-prefix=Up --symbol-prefix=up_ --warn-all --add-include-path=$(srcdir)
+ UPowerGlib_1_0_gir_LIBS = libupower-glib.la
+ UPowerGlib_1_0_gir_FILES = $(introspection_sources)
++UPowerGlib_1_0_gir_NAMESPACE = UPowerGlib
+ INTROSPECTION_GIRS += UPowerGlib-1.0.gir
+
+ girdir = $(datadir)/gir-1.0
+--
+cgit v0.8.3-6-g21f6
diff --git a/sys-power/upower/upower-0.9.6.ebuild b/sys-power/upower/upower-0.9.6.ebuild
index 75c13ebb51ba..3df722f90e83 100644
--- a/sys-power/upower/upower-0.9.6.ebuild
+++ b/sys-power/upower/upower-0.9.6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/upower/upower-0.9.6.ebuild,v 1.1 2010/10/17 08:16:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/upower/upower-0.9.6.ebuild,v 1.2 2010/10/18 09:45:31 ssuominen Exp $
EAPI=3
-inherit linux-info
+inherit autotools eutils linux-info
DESCRIPTION="D-Bus abstraction for enumerating power devices and querying history and statistics"
HOMEPAGE="http://upower.freedesktop.org/"
@@ -31,7 +31,8 @@ DEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.40.0
dev-util/pkgconfig
doc? ( dev-util/gtk-doc
- app-text/docbook-xml-dtd:4.1.2 )"
+ app-text/docbook-xml-dtd:4.1.2 )
+ introspection? ( dev-util/gtk-doc-am )" # eautoreconf
RESTRICT="test" # error getting system bus
@@ -45,7 +46,13 @@ pkg_setup() {
}
src_prepare() {
- sed -i -e '/DISABLE_DEPRECATED/d' configure || die
+ if use introspection; then
+ sed -i -e '/DISABLE_DEPRECATED/d' configure.ac || die
+ epatch "${FILESDIR}"/${P}-introspection{,-2}.patch
+ eautoreconf
+ else
+ sed -i -e '/DISABLE_DEPRECATED/d' configure || die
+ fi
}
src_configure() {