summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-05-05 21:42:46 +0000
committerMichael Weber <xmw@gentoo.org>2011-05-05 21:42:46 +0000
commite4efd830078191c9e9e8dcec5d1cfc4d009f134b (patch)
treef4b8839e77af356f673a11f36d4a381d2b838a86 /sys-power/suspend
parentVersion bump. (diff)
downloadgentoo-2-e4efd830078191c9e9e8dcec5d1cfc4d009f134b.tar.gz
gentoo-2-e4efd830078191c9e9e8dcec5d1cfc4d009f134b.tar.bz2
gentoo-2-e4efd830078191c9e9e8dcec5d1cfc4d009f134b.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'sys-power/suspend')
-rw-r--r--sys-power/suspend/ChangeLog7
-rw-r--r--sys-power/suspend/suspend-1.0.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/sys-power/suspend/ChangeLog b/sys-power/suspend/ChangeLog
index abcf6f63c8cf..a124687366e9 100644
--- a/sys-power/suspend/ChangeLog
+++ b/sys-power/suspend/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/suspend
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/ChangeLog,v 1.18 2011/02/14 22:20:54 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/ChangeLog,v 1.19 2011/05/05 21:42:46 xmw Exp $
+
+*suspend-1.0 (05 May 2011)
+
+ 05 May 2011; Michael Weber <xmw@gentoo.org> +suspend-1.0.ebuild:
+ Version bump, thanks to Aleksey Kunitskiy for the hint (bug 365327)
14 Feb 2011; Sebastian Pipping <sping@gentoo.org> suspend-0.9_pre0.ebuild:
For USE=crypt depend on dev-libs/libgcrypt[static-libs] and
diff --git a/sys-power/suspend/suspend-1.0.ebuild b/sys-power/suspend/suspend-1.0.ebuild
new file mode 100644
index 000000000000..0feabba23ab3
--- /dev/null
+++ b/sys-power/suspend/suspend-1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/suspend-1.0.ebuild,v 1.1 2011/05/05 21:42:46 xmw Exp $
+
+EAPI=2
+
+inherit autotools eutils
+
+DESCRIPTION="Userspace Software Suspend and S2Ram"
+HOMEPAGE="http://suspend.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/-utils-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fbsplash crypt threads"
+
+X86_RDEPEND="dev-libs/libx86"
+X86_DEPEND="
+ ${X86_RDEPEND}
+ >=sys-apps/pciutils-2.2.4"
+RDEPEND=">=dev-libs/lzo-2[static-libs]
+ fbsplash? ( >=media-gfx/splashutils-1.5.2 )
+ crypt? ( dev-libs/libgcrypt[static-libs]
+ dev-libs/libgpg-error[static-libs] )
+ x86? ( ${X86_RDEPEND} )
+ amd64? ( ${X86_RDEPEND} )"
+DEPEND="${RDEPEND}
+ x86? ( ${X86_DEPEND} )
+ amd64? ( ${X86_DEPEND} )
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${P/-/-utils-}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9_pre0-errno.patch
+ sed -i -e "/AC_INIT/s/0\.8/0.9-${MY_GIT_SHORT_COMMIT}/" configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-compress \
+ $(use_enable crypt encrypt) \
+ $(use_enable fbsplash) \
+ $(use_enable threads) \
+ || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}
+
+pkg_postinst() {
+ elog "In order to make this package work with genkernel see:"
+ elog "http://bugs.gentoo.org/show_bug.cgi?id=156445"
+}