summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-12-09 20:48:24 +0000
committerRick Farina <zerochaos@gentoo.org>2012-12-09 20:48:24 +0000
commitde3113315aae25b9c895f01c6e6d59665da8a043 (patch)
tree49f4504c2fef12519dd28a2e35ed53fbbe1600b2 /sys-power/powertop
parentRemove stupid mask. (diff)
downloadgentoo-2-de3113315aae25b9c895f01c6e6d59665da8a043.tar.gz
gentoo-2-de3113315aae25b9c895f01c6e6d59665da8a043.tar.bz2
gentoo-2-de3113315aae25b9c895f01c6e6d59665da8a043.zip
fix gettext deps per bug #398977 and clean out old ebuilds
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-power/powertop')
-rw-r--r--sys-power/powertop/ChangeLog7
-rw-r--r--sys-power/powertop/powertop-1.11.ebuild42
-rw-r--r--sys-power/powertop/powertop-2.0.ebuild65
-rw-r--r--sys-power/powertop/powertop-2.1-r1.ebuild105
-rw-r--r--sys-power/powertop/powertop-2.1.ebuild63
-rw-r--r--sys-power/powertop/powertop-2.2-r1.ebuild5
6 files changed, 9 insertions, 278 deletions
diff --git a/sys-power/powertop/ChangeLog b/sys-power/powertop/ChangeLog
index e7bfe209ceac..3edfdedf44ae 100644
--- a/sys-power/powertop/ChangeLog
+++ b/sys-power/powertop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/powertop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.73 2012/11/23 18:05:35 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.74 2012/12/09 20:48:24 zerochaos Exp $
+
+ 09 Dec 2012; Rick Farina <zerochaos@gentoo.org> -powertop-1.11.ebuild,
+ -powertop-2.0.ebuild, -powertop-2.1-r1.ebuild, -powertop-2.1.ebuild,
+ powertop-2.2-r1.ebuild:
+ fix gettext deps per bug #398977 and clean out old ebuilds
*powertop-2.2-r1 (23 Nov 2012)
diff --git a/sys-power/powertop/powertop-1.11.ebuild b/sys-power/powertop/powertop-1.11.ebuild
deleted file mode 100644
index 06fe5f81bb73..000000000000
--- a/sys-power/powertop/powertop-1.11.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-1.11.ebuild,v 1.9 2010/04/05 17:02:18 armin76 Exp $
-
-EAPI=3
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="tool that helps you find what software is using the most power"
-HOMEPAGE="http://www.lesswatts.org/projects/powertop/"
-SRC_URI="http://www.lesswatts.org/projects/powertop/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ppc sparc x86 ~amd64-linux ~x86-linux"
-IUSE="unicode"
-
-DEPEND="sys-libs/ncurses[unicode?]
- sys-devel/gettext"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- sed -i '/${CFLAGS}/s:$: ${LDFLAGS}:' Makefile
- use unicode || sed -i 's:-lncursesw:-lncurses:' Makefile
-}
-
-src_configure() {
- tc-export CC
-}
-
-src_install() {
- emake install DESTDIR="${ED}" || die
- dodoc Changelog README
- gunzip "${ED}"/usr/share/man/man1/powertop.1.gz
-}
-
-pkg_postinst() {
- echo
- einfo "For PowerTOP to work best, use a Linux kernel with the"
- einfo "tickless idle (NO_HZ) feature enabled (version 2.6.21 or later)"
- echo
-}
diff --git a/sys-power/powertop/powertop-2.0.ebuild b/sys-power/powertop/powertop-2.0.ebuild
deleted file mode 100644
index 3f646d176a94..000000000000
--- a/sys-power/powertop/powertop-2.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.0.ebuild,v 1.4 2012/06/01 18:36:59 vapier Exp $
-
-EAPI="4"
-
-inherit eutils
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://github.com/fenrus75/powertop.git"
- inherit git-2
- SRC_URI=""
-else
- SRC_URI="https://01.org/powertop/sites/default/files/downloads/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="tool that helps you find what software is using the most power"
-HOMEPAGE="https://01.org/powertop/ http://www.lesswatts.org/projects/powertop/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="unicode"
-
-DEPEND="
- dev-libs/libnl
- sys-apps/pciutils
- sys-devel/gettext
- sys-libs/ncurses[unicode?]
- sys-libs/zlib
-"
-RDEPEND="
- ${DEPEND}
- x11-apps/xset
-"
-
-DOCS=( TODO README )
-
-src_prepare() {
- sed -i -r \
- -e '/^powertop_CXXFLAGS/s: (-O2|-g|-I/usr/include/) : :g' \
- src/Makefile.in || die
-}
-
-src_configure() {
- export ac_cv_search_delwin=$(usex unicode -lncursesw no)
- default
-}
-
-src_compile() {
- emake -C src csstoh
- cp "${FILESDIR}"/csstoh src/ || die
- emake
-}
-
-src_install() {
- default
- keepdir /var/cache/powertop
-}
-
-pkg_postinst() {
- echo
- einfo "For PowerTOP to work best, use a Linux kernel with the"
- einfo "tickless idle (NO_HZ) feature enabled (version 2.6.21 or later)"
- echo
-}
diff --git a/sys-power/powertop/powertop-2.1-r1.ebuild b/sys-power/powertop/powertop-2.1-r1.ebuild
deleted file mode 100644
index e51421791703..000000000000
--- a/sys-power/powertop/powertop-2.1-r1.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.1-r1.ebuild,v 1.9 2012/11/22 15:00:37 zerochaos Exp $
-
-EAPI="4"
-
-inherit eutils linux-info
-if [ ${PV} == "9999" ] ; then
- EGIT_REPO_URI="git://github.com/fenrus75/powertop.git"
- inherit git-2 autotools
- SRC_URI=""
-else
- SRC_URI="https://01.org/powertop/sites/default/files/downloads/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="tool that helps you find what software is using the most power"
-HOMEPAGE="https://01.org/powertop/ http://www.lesswatts.org/projects/powertop/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="unicode X"
-
-COMMON_DEPEND="
- dev-libs/libnl:3
- sys-apps/pciutils
- sys-devel/gettext
- sys-libs/ncurses[unicode?]
-"
-
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
-"
-RDEPEND="
- ${COMMON_DEPEND}
- X? ( x11-apps/xset )
-"
-
-DOCS=( TODO README )
-
-pkg_setup() {
- if linux_config_exists; then
- CONFIG_CHECK="
- ~X86_MSR
- ~DEBUG_FS
- ~PERF_EVENTS
- ~TRACEPOINTS
- ~NO_HZ
- ~HIGH_RES_TIMERS
- ~HPET_TIMER
- ~CPU_FREQ_STAT
- ~CPU_FREQ_GOV_ONDEMAND
- ~USB_SUSPEND
- ~FTRACE
- ~BLK_DEV_IO_TRACE
- ~TIMER_STATS
- ~EVENT_POWER_TRACING_DEPRECATED
- ~TRACING
- "
- if kernel_is -lt 3 7 0; then
- linux_chkconfig_present SND_HDA_INTEL && CONFIG_CHECK+="~SND_HDA_POWER_SAVE"
- linux_chkconfig_present SND_HDA_INTEL && ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
- fi
- ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
- ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
- ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_TRACEPOINTS="TRACEPOINTS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_NO_HZ="NO_HZ should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_HIGH_RES_TIMERS="HIGH_RES_TIMERS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_USB_SUSPEND="USB_SUSPEND should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
- ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
- ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
- linux-info_pkg_setup
- else
- ewarn "unable to find kernel config, all checks disabled"
- fi
-}
-
-src_prepare() {
- if [ ${PV} == "9999" ] ; then
- eautoreconf
- fi
-}
-
-src_configure() {
- export ac_cv_search_delwin=$(usex unicode -lncursesw -lncurses)
- default
-}
-
-src_compile() {
- #the clean is needed because the 2.1 tarball had object files in src/tuning/
- emake clean
- emake
-}
-
-src_install() {
- default
- keepdir /var/cache/powertop
-}
diff --git a/sys-power/powertop/powertop-2.1.ebuild b/sys-power/powertop/powertop-2.1.ebuild
deleted file mode 100644
index 69bf3f7b4e2d..000000000000
--- a/sys-power/powertop/powertop-2.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.1.ebuild,v 1.5 2012/09/07 11:48:13 pinkbyte Exp $
-
-EAPI="4"
-
-inherit eutils
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://github.com/fenrus75/powertop.git"
- inherit git-2
- SRC_URI=""
-else
- SRC_URI="https://01.org/powertop/sites/default/files/downloads/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="tool that helps you find what software is using the most power"
-HOMEPAGE="https://01.org/powertop/ http://www.lesswatts.org/projects/powertop/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="unicode"
-
-COMMON_DEPEND="
- dev-libs/libnl:3
- sys-apps/pciutils
- sys-devel/gettext
- sys-libs/ncurses[unicode?]
- sys-libs/zlib
-"
-
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
-"
-RDEPEND="
- ${COMMON_DEPEND}
- x11-apps/xset
-"
-
-DOCS=( TODO README )
-
-src_configure() {
- export ac_cv_search_delwin=$(usex unicode -lncursesw -lncurses)
- default
-}
-
-src_compile() {
- #the clean is needed because the 2.1 tarball had object files in src/tuning/
- emake clean
- emake
-}
-
-src_install() {
- default
- keepdir /var/cache/powertop
-}
-
-pkg_postinst() {
- echo
- einfo "For PowerTOP to work best, use a Linux kernel with the"
- einfo "tickless idle (NO_HZ) feature enabled (version 2.6.21 or later)"
- echo
-}
diff --git a/sys-power/powertop/powertop-2.2-r1.ebuild b/sys-power/powertop/powertop-2.2-r1.ebuild
index 12163f7e032e..9443d3c3fcbd 100644
--- a/sys-power/powertop/powertop-2.2-r1.ebuild
+++ b/sys-power/powertop/powertop-2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.2-r1.ebuild,v 1.1 2012/11/23 18:05:35 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.2-r1.ebuild,v 1.2 2012/12/09 20:48:24 zerochaos Exp $
EAPI="5"
@@ -24,16 +24,17 @@ IUSE="unicode X"
COMMON_DEPEND="
dev-libs/libnl:3
sys-apps/pciutils
- sys-devel/gettext
sys-libs/ncurses[unicode?]
"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
+ sys-devel/gettext
"
RDEPEND="
${COMMON_DEPEND}
X? ( x11-apps/xset )
+ virtual/libintl
"
DOCS=( TODO README )