summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-06-04 19:51:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-06-04 19:51:49 +0000
commit654a0bf92c9d55e2ca906f015a9cba748323a63d (patch)
tree217ba2320d6516bdc28b0b46740ae33f72da3ac7 /sys-power/pm-utils
parentVersion bump (bug #511196). (diff)
downloadgentoo-2-654a0bf92c9d55e2ca906f015a9cba748323a63d.tar.gz
gentoo-2-654a0bf92c9d55e2ca906f015a9cba748323a63d.tar.bz2
gentoo-2-654a0bf92c9d55e2ca906f015a9cba748323a63d.zip
Inhibit on right status wrt #360673 by Gerard Neil
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-power/pm-utils')
-rw-r--r--sys-power/pm-utils/ChangeLog11
-rw-r--r--sys-power/pm-utils/files/1.4.1-inhibit-on-right-status.patch20
-rw-r--r--sys-power/pm-utils/pm-utils-1.4.1-r3.ebuild64
3 files changed, 92 insertions, 3 deletions
diff --git a/sys-power/pm-utils/ChangeLog b/sys-power/pm-utils/ChangeLog
index 0c54f30c05e2..30a11a2888dd 100644
--- a/sys-power/pm-utils/ChangeLog
+++ b/sys-power/pm-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/pm-utils
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/pm-utils/ChangeLog,v 1.65 2013/09/01 10:43:25 eva Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/pm-utils/ChangeLog,v 1.66 2014/06/04 19:51:49 ssuominen Exp $
+
+*pm-utils-1.4.1-r3 (04 Jun 2014)
+
+ 04 Jun 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +files/1.4.1-inhibit-on-right-status.patch, +pm-utils-1.4.1-r3.ebuild:
+ Inhibit on right status wrt #360673 by Gerard Neil
01 Sep 2013; Gilles Dartiguelongue <eva@gentoo.org> pm-utils-1.4.1-r2.ebuild:
Do not install docs twice, bug #396351.
@@ -282,4 +288,3 @@
23 Nov 2007; Saleem Abdulrasool <compnerd@gentoo.org> +metadata.xml,
+pm-utils-0.99.4.ebuild:
Initial commit of pm-utils for HAL 0.5.10
-
diff --git a/sys-power/pm-utils/files/1.4.1-inhibit-on-right-status.patch b/sys-power/pm-utils/files/1.4.1-inhibit-on-right-status.patch
new file mode 100644
index 000000000000..250ae0872fbd
--- /dev/null
+++ b/sys-power/pm-utils/files/1.4.1-inhibit-on-right-status.patch
@@ -0,0 +1,20 @@
+Description: Do not use the exit status of log rather the exit status of the hook.
+
+http://bugs.freedesktop.org/show_bug.cgi?id=32210
+http://bugs.gentoo.org/360673
+
+--- pm/pm-functions.in
++++ pm/pm-functions.in
+@@ -197,9 +197,11 @@
+ # rest of args passed to hook unchanged.
+ log "Running hook $*:"
+ hook_ok "$1" && "$@"
++ # log() changes the return value, so save it for later
++ local status=$?
+ log ""
+ log -n "$*: "
+- hook_exit_status $? && LAST_HOOK="${1##*/}" || inhibit
++ hook_exit_status $status && LAST_HOOK="${1##*/}" || inhibit
+ }
+
+ if profiling; then
diff --git a/sys-power/pm-utils/pm-utils-1.4.1-r3.ebuild b/sys-power/pm-utils/pm-utils-1.4.1-r3.ebuild
new file mode 100644
index 000000000000..2e02bbc7c1f6
--- /dev/null
+++ b/sys-power/pm-utils/pm-utils-1.4.1-r3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/pm-utils/pm-utils-1.4.1-r3.ebuild,v 1.1 2014/06/04 19:51:49 ssuominen Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Suspend and hibernation utilities"
+HOMEPAGE="http://pm-utils.freedesktop.org/"
+SRC_URI="http://pm-utils.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa debug ntp video_cards_intel video_cards_radeon"
+
+vbetool="!video_cards_intel? ( sys-apps/vbetool )"
+RDEPEND="!<app-laptop/laptop-mode-tools-1.55-r1
+ !sys-power/powermgmt-base[-pm-utils(+)]
+ sys-apps/dbus
+ >=sys-apps/util-linux-2.13
+ sys-power/pm-quirks
+ alsa? ( media-sound/alsa-utils )
+ ntp? ( || ( net-misc/ntp net-misc/openntpd ) )
+ amd64? ( ${vbetool} )
+ x86? ( ${vbetool} )
+ video_cards_radeon? ( app-laptop/radeontool )"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog NEWS pm/HOWTO* README* TODO"
+
+src_prepare() {
+ local ignore="01grub"
+ use ntp || ignore+=" 90clock"
+
+ use debug && echo 'PM_DEBUG="true"' > "${T}"/gentoo
+ echo "HOOK_BLACKLIST=\"${ignore}\"" >> "${T}"/gentoo
+
+ epatch \
+ "${FILESDIR}"/${PV}-bluetooth-sync.patch \
+ "${FILESDIR}"/${PV}-disable-sata-alpm.patch \
+ "${FILESDIR}"/${PV}-fix-intel-audio-powersave-hook.patch \
+ "${FILESDIR}"/${PV}-logging-append.patch \
+ "${FILESDIR}"/${PV}-inhibit-on-right-status.patch
+
+}
+
+src_configure() {
+ econf --disable-doc
+}
+
+src_install() {
+ default
+ doman man/*.{1,8}
+
+ # Remove duplicate documentation install
+ rm -r "${D}"/usr/share/doc/${PN}
+
+ insinto /etc/pm/config.d
+ doins "${T}"/gentoo
+
+ # NetworkManager 0.8.2 is handling suspend/resume on it's own with UPower
+ find "${D}" -type f -name 55NetworkManager -exec rm -f '{}' +
+}