summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-10-27 11:28:07 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-10-27 11:28:07 +0000
commit62d9a7a05e254e44da68500fd097afd1e9127187 (patch)
treed550d2a028285c8c41a96553bbc4cff03b2db4d5 /sys-power/hibernate-script
parentppc stable, bug #195503 (diff)
downloadgentoo-2-62d9a7a05e254e44da68500fd097afd1e9127187.tar.gz
gentoo-2-62d9a7a05e254e44da68500fd097afd1e9127187.tar.bz2
gentoo-2-62d9a7a05e254e44da68500fd097afd1e9127187.zip
Version bump
(Portage version: 2.1.3.16)
Diffstat (limited to 'sys-power/hibernate-script')
-rw-r--r--sys-power/hibernate-script/ChangeLog8
-rw-r--r--sys-power/hibernate-script/files/digest-hibernate-script-1.976
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.97.ebuild72
3 files changed, 85 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index 1adb4e8cb8fa..b641a477edc5 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.63 2007/09/12 22:54:46 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.64 2007/10/27 11:28:07 alonbl Exp $
+
+*hibernate-script-1.97 (27 Oct 2007)
+
+ 27 Oct 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +hibernate-script-1.97.ebuild:
+ Version bump
*hibernate-script-1.96-r1 (12 Sep 2007)
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.97 b/sys-power/hibernate-script/files/digest-hibernate-script-1.97
new file mode 100644
index 000000000000..7321596590fd
--- /dev/null
+++ b/sys-power/hibernate-script/files/digest-hibernate-script-1.97
@@ -0,0 +1,6 @@
+MD5 68e4d568da76808a95426a2a0560b7c3 hibernate-script-1.97-patches-1.tar.bz2 1222
+RMD160 4453384bc0f06f32277217785b6cb1b227e232b9 hibernate-script-1.97-patches-1.tar.bz2 1222
+SHA256 4a893ec16d0a283e1c5dd876fddc47866b88aefc32d72388081327ba683feb5e hibernate-script-1.97-patches-1.tar.bz2 1222
+MD5 c3551238a2fe8bbe7b0e20322d8e02a5 hibernate-script-1.97.tar.gz 81504
+RMD160 6346a098f0892e6cffd547b0b7d042a51f298bb2 hibernate-script-1.97.tar.gz 81504
+SHA256 8374bedc80206a6708c10d9814b92bebed3d9e4966c01c2d086e9e5b5646827c hibernate-script-1.97.tar.gz 81504
diff --git a/sys-power/hibernate-script/hibernate-script-1.97.ebuild b/sys-power/hibernate-script/hibernate-script-1.97.ebuild
new file mode 100644
index 000000000000..cf447c18ae1f
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.97.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.97.ebuild,v 1.1 2007/10/27 11:28:07 alonbl Exp $
+
+inherit eutils
+
+PATCH_VERSION="1"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.tuxonice.net/"
+SRC_URI="http://www.tuxonice.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim-syntax"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )
+ !<media-gfx/splashutils-1.5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Our patches
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate suspend"
+ elog "images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+}