summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-05-10 22:00:40 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-05-10 22:00:40 +0000
commit0ef346ef59ea20a3c388c244d921b4aa148e3484 (patch)
tree644d5cf8c0e9f8b20ac20ec2af2418cd7edbe86b /sys-power/hibernate-script
parentgcrypt initialisation fault. bug #177682 (diff)
downloadgentoo-2-0ef346ef59ea20a3c388c244d921b4aa148e3484.tar.gz
gentoo-2-0ef346ef59ea20a3c388c244d921b4aa148e3484.tar.bz2
gentoo-2-0ef346ef59ea20a3c388c244d921b4aa148e3484.zip
Fix functions.sh location, bug#177690, thanks to comio and SpanKY
(Portage version: 2.1.2.7)
Diffstat (limited to 'sys-power/hibernate-script')
-rw-r--r--sys-power/hibernate-script/ChangeLog8
-rw-r--r--sys-power/hibernate-script/files/digest-hibernate-script-1.95_beta20070504-r16
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.95_beta20070504-r1.ebuild76
3 files changed, 89 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index e429cb6628ad..d71f3b260645 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.53 2007/05/04 04:37:01 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.54 2007/05/10 22:00:40 alonbl Exp $
+
+*hibernate-script-1.95_beta20070504-r1 (10 May 2007)
+
+ 10 May 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +hibernate-script-1.95_beta20070504-r1.ebuild:
+ Fix functions.sh location, bug#177690, thanks to comio and SpanKY
*hibernate-script-1.95_beta20070504 (04 May 2007)
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.95_beta20070504-r1 b/sys-power/hibernate-script/files/digest-hibernate-script-1.95_beta20070504-r1
new file mode 100644
index 000000000000..3411e1cef935
--- /dev/null
+++ b/sys-power/hibernate-script/files/digest-hibernate-script-1.95_beta20070504-r1
@@ -0,0 +1,6 @@
+MD5 7349c434af66cccf04bcf48c980e112e hibernate-script-1.95_beta20070504-patches-2.tar.bz2 1539
+RMD160 38b0e5d43a88c54cf7fc81910fba7000755acf1d hibernate-script-1.95_beta20070504-patches-2.tar.bz2 1539
+SHA256 287e8c23f0ff67b40d49c5927a1e71cedd3947899eac0525a6151d1444273fe0 hibernate-script-1.95_beta20070504-patches-2.tar.bz2 1539
+MD5 025a661a95aba9f0ca678907dcb5dde2 hibernate-script-1.95_beta20070504.tar.gz 74733
+RMD160 b552ad412a7846bc52599ee5f2797cb2203ded31 hibernate-script-1.95_beta20070504.tar.gz 74733
+SHA256 cb4d4e42b7c2d349c13e559fe1e785547eab0089dfcabf03a6926ff6bbc4595c hibernate-script-1.95_beta20070504.tar.gz 74733
diff --git a/sys-power/hibernate-script/hibernate-script-1.95_beta20070504-r1.ebuild b/sys-power/hibernate-script/hibernate-script-1.95_beta20070504-r1.ebuild
new file mode 100644
index 000000000000..0c94a96e6e70
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.95_beta20070504-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.95_beta20070504-r1.ebuild,v 1.1 2007/05/10 22:00:40 alonbl Exp $
+
+inherit eutils
+
+PATCH_VERSION="2"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.suspend2.net/"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Our patches
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate"
+ elog "suspend images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+ elog
+ elog "Starting with hibernate-script-1.90 the configuration files have"
+ elog "been reordered and split into method specific files. Make sure you"
+ elog "update your /etc/hibernate/ configuration files accordingly."
+ elog
+}