summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-10-07 07:00:29 +0000
committerChristian Heim <phreak@gentoo.org>2006-10-07 07:00:29 +0000
commit829e9fb43e64d26c5805292c5ae26e4ea57c710a (patch)
tree6fad111b0e44dc2f86ca0274fc2b1af30249653f /sys-power/cpufreqd
parentversion bump fixing some bugs and adding a couple of features. removed older ... (diff)
downloadgentoo-2-829e9fb43e64d26c5805292c5ae26e4ea57c710a.tar.gz
gentoo-2-829e9fb43e64d26c5805292c5ae26e4ea57c710a.tar.bz2
gentoo-2-829e9fb43e64d26c5805292c5ae26e4ea57c710a.zip
Version bump. Also bumping the nvclock to use the latest one available from UPSTREAM (0.8b2).
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'sys-power/cpufreqd')
-rw-r--r--sys-power/cpufreqd/ChangeLog9
-rw-r--r--sys-power/cpufreqd/cpufreqd-2.2.0.ebuild66
-rw-r--r--sys-power/cpufreqd/files/digest-cpufreqd-2.2.06
-rw-r--r--sys-power/cpufreqd/files/nvclock0.8b2-fpic.patch20
4 files changed, 100 insertions, 1 deletions
diff --git a/sys-power/cpufreqd/ChangeLog b/sys-power/cpufreqd/ChangeLog
index 2bb8b999ea9d..7d7f55593b3c 100644
--- a/sys-power/cpufreqd/ChangeLog
+++ b/sys-power/cpufreqd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-power/cpufreqd
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/ChangeLog,v 1.35 2006/10/07 06:45:42 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/ChangeLog,v 1.36 2006/10/07 07:00:29 phreak Exp $
+
+*cpufreqd-2.2.0 (07 Oct 2006)
+
+ 07 Oct 2006; Christian Heim <phreak@gentoo.org>
+ +files/nvclock0.8b2-fpic.patch, +cpufreqd-2.2.0.ebuild:
+ Version bump. Also bumping the nvclock to use the latest one available from
+ UPSTREAM (0.8b2).
07 Oct 2006; Christian Heim <phreak@gentoo.org> cpufreqd-2.1.0.ebuild,
cpufreqd-2.1.1.ebuild:
diff --git a/sys-power/cpufreqd/cpufreqd-2.2.0.ebuild b/sys-power/cpufreqd/cpufreqd-2.2.0.ebuild
new file mode 100644
index 000000000000..180318a1c635
--- /dev/null
+++ b/sys-power/cpufreqd/cpufreqd-2.2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.2.0.ebuild,v 1.1 2006/10/07 07:00:29 phreak Exp $
+
+inherit eutils
+
+NVCLOCK_VERSION="0.8b2"
+
+DESCRIPTION="CPU Frequency Daemon"
+HOMEPAGE="http://cpufreqd.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ nvidia? ( http://www.linuxhardware.org/nvclock/nvclock${NVCLOCK_VERSION}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="acpi apm lm_sensors nforce2 nvidia pmu"
+RDEPEND=">=sys-power/cpufrequtils-002
+ lm_sensors? ( sys-apps/lm_sensors )"
+DEPEND="sys-apps/sed
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e "s:acpi_event:acpi:" ${S}/cpufreqd.conf
+
+ if use nvidia; then
+ cd ${WORKDIR}/nvclock${NVCLOCK_VERSION}
+ epatch "${FILESDIR}"/nvclock${NVCLOCK_VERSION}-fpic.patch
+ fi
+}
+
+src_compile() {
+ local config
+
+ if use nvidia; then
+ cd ${WORKDIR}/nvclock${NVCLOCK_VERSION}
+ econf \
+ --disable-gtk \
+ --disable-qt \
+ --disable-nvcontrol \
+ || die "econf nvclock failed"
+ emake -j1 || die "emake nvclock failed"
+ config="--enable-nvclock=${WORKDIR}/nvclock${NVCLOCK_VERSION}"
+ fi
+
+ cd "${S}"
+ econf \
+ $(use_enable acpi) \
+ $(use_enable apm) \
+ $(use_enable lm_sensors sensors) \
+ $(use_enable nforce2) \
+ $(use_enable pmu) \
+ ${config} \
+ || die "econf failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ newinitd "${FILESDIR}"/${P}-init.d ${PN}
+}
diff --git a/sys-power/cpufreqd/files/digest-cpufreqd-2.2.0 b/sys-power/cpufreqd/files/digest-cpufreqd-2.2.0
new file mode 100644
index 000000000000..bee4d49cb0f4
--- /dev/null
+++ b/sys-power/cpufreqd/files/digest-cpufreqd-2.2.0
@@ -0,0 +1,6 @@
+MD5 a8916004d3fb75ed43822eb978c08fc5 cpufreqd-2.2.0.tar.bz2 292219
+RMD160 2e61db9bac593ae564e5103c80b4c49b9a85011c cpufreqd-2.2.0.tar.bz2 292219
+SHA256 13b857d23dff773965eb03a1531e6265627c328d5cc448ec4d446a7c54348d3b cpufreqd-2.2.0.tar.bz2 292219
+MD5 8b9f55115f3c5b7b9a9a16fe40cec4a5 nvclock0.8b2.tar.gz 316510
+RMD160 1c8aff1a0f2bd472f9d5296d2d575823b2cb5107 nvclock0.8b2.tar.gz 316510
+SHA256 b3c05f1cceb57a816cea096f9b71154c0ce5e2ec31febb85e3db831b0b3407aa nvclock0.8b2.tar.gz 316510
diff --git a/sys-power/cpufreqd/files/nvclock0.8b2-fpic.patch b/sys-power/cpufreqd/files/nvclock0.8b2-fpic.patch
new file mode 100644
index 000000000000..ab926f6c8dc4
--- /dev/null
+++ b/sys-power/cpufreqd/files/nvclock0.8b2-fpic.patch
@@ -0,0 +1,20 @@
+Index: nvclock0.8b2/src/backend/Makefile.in
+===================================================================
+--- nvclock0.8b2.orig/src/backend/Makefile.in
++++ nvclock0.8b2/src/backend/Makefile.in
+@@ -5,7 +5,7 @@ RANLIB=@RANLIB@
+ system=@system@
+ HAVE_NVCONTROL=@HAVE_NVCONTROL@
+ OBJECTS=backend.o bios.o config.o error.o nv30.o nv31.o nv40.o info.o overclock.o i2c.o xf86i2c.o adt7473.o f75375.o lm99.o w83781d.o w83l785r.o libc_wrapper.o
+-CFLAGS=@X11_CFLAGS@ -I../.. -I../nvcontrol
++CFLAGS=@X11_CFLAGS@ -I../.. -I../nvcontrol -fPIC
+
+ ifeq ($(system), FreeBSD)
+ OBJECTS+=back_bsd.o
+@@ -36,4 +36,4 @@ distclean: clean
+ rm -f Makefile
+
+ install:
+-uninstall:
+\ No newline at end of file
++uninstall: