summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-10-01 10:57:44 +0000
committerRoy Marples <uberlord@gentoo.org>2007-10-01 10:57:44 +0000
commit81c8a410c155c0ac824dc7d57ddcf042507f7f54 (patch)
tree4c8d858742e20032caa46a54df4348363969de2c /sys-power/athcool/athcool-0.3.11-r1.ebuild
parentalpha/ia64/sparc stable wrt security #194039 (diff)
downloadgentoo-2-81c8a410c155c0ac824dc7d57ddcf042507f7f54.tar.gz
gentoo-2-81c8a410c155c0ac824dc7d57ddcf042507f7f54.tar.bz2
gentoo-2-81c8a410c155c0ac824dc7d57ddcf042507f7f54.zip
Remove bashisms from init script, #194362 thanks to Peter Alfredsen
(Portage version: 2.1.3.11, RepoMan options: --force)
Diffstat (limited to 'sys-power/athcool/athcool-0.3.11-r1.ebuild')
-rw-r--r--sys-power/athcool/athcool-0.3.11-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-power/athcool/athcool-0.3.11-r1.ebuild b/sys-power/athcool/athcool-0.3.11-r1.ebuild
new file mode 100644
index 000000000000..1b6639ce30a8
--- /dev/null
+++ b/sys-power/athcool/athcool-0.3.11-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/athcool/athcool-0.3.11-r1.ebuild,v 1.1 2007/10/01 10:57:44 uberlord Exp $
+
+inherit eutils
+
+DESCRIPTION="small utility to toggle Powersaving mode for AMD Athlon/Duron processors"
+HOMEPAGE="http://members.jcom.home.ne.jp/jacobi/linux/softwares.html#athcool"
+SRC_URI="http://members.jcom.home.ne.jp/jacobi/linux/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+
+DEPEND="sys-apps/pciutils"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ doinitd "${FILESDIR}"/athcool
+ dodoc README ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "WARNING: Depending on your motherboard and/or hardware components,"
+ ewarn "enabling powersaving mode may cause:"
+ ewarn " * noisy or distorted sound playback"
+ ewarn " * a slowdown in harddisk performance"
+ ewarn " * system locks or instability"
+ ewarn "If you met those problems, you should not use athcool. Please use"
+ ewarn "athcool AT YOUR OWN RISK!"
+}