summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-08 10:40:24 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-08 10:40:24 +0000
commitce1ed6c115778feb69dad92ac5db7684e4f7a623 (patch)
treef76ba64b9df8dd318961b461319066a32a75e132 /sys-power/acpid
parentVersion bump wrt #379711 by Johannes Huber (diff)
downloadgentoo-2-ce1ed6c115778feb69dad92ac5db7684e4f7a623.tar.gz
gentoo-2-ce1ed6c115778feb69dad92ac5db7684e4f7a623.tar.bz2
gentoo-2-ce1ed6c115778feb69dad92ac5db7684e4f7a623.zip
Version bump.
(Portage version: 2.2.0_alpha53/cvs/Linux x86_64)
Diffstat (limited to 'sys-power/acpid')
-rw-r--r--sys-power/acpid/ChangeLog7
-rw-r--r--sys-power/acpid/acpid-2.0.12.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/sys-power/acpid/ChangeLog b/sys-power/acpid/ChangeLog
index 20f424c683e1..a70b7cf1667e 100644
--- a/sys-power/acpid/ChangeLog
+++ b/sys-power/acpid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/acpid
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.71 2011/08/05 08:47:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.72 2011/09/08 10:40:24 ssuominen Exp $
+
+*acpid-2.0.12 (08 Sep 2011)
+
+ 08 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> +acpid-2.0.12.ebuild:
+ Version bump.
05 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> acpid-2.0.11.ebuild,
files/acpid-2.0.11-init.d:
diff --git a/sys-power/acpid/acpid-2.0.12.ebuild b/sys-power/acpid/acpid-2.0.12.ebuild
new file mode 100644
index 000000000000..9dd957b3c092
--- /dev/null
+++ b/sys-power/acpid/acpid-2.0.12.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.12.ebuild,v 1.1 2011/09/08 10:40:24 ssuominen Exp $
+
+EAPI=4
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
+HOMEPAGE="http://tedfelix.com/linux/acpid-netlink.html"
+SRC_URI="http://tedfelix.com/linux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 -ppc ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/openrc-0.6.0"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.3.patch
+}
+
+src_compile() {
+ tc-export CC CPP
+ emake
+ emake -C kacpimon
+}
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR=/usr/share/doc/${PF} install
+
+ dobin kacpimon/kacpimon
+ newdoc kacpimon/README README.kacpimon
+
+ exeinto /etc/acpi
+ newexe "${FILESDIR}"/${PN}-1.0.6-default.sh default.sh
+ insinto /etc/acpi/events
+ newins "${FILESDIR}"/${PN}-1.0.4-default default
+
+ newinitd "${FILESDIR}"/${PN}-2.0.11-init.d acpid
+ newconfd "${FILESDIR}"/${PN}-1.0.6-conf.d acpid
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+ elog
+ elog "You may wish to read the Gentoo Linux Power Management Guide,"
+ elog "which can be found online at:"
+ elog "http://www.gentoo.org/doc/en/power-management-guide.xml"
+ elog
+}