summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-07 04:42:37 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-07 04:42:37 +0000
commitf904f0038084a274279b890ff66ea48ac6813795 (patch)
treeabda3ac3c5ef16497ba64f21c6b1f229359654ee /sys-libs
parentRespect LDFLAGS and fixup parameters to recvfrom(). (diff)
downloadgentoo-2-f904f0038084a274279b890ff66ea48ac6813795.tar.gz
gentoo-2-f904f0038084a274279b890ff66ea48ac6813795.tar.bz2
gentoo-2-f904f0038084a274279b890ff66ea48ac6813795.zip
make sure we only install locale symlinks in abidirs #150210
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r5.ebuild9
-rw-r--r--sys-libs/glibc/glibc-2.4-r4.ebuild9
-rw-r--r--sys-libs/glibc/glibc-2.5.ebuild9
3 files changed, 15 insertions, 12 deletions
diff --git a/sys-libs/glibc/glibc-2.3.6-r5.ebuild b/sys-libs/glibc/glibc-2.3.6-r5.ebuild
index f486d8153ec2..034813133748 100644
--- a/sys-libs/glibc/glibc-2.3.6-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r5.ebuild,v 1.4 2006/10/06 18:23:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r5.ebuild,v 1.5 2006/10/07 04:42:37 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -433,10 +433,11 @@ toolchain-glibc_src_install() {
# Make sure all the ABI's can find the locales and so we only
# have to generate one set
+ local a
keepdir /usr/$(get_libdir)/locale
- for l in $(get_all_libdirs) ; do
- if [[ ! -e ${D}/usr/${l}/locale ]] ; then
- dosym /usr/$(get_libdir)/locale /usr/${l}/locale
+ for a in $(get_install_abis) ; do
+ if [[ ! -e ${D}/usr/$(get_abi_LIBDIR ${a})/locale ]] ; then
+ dosym /usr/$(get_libdir)/locale /usr/$(get_abi_LIBDIR ${a})/locale
fi
done
diff --git a/sys-libs/glibc/glibc-2.4-r4.ebuild b/sys-libs/glibc/glibc-2.4-r4.ebuild
index cb615cedb6f9..3cdb7566ce4c 100644
--- a/sys-libs/glibc/glibc-2.4-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r4.ebuild,v 1.3 2006/10/06 16:15:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r4.ebuild,v 1.4 2006/10/07 04:42:37 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -451,10 +451,11 @@ toolchain-glibc_src_install() {
# Make sure all the ABI's can find the locales and so we only
# have to generate one set
+ local a
keepdir /usr/$(get_libdir)/locale
- for l in $(get_all_libdirs) ; do
- if [[ ! -e ${D}/usr/${l}/locale ]] ; then
- dosym /usr/$(get_libdir)/locale /usr/${l}/locale
+ for a in $(get_install_abis) ; do
+ if [[ ! -e ${D}/usr/$(get_abi_LIBDIR ${a})/locale ]] ; then
+ dosym /usr/$(get_libdir)/locale /usr/$(get_abi_LIBDIR ${a})/locale
fi
done
diff --git a/sys-libs/glibc/glibc-2.5.ebuild b/sys-libs/glibc/glibc-2.5.ebuild
index f9fbfad31882..306533d5f20a 100644
--- a/sys-libs/glibc/glibc-2.5.ebuild
+++ b/sys-libs/glibc/glibc-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.5.ebuild,v 1.3 2006/10/06 17:20:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.5.ebuild,v 1.4 2006/10/07 04:42:37 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -352,10 +352,11 @@ toolchain-glibc_src_install() {
# Make sure all the ABI's can find the locales and so we only
# have to generate one set
+ local a
keepdir /usr/$(get_libdir)/locale
- for l in $(get_all_libdirs) ; do
- if [[ ! -e ${D}/usr/${l}/locale ]] ; then
- dosym /usr/$(get_libdir)/locale /usr/${l}/locale
+ for a in $(get_install_abis) ; do
+ if [[ ! -e ${D}/usr/$(get_abi_LIBDIR ${a})/locale ]] ; then
+ dosym /usr/$(get_libdir)/locale /usr/$(get_abi_LIBDIR ${a})/locale
fi
done