summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-11-24 02:34:45 +0000
committerTim Harder <radhermit@gentoo.org>2012-11-24 02:34:45 +0000
commiteea1f08be7ce2c4902998977000071f945041f05 (patch)
tree5a91fa3897edac69b6514e2a0b7464949f91ec62 /sys-libs
parentstable arm, bug #421621 (diff)
downloadgentoo-2-eea1f08be7ce2c4902998977000071f945041f05.tar.gz
gentoo-2-eea1f08be7ce2c4902998977000071f945041f05.tar.bz2
gentoo-2-eea1f08be7ce2c4902998977000071f945041f05.zip
Version bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcap-ng/ChangeLog7
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.7.3.ebuild114
2 files changed, 120 insertions, 1 deletions
diff --git a/sys-libs/libcap-ng/ChangeLog b/sys-libs/libcap-ng/ChangeLog
index 3d496c799c3f..39fb047cd3ab 100644
--- a/sys-libs/libcap-ng/ChangeLog
+++ b/sys-libs/libcap-ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libcap-ng
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.51 2012/11/02 22:25:37 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.52 2012/11/24 02:34:45 radhermit Exp $
+
+*libcap-ng-0.7.3 (24 Nov 2012)
+
+ 24 Nov 2012; Tim Harder <radhermit@gentoo.org> +libcap-ng-0.7.3.ebuild:
+ Version bump.
02 Nov 2012; Tim Harder <radhermit@gentoo.org> libcap-ng-0.7.1.ebuild:
Drop unused sys-apps/attr dep as noted by Arfrever.
diff --git a/sys-libs/libcap-ng/libcap-ng-0.7.3.ebuild b/sys-libs/libcap-ng/libcap-ng-0.7.3.ebuild
new file mode 100644
index 000000000000..74c041d5dce2
--- /dev/null
+++ b/sys-libs/libcap-ng/libcap-ng-0.7.3.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/libcap-ng-0.7.3.ebuild,v 1.1 2012/11/24 02:34:45 radhermit Exp $
+
+EAPI=5
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython *-pypy-*"
+
+inherit autotools flag-o-matic python
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="http://people.redhat.com/sgrubb/libcap-ng/"
+SRC_URI="http://people.redhat.com/sgrubb/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="python static-libs"
+
+RDEPEND="python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ python? ( >=dev-lang/swig-2 )"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ # Disable byte-compilation of Python modules.
+ >py-compile
+
+ # Python bindings are built/tested/installed manually.
+ sed -i -e "/^SUBDIRS/s/ python//" bindings/Makefile.am || die
+
+ eautoreconf
+
+ use sparc && replace-flags -O? -O0
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with python)
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources bindings/python
+
+ building() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir bindings/python building
+ fi
+}
+
+src_test() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ ewarn "Skipping tests due to root permissions."
+ return
+ fi
+
+ default
+
+ if use python; then
+ testing() {
+ emake \
+ PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ TESTS_ENVIRONMENT="PYTHONPATH=..:../.libs" \
+ check
+ }
+ python_execute_function -s --source-dir bindings/python testing
+ fi
+}
+
+src_install() {
+ default
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir bindings/python installation
+
+ python_clean_installation_image
+ fi
+
+ rm -f "${ED}"/usr/lib*/${PN}.la
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize capng.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup capng.py
+}