summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-10 03:35:22 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-10 03:35:22 +0000
commited0c343de9bcf02213f7d3692740d21c82f27278 (patch)
tree249cef5bc7c09d5161ea7b18c6ce4b9b385b0e70 /sys-libs
parentonly copy over /lib/udev/devices/* if /lib/udev/devices actually exists (diff)
downloadgentoo-2-ed0c343de9bcf02213f7d3692740d21c82f27278.tar.gz
gentoo-2-ed0c343de9bcf02213f7d3692740d21c82f27278.tar.bz2
gentoo-2-ed0c343de9bcf02213f7d3692740d21c82f27278.zip
fixup sysroot support
(Portage version: 2.1_pre7-r4)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/files/digest-glibc-2.4-r26
-rw-r--r--sys-libs/glibc/glibc-2.4-r2.ebuild50
2 files changed, 32 insertions, 24 deletions
diff --git a/sys-libs/glibc/files/digest-glibc-2.4-r2 b/sys-libs/glibc/files/digest-glibc-2.4-r2
index 4f7eec372a7c..f83962d074e8 100644
--- a/sys-libs/glibc/files/digest-glibc-2.4-r2
+++ b/sys-libs/glibc/files/digest-glibc-2.4-r2
@@ -1,6 +1,6 @@
-MD5 8c9956204abd53f2c10d2a33deb7cda9 glibc-2.4-patches-1.4.tar.bz2 108500
-RMD160 2fbb84e5c329508128b78773b835136941d51c2f glibc-2.4-patches-1.4.tar.bz2 108500
-SHA256 c921c90dd78d610f5948a8c0affd963551406bac1ec6f53270ce57fa7dea3287 glibc-2.4-patches-1.4.tar.bz2 108500
+MD5 d13dd8f943863027c9ad571bf0f3d13a glibc-2.4-patches-1.5.tar.bz2 108453
+RMD160 d34eb5fa2bae324390aedb72979111505b00d61a glibc-2.4-patches-1.5.tar.bz2 108453
+SHA256 35b0bf1038e72b05d4683eed3f340430ed4044273dc7733d2f6c9f92ace5b9e6 glibc-2.4-patches-1.5.tar.bz2 108453
MD5 7e9a88dcd41fbc53801dbe5bdacaf245 glibc-2.4.tar.bz2 15202445
RMD160 ee2712a0e6fab8e086958c1f23221f8d07af3de1 glibc-2.4.tar.bz2 15202445
SHA256 27aaaaa78b4ab5da76bb29385dc9be087ba7b855a9102eaaa78ce3ec5e2e7fcd glibc-2.4.tar.bz2 15202445
diff --git a/sys-libs/glibc/glibc-2.4-r2.ebuild b/sys-libs/glibc/glibc-2.4-r2.ebuild
index 4265c74652e6..8d228f336cdf 100644
--- a/sys-libs/glibc/glibc-2.4-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r2.ebuild,v 1.3 2006/04/02 23:02:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r2.ebuild,v 1.4 2006/04/10 03:35:22 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -27,7 +27,7 @@ GLIBC_MANPAGE_VERSION="none"
GLIBC_INFOPAGE_VERSION="none"
# Gentoo patchset
-PATCH_VER="1.4"
+PATCH_VER="1.5"
# Fedora addons (like c_stubs)
# sniped from RHEL's glibc-2.4-4.src.rpm
@@ -327,28 +327,28 @@ toolchain-glibc_src_install() {
MYMAINBUILDDIR=build-${ABI}-${CTARGET}-nptl
fi
+ local install_root=${D}
+ if is_crosscompile ; then
+ install_root="${install_root}/usr/${CTARGET}"
+ fi
if want_linuxthreads ; then
cd "${WORKDIR}"/build-${ABI}-${CTARGET}-linuxthreads
einfo "Installing GLIBC ${ABI} with linuxthreads ..."
make PARALLELMFLAGS="${MAKEOPTS} -j1" \
- install_root="${D}" \
+ install_root="${install_root}" \
install || die
else
cd "${WORKDIR}"/build-${ABI}-${CTARGET}-nptl
einfo "Installing GLIBC ${ABI} with NPTL ..."
make PARALLELMFLAGS="${MAKEOPTS} -j1" \
- install_root="${D}" \
+ install_root="${install_root}" \
install || die
fi
if is_crosscompile ; then
# punt all the junk not needed by a cross-compiler
- rm -rf "${D}"/{,usr/}{bin,etc,sbin,share} "${D}"/usr/*/*/{gconv,misc}
- else
- # zoneinfo stuff is now provided by the timezone-data package
- rm -rf "${D}"/usr/share/zoneinfo
- rm -f "${D}"/usr/bin/tzselect
- rm -f "${D}"/usr/sbin/{zic,zdump}
+ cd "${D}"/usr/${CTARGET} || die
+ rm -rf ./{,usr/}{bin,etc,sbin,share} ./{,usr/}*/{gconv,misc}
fi
if want_linuxthreads && want_nptl ; then
@@ -407,8 +407,18 @@ toolchain-glibc_src_install() {
# a 2nd stage cross-compiler, gcc finds the target system
# headers correctly. See gcc/doc/gccinstall.info
if is_crosscompile ; then
- dosym include /usr/${CTARGET}/sys-include
- dosym . /usr/${CTARGET}/usr
+ dosym usr/include /usr/${CTARGET}/sys-include
+
+ # When cross-compiling for a non-multilib setup, make sure we have
+ # lib and a proper symlink setup
+ if ! use multilib && [[ $(get_libdir) != "lib" ]] ; then
+ cd "${D}"$(alt_libdir)/..
+ mv $(get_libdir) lib || die
+ ln -s lib $(get_libdir) || die
+ cd "${D}"$(alt_usrlibdir)/..
+ mv $(get_libdir) lib || die
+ ln -s lib $(get_libdir) || die
+ fi
return 0
fi
@@ -501,8 +511,7 @@ toolchain-glibc_headers_install() {
# Make sure we install the sys-include symlink so that when
# we build a 2nd stage cross-compiler, gcc finds the target
# system headers correctly. See gcc/doc/gccinstall.info
- dosym include /usr/${CTARGET}/sys-include
- dosym . /usr/${CTARGET}/usr
+ dosym usr/include /usr/${CTARGET}/sys-include
}
toolchain-glibc_pkg_postinst() {
@@ -571,7 +580,7 @@ toolchain-glibc_pkg_postinst() {
alt_headers() {
if [[ -z ${ALT_HEADERS} ]] ; then
if is_crosscompile ; then
- ALT_HEADERS="/usr/${CTARGET}/include"
+ ALT_HEADERS="/usr/${CTARGET}/usr/include"
else
ALT_HEADERS="/usr/include"
fi
@@ -596,7 +605,7 @@ alt_libdir() {
alt_usrlibdir() {
if is_crosscompile ; then
- echo /usr/${CTARGET}/$(get_libdir)
+ echo /usr/${CTARGET}/usr/$(get_libdir)
else
echo /usr/$(get_libdir)
fi
@@ -929,16 +938,15 @@ glibc_do_configure() {
--without-gd
--with-headers=$(alt_build_headers)
--prefix=/usr
- --includedir=$(alt_headers)
- --libdir=$(alt_usrlibdir)
+ --libdir=/usr/$(get_libdir)
--mandir=/usr/share/man
--infodir=/usr/share/info
- --libexecdir=$(alt_usrlibdir)/misc/glibc
+ --libexecdir=/usr/$(get_libdir)/misc/glibc
${EXTRA_ECONF}"
# There is no configure option for this and we need to export it
# since the glibc build will re-run configure on itself
- export libc_cv_slibdir=$(alt_libdir)
+ export libc_cv_slibdir=/$(get_libdir)
has_version app-admin/eselect-compiler || export CC="$(tc-getCC ${CTARGET})"
@@ -1082,7 +1090,7 @@ pkg_setup() {
die "nptlonly without nptl"
fi
- if ! type -p scanelf ; then
+ if ! type -p scanelf > /dev/null ; then
eerror "You do not have pax-utils installed."
die "install pax-utils"
fi