summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-03-20 19:39:55 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-03-20 19:39:55 +0000
commite5de6ba6434af59bb002b3ee609eec3c1e5662fa (patch)
tree8a06efebb0d799f670c4749ff753e1adf5cb3687 /sys-libs
parentstyle fix: change `...` to $(...) (diff)
downloadgentoo-2-e5de6ba6434af59bb002b3ee609eec3c1e5662fa.tar.gz
gentoo-2-e5de6ba6434af59bb002b3ee609eec3c1e5662fa.tar.bz2
gentoo-2-e5de6ba6434af59bb002b3ee609eec3c1e5662fa.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/musl/ChangeLog7
-rw-r--r--sys-libs/musl/musl-1.0.0.ebuild101
2 files changed, 107 insertions, 1 deletions
diff --git a/sys-libs/musl/ChangeLog b/sys-libs/musl/ChangeLog
index 557646fb08d8..203d68d09fcb 100644
--- a/sys-libs/musl/ChangeLog
+++ b/sys-libs/musl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/musl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.18 2014/03/10 20:27:04 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.19 2014/03/20 19:39:55 blueness Exp $
+
+*musl-1.0.0 (20 Mar 2014)
+
+ 20 Mar 2014; Anthony G. Basile <blueness@gentoo.org> +musl-1.0.0.ebuild:
+ Version bump
10 Mar 2014; Anthony G. Basile <blueness@gentoo.org> musl-0.9.15.ebuild,
musl-9999.ebuild:
diff --git a/sys-libs/musl/musl-1.0.0.ebuild b/sys-libs/musl/musl-1.0.0.ebuild
new file mode 100644
index 000000000000..60b924e3231b
--- /dev/null
+++ b/sys-libs/musl/musl-1.0.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/musl-1.0.0.ebuild,v 1.1 2014/03/20 19:39:55 blueness Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.musl-libc.org/musl"
+ inherit git-2
+fi
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+DESCRIPTION="Lightweight, fast and simple C library focused on standards-conformance and safety"
+HOMEPAGE="http://www.musl-libc.org/"
+if [[ ${PV} != "9999" ]] ; then
+ PATCH_VER=""
+ SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
+ KEYWORDS="-* ~amd64 ~arm ~mips ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="crosscompile_opts_headers-only nls"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ RDEPEND+=" sys-apps/getent"
+fi
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+
+just_headers() {
+ use crosscompile_opts_headers-only && is_crosscompile
+}
+
+pkg_setup() {
+ if [ ${CTARGET} == ${CHOST} ] ; then
+ case ${CHOST} in
+ *-musl*) ;;
+ *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
+ esac
+ fi
+}
+
+src_configure() {
+ tc-export CC
+
+ ./configure \
+ --target="${CTARGET}" \
+ --prefix="/usr" \
+ --disable-gcc-wrapper
+}
+
+src_compile() {
+ emake include/bits/alltypes.h || die
+ just_headers && return 0
+
+ emake || die
+}
+
+src_install() {
+ local sysroot=${D}
+ is_crosscompile && sysroot+="/usr/${CTARGET}"
+
+ local target="install"
+ just_headers && target="install-headers"
+ emake DESTDIR="${sysroot}" ${target} || die
+
+ # Make sure we install the sys-include symlink so that when
+ # we build a 2nd stage cross-compiler, gcc finds the target
+ # system headers correctly. See gcc/doc/gccinstall.info
+ if is_crosscompile ; then
+ dosym usr/include /usr/${CTARGET}/sys-include
+ fi
+
+ # If we are going to use gnu's gettext then we have to
+ # move musl's libintl out of the way.
+ use nls && mv "${D}"/usr/include/libintl{,-musl}.h
+}
+
+pkg_postinst() {
+ is_crosscompile && return 0
+
+ [ "${ROOT}" != "/" ] && return 0
+
+ # TODO: musl doesn't use ldconfig, instead here we can
+ # create sym links to libraries outside of /lib and /usr/lib
+ ldconfig
+ # reload init ...
+ /sbin/telinit U 2>/dev/null
+}