summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-05-19 00:43:19 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-05-19 00:43:19 +0000
commitddb362042489aff2bd651e755f4334bfc97ba7a4 (patch)
tree480e216c36c57104d5ec9038bf07359cf467466a /sys-libs
parentfix gcc-3.3 issues, bug #21213 (diff)
downloadgentoo-2-ddb362042489aff2bd651e755f4334bfc97ba7a4.tar.gz
gentoo-2-ddb362042489aff2bd651e755f4334bfc97ba7a4.tar.bz2
gentoo-2-ddb362042489aff2bd651e755f4334bfc97ba7a4.zip
Removing some gcc hardcodes, using ${CC:-gcc} instead.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/pam/ChangeLog5
-rw-r--r--sys-libs/pam/pam-0.75-r11.ebuild17
-rw-r--r--sys-libs/pwdb/ChangeLog5
-rw-r--r--sys-libs/pwdb/pwdb-0.61-r4.ebuild5
-rw-r--r--sys-libs/slang/ChangeLog5
-rw-r--r--sys-libs/slang/slang-1.4.5-r2.ebuild6
6 files changed, 34 insertions, 9 deletions
diff --git a/sys-libs/pam/ChangeLog b/sys-libs/pam/ChangeLog
index aa703707ab96..4bd34676d102 100644
--- a/sys-libs/pam/ChangeLog
+++ b/sys-libs/pam/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/pam
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/ChangeLog,v 1.27 2003/03/15 17:13:12 tuxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/ChangeLog,v 1.28 2003/05/19 00:43:19 taviso Exp $
+
+ 18 May 2003; Tavis Ormandy <taviso@gentoo.org> pam-0.75-r11.ebuild:
+ If glib was compiled with ccc, we need -lots.
20 Feb 2003; Zach Welch <zwelch@gentoo.org> pam-0.75-r11.ebuild :
Added arm to keywords.
diff --git a/sys-libs/pam/pam-0.75-r11.ebuild b/sys-libs/pam/pam-0.75-r11.ebuild
index 861d9f8bdad7..faf5827a29c1 100644
--- a/sys-libs/pam/pam-0.75-r11.ebuild
+++ b/sys-libs/pam/pam-0.75-r11.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r11.ebuild,v 1.8 2003/03/15 17:13:12 tuxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r11.ebuild,v 1.9 2003/05/19 00:43:19 taviso Exp $
IUSE="berkdb"
-inherit gcc eutils
+inherit gcc eutils flag-o-matic
PATCH_LEVEL=""
@@ -63,6 +63,17 @@ src_unpack() {
src_compile() {
export CFLAGS="${CFLAGS} -fPIC"
+ if [ "${ARCH}" = "alpha" ]; then
+ if [ -f /usr/lib/libots.so -a ! -f /usr/lib/libglib.so -a /usr/lib/libglib.a ]; then
+ # should be LDFLAGS, but this configure is screwy.
+ einfo "looks like you compiled glib with ccc, i need to append -lots..."
+ einfo "Dont worry if i've got this wrong, PAM will still build correctly..."
+ append-flags -lots
+ cp ${S}/modules/pam_pwdb/Makefile ${S}/modules/pam_pwdb/Makefile.orig
+ sed -e 's/$(CC) -o/$(CC) -lots -o/g' ${S}/modules/pam_pwdb/Makefile.orig > \
+ ${S}/modules/pam_pwdb/Makefile
+ fi
+ fi
./configure --host=${CHOST} \
--prefix=/ \
@@ -107,7 +118,7 @@ src_install() {
# Make sure every module built.
# Do not remove this, as some module can fail to build
# and effectively lock the user out of his system.
- einfo "Checking if all modules was build..."
+ einfo "Checking if all modules were built..."
for x in ${S}/modules/pam_*
do
if [ -d ${x} ]
diff --git a/sys-libs/pwdb/ChangeLog b/sys-libs/pwdb/ChangeLog
index 8b67649c8089..0343a0077101 100644
--- a/sys-libs/pwdb/ChangeLog
+++ b/sys-libs/pwdb/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/pwdb
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/ChangeLog,v 1.13 2003/03/24 13:26:09 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/ChangeLog,v 1.14 2003/05/19 00:43:19 taviso Exp $
+
+ 18 May 2003; Tavis Ormandy <taviso@gentoo.org> pwdb-0.61-r4.ebuild:
+ stop gcc being hardcoded.
24 Mar 2003; Guy Martin <gmsoft@gentoo.org> pwdb-0.61-r4.ebuild, pwdb-0.61-hppa.patch :
Added patch to fix linking under some circumstances on hppa.
diff --git a/sys-libs/pwdb/pwdb-0.61-r4.ebuild b/sys-libs/pwdb/pwdb-0.61-r4.ebuild
index e7ba4bf9408c..ed4f32614c62 100644
--- a/sys-libs/pwdb/pwdb-0.61-r4.ebuild
+++ b/sys-libs/pwdb/pwdb-0.61-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/pwdb-0.61-r4.ebuild,v 1.8 2003/03/24 13:26:09 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/pwdb-0.61-r4.ebuild,v 1.9 2003/05/19 00:43:19 taviso Exp $
inherit eutils
@@ -25,9 +25,10 @@ src_unpack () {
src_compile() {
cp Makefile Makefile.orig
+ cp default.defs default.defs.orig
sed -e "s/^DIRS = .*/DIRS = libpwdb/" -e "s:EXTRAS += :EXTRAS += ${CFLAGS} :" \
Makefile.orig > Makefile
-
+ sed -e "s/=gcc/=${CC:-gcc}/g" default.defs.orig > default.defs
emake || die
}
diff --git a/sys-libs/slang/ChangeLog b/sys-libs/slang/ChangeLog
index f0f4496cf590..7a050027a6db 100644
--- a/sys-libs/slang/ChangeLog
+++ b/sys-libs/slang/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/slang
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.13 2003/03/16 18:01:09 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.14 2003/05/19 00:43:19 taviso Exp $
+
+ 18 May 2003; Tavis Ormandy <taviso@gentoo.org> slang-1.4.5-r2.ebuild:
+ removing hardcoded compiler.
*slang-1.4.8 (22 Feb 2003)
diff --git a/sys-libs/slang/slang-1.4.5-r2.ebuild b/sys-libs/slang/slang-1.4.5-r2.ebuild
index 3493cdee7c22..10af7b63e3c8 100644
--- a/sys-libs/slang/slang-1.4.5-r2.ebuild
+++ b/sys-libs/slang/slang-1.4.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.5-r2.ebuild,v 1.16 2003/02/28 13:18:14 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.5-r2.ebuild,v 1.17 2003/05/19 00:43:19 taviso Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Console display library used by most text viewer"
@@ -13,6 +13,10 @@ HOMEPAGE="http://space.mit.edu/~davis/slang/"
DEPEND=">=sys-libs/ncurses-5.2-r2"
src_compile() {
+ # remove hardcoded compilers
+ cp configure configure.orig
+ sed -e "s:=\"gcc:=\"${CC:-gcc}:" \
+ configure.orig > configure
./configure \
--host=${CHOST} \
--prefix=/usr || die "./configure failed"