summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-05-02 05:40:16 +0000
committerMike Frysinger <vapier@gentoo.org>2007-05-02 05:40:16 +0000
commitdbaf9f5002aecda95892256406439773f4647755 (patch)
treec61e82aedf76672bd1f510cf1c9bd620d4d51651 /sys-libs
parentold (diff)
downloadgentoo-2-dbaf9f5002aecda95892256406439773f4647755.tar.gz
gentoo-2-dbaf9f5002aecda95892256406439773f4647755.tar.bz2
gentoo-2-dbaf9f5002aecda95892256406439773f4647755.zip
Version bump.
(Portage version: 2.1.2.5)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/ChangeLog7
-rw-r--r--sys-libs/readline/files/digest-readline-5.2_p415
-rw-r--r--sys-libs/readline/readline-5.2_p4.ebuild101
3 files changed, 122 insertions, 1 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index 12286e07db27..a924e5ee8616 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/readline
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.90 2007/04/24 14:45:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.91 2007/05/02 05:40:16 vapier Exp $
+
+*readline-5.2_p4 (02 May 2007)
+
+ 02 May 2007; Mike Frysinger <vapier@gentoo.org> +readline-5.2_p4.ebuild:
+ Version bump.
24 Apr 2007; Raúl Porcel <armin76@gentoo.org> readline-5.2_p2.ebuild:
ia64 + x86 stable
diff --git a/sys-libs/readline/files/digest-readline-5.2_p4 b/sys-libs/readline/files/digest-readline-5.2_p4
new file mode 100644
index 000000000000..9ce8adc28ae9
--- /dev/null
+++ b/sys-libs/readline/files/digest-readline-5.2_p4
@@ -0,0 +1,15 @@
+MD5 e39331f32ad14009b9ff49cc10c5e751 readline-5.2.tar.gz 2037705
+RMD160 983cbb25192e0a376b80cb2428fe8ee254a041c7 readline-5.2.tar.gz 2037705
+SHA256 12e88d96aee2cd1192500356f0535540db499282ca7f76339fb4228c31249f45 readline-5.2.tar.gz 2037705
+MD5 9d4d41622aa9b230c57f68548ce87d8f readline52-001 874
+RMD160 0cedb82ccc4709e6b39e6cb95143131259b0e7c5 readline52-001 874
+SHA256 eac304c369154059f93049ada328739faaf40338d3cb1fb4b544c93d5ce3f8d5 readline52-001 874
+MD5 f03e512d14206e37f7d6a748b56b9476 readline52-002 1433
+RMD160 c9bbff4b1ba2ff77e5a43ad98a94f4753e5f0aa3 readline52-002 1433
+SHA256 9deacaef25507a0c2ae0b661bf9342559b59a2954d66ea3c5f5bcd900fdfcf78 readline52-002 1433
+MD5 252b42d8750f1a94b6bdf086612dceb2 readline52-003 1204
+RMD160 4007b1dcd19d204f6ce75fe5a60a5c780f221a12 readline52-003 1204
+SHA256 2a55d2ecb1c9b0147aeb193a6323616ab31c1c525a83b2db3a994b15594ba934 readline52-003 1204
+MD5 a32333c2e603a3ed250514e91050e552 readline52-004 2192
+RMD160 7c8ef28a2d4fb6054aa84e0abfbdff0d446c0c90 readline52-004 2192
+SHA256 a03b65633781efa7c3aae5d57162985e7b7a3c10acf0f2621be610e16f27e5f2 readline52-004 2192
diff --git a/sys-libs/readline/readline-5.2_p4.ebuild b/sys-libs/readline/readline-5.2_p4.ebuild
new file mode 100644
index 000000000000..83927e290ea7
--- /dev/null
+++ b/sys-libs/readline/readline-5.2_p4.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.2_p4.ebuild,v 1.1 2007/05/02 05:40:16 vapier Exp $
+
+inherit eutils multilib toolchain-funcs flag-o-matic
+
+# Official patches
+# See ftp://ftp.cwru.edu/pub/bash/readline-5.1-patches/
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Another cute console display library"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+SRC_URI="mirror://gnu/readline/${MY_P}.tar.gz
+ $(for ((i=1; i<=PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${MY_PV} ${MY_PV/\.} ${i}
+ printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${MY_PV} ${MY_PV/\.} ${i}
+ done)"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+# We must be certain that we have a bash that is linked
+# to its internal readline, else we may get problems.
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-2.05b-r2"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ cd "${S}"
+ # Official patches
+ local i
+ for ((i=1; i<=PLEVEL; i++)); do
+ epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
+ done
+ epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
+ epatch "${FILESDIR}"/${PN}-5.2-rlfe-build.patch #151174
+ epatch "${FILESDIR}"/${PN}-5.1-rlfe-uclibc.patch
+ epatch "${FILESDIR}"/${PN}-5.1-fbsd-pic.patch
+
+ ln -s ../.. examples/rlfe/readline
+
+ # force ncurses linking #71420
+ sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
+}
+
+src_compile() {
+ append-flags -D_GNU_SOURCE
+
+ # the --libdir= is needed because if lib64 is a directory, it will default
+ # to using that... even if CONF_LIBDIR isnt set or we're using a version
+ # of portage without CONF_LIBDIR support.
+ econf --with-curses --libdir=/usr/$(get_libdir) || die
+ emake || die
+
+ if ! tc-is-cross-compiler; then
+ cd examples/rlfe
+ econf || die
+ emake || die "make rlfe failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodir /$(get_libdir)
+
+ if ! use userland_Darwin ; then
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ chmod a+rx "${D}"/$(get_libdir)/*.so*
+
+ # Bug #4411
+ gen_usr_ldscript libreadline.so
+ gen_usr_ldscript libhistory.so
+ fi
+
+ if ! tc-is-cross-compiler; then
+ dobin examples/rlfe/rlfe || die
+ fi
+
+ dodoc CHANGELOG CHANGES README USAGE NEWS
+ docinto ps
+ dodoc doc/*.ps
+ dohtml -r doc
+}
+
+pkg_preinst() {
+ preserve_old_lib /$(get_libdir)/lib{history,readline}.so.4 #29865
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.4
+}