summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2012-03-31 11:03:18 +0000
committerSven Vermeulen <swift@gentoo.org>2012-03-31 11:03:18 +0000
commitd15030640c2508e1b55baf34f34982caae010dcc (patch)
tree203260b4a694710b4662a0d4219d8adab27080d4 /sys-libs
parentUpdating SELinux userspace utilities to support pending 2.20120215 policies (diff)
downloadgentoo-2-d15030640c2508e1b55baf34f34982caae010dcc.tar.gz
gentoo-2-d15030640c2508e1b55baf34f34982caae010dcc.tar.bz2
gentoo-2-d15030640c2508e1b55baf34f34982caae010dcc.zip
Updating SELinux userspace utilities to support pending 2.20120215 policies
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libsepol/ChangeLog10
-rw-r--r--sys-libs/libsepol/files/libsepol-2.1.4-fix_role_fix_callback.patch15
-rw-r--r--sys-libs/libsepol/libsepol-2.1.4-r1.ebuild40
3 files changed, 63 insertions, 2 deletions
diff --git a/sys-libs/libsepol/ChangeLog b/sys-libs/libsepol/ChangeLog
index 9be0a1f062e6..12f5b00baf77 100644
--- a/sys-libs/libsepol/ChangeLog
+++ b/sys-libs/libsepol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libsepol
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.45 2011/11/12 18:11:13 swift Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.46 2012/03/31 11:03:18 swift Exp $
+
+*libsepol-2.1.4-r1 (31 Mar 2012)
+
+ 31 Mar 2012; <swift@gentoo.org> +libsepol-2.1.4-r1.ebuild,
+ +files/libsepol-2.1.4-fix_role_fix_callback.patch:
+ Bump to version 2.1.4
12 Nov 2011; <swift@gentoo.org> -libsepol-2.0.41.ebuild,
-libsepol-2.0.42.ebuild:
diff --git a/sys-libs/libsepol/files/libsepol-2.1.4-fix_role_fix_callback.patch b/sys-libs/libsepol/files/libsepol-2.1.4-fix_role_fix_callback.patch
new file mode 100644
index 000000000000..256cc52090f3
--- /dev/null
+++ b/sys-libs/libsepol/files/libsepol-2.1.4-fix_role_fix_callback.patch
@@ -0,0 +1,15 @@
+diff -uNr libsepol-2.1.4.orig/src/expand.c libsepol-2.1.4-fix_role_fix_callback/src/expand.c
+--- libsepol-2.1.4.orig/src/expand.c 2012-02-25 14:34:37.408341044 +0100
++++ libsepol-2.1.4-fix_role_fix_callback/src/expand.c 2012-02-25 14:35:58.345341216 +0100
+@@ -688,6 +688,11 @@
+ return 0;
+ }
+
++ if (!is_id_enabled(id, state->base, SYM_ROLES)) {
++ /* Identifiers scope is not enabled */
++ return 0;
++ }
++
+ if (role->flavor != ROLE_ATTRIB)
+ return 0;
+
diff --git a/sys-libs/libsepol/libsepol-2.1.4-r1.ebuild b/sys-libs/libsepol/libsepol-2.1.4-r1.ebuild
new file mode 100644
index 000000000000..2fd091887b0c
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.1.4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.1.4-r1.ebuild,v 1.1 2012/03/31 11:03:18 swift Exp $
+
+EAPI="2"
+
+inherit multilib toolchain-funcs eutils
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20120216/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib SHLIBDIR failed."
+ epatch "${FILESDIR}/libsepol-2.1.4-fix_role_fix_callback.patch"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}