summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2011-01-03 19:45:20 +0000
committerVictor Ostorga <vostorga@gentoo.org>2011-01-03 19:45:20 +0000
commitcd2e2174fd13a362b7d8a7a1d7fed056c6edac93 (patch)
treed0f4c079c415d84576b572e9a31bab59b969af70 /sys-libs
parentx86 stable wrt bug #349887 (diff)
downloadgentoo-2-cd2e2174fd13a362b7d8a7a1d7fed056c6edac93.tar.gz
gentoo-2-cd2e2174fd13a362b7d8a7a1d7fed056c6edac93.tar.bz2
gentoo-2-cd2e2174fd13a362b7d8a7a1d7fed056c6edac93.zip
Version bump to 1.2.7 bug #350464
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/tdb/ChangeLog9
-rw-r--r--sys-libs/tdb/tdb-1.2.7.ebuild92
2 files changed, 99 insertions, 2 deletions
diff --git a/sys-libs/tdb/ChangeLog b/sys-libs/tdb/ChangeLog
index c02f9c83a5ce..73114d2e607a 100644
--- a/sys-libs/tdb/ChangeLog
+++ b/sys-libs/tdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/tdb
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.24 2010/12/29 21:36:14 vostorga Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.25 2011/01/03 19:45:20 vostorga Exp $
+
+*tdb-1.2.7 (03 Jan 2011)
+
+ 03 Jan 2011; Víctor Ostorga <vostorga@gentoo.org> +tdb-1.2.7.ebuild:
+ Version bump to 1.2.7 bug #350464
29 Dec 2010; Víctor Ostorga <vostorga@gentoo.org> tdb-1.2.1-r1.ebuild:
Improving python related code, patch thanks to Arfrever Frehtes Taifersar
diff --git a/sys-libs/tdb/tdb-1.2.7.ebuild b/sys-libs/tdb/tdb-1.2.7.ebuild
new file mode 100644
index 000000000000..a0f9121f3ef5
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.2.7.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.7.ebuild,v 1.1 2011/01/03 19:45:20 vostorga Exp $
+
+EAPI="2"
+PYTHON_DEPEND="python? 2"
+
+inherit autotools python
+
+DESCRIPTION="Samba tdb"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="python static-libs tools tdbtest"
+
+RDEPEND=""
+DEPEND="!<net-fs/samba-3.3
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-libs/popt"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ eautoconf -Ilib/replace
+ sed -i \
+ -e 's:$(SHLD_FLAGS) :$(SHLD_FLAGS) $(LDFLAGS) :' \
+ {Makefile.in,tdb.mk} || die "sed failed"
+
+ # xsltproc will display a warning but we can assume the xml files are valid
+ sed -i \
+ -e 's|$(XSLTPROC) -o|$(XSLTPROC) --nonet -o|' \
+ tdb.mk || die "sed failed"
+}
+
+src_configure() {
+ local myconf=()
+
+ if use python; then
+ myconf+=(
+ PYTHON_CONFIG="${EPREFIX}/usr/bin/python-config-$(python_get_version)"
+ PYTHON="$(PYTHON -a)"
+ )
+ fi
+
+ econf \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ $(use_enable python) \
+ "${myconf[@]}"
+}
+
+src_compile() {
+ # TODO:
+ # - don't build static-libs in case of USE=-static-libs
+
+ # we create the directories first to avoid workaround parallel build problem
+ emake dirs || die "emake dirs failed"
+
+ emake shared-build || die "emake shared-build failed"
+
+ if use tdbtest ; then
+ emake bin/tdbtest || die "emake tdbtest failed"
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ # installs a necessary symlink
+ dolib.so sharedbuild/lib/libtdb.so
+
+ dodoc docs/README
+
+ use static-libs || rm -f "${D}"/usr/lib*/*.a
+ use tools || rm -rf "${D}/usr/bin" "${D}/usr/share/man"
+ use tdbtest && dobin bin/tdbtest
+ use python && python_need_rebuild
+}
+
+src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check || die "emake check failed"
+}