summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-05-28 14:03:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-05-28 14:03:08 +0000
commitcae3d5c2986967fe9372c80bc24a7434302f72aa (patch)
treeb4a4eb374a15b1b81edcba053cfe3d53aaeedcc3 /sys-libs
parentStable for x86, wrt bug #417979 (diff)
downloadgentoo-2-cae3d5c2986967fe9372c80bc24a7434302f72aa.tar.gz
gentoo-2-cae3d5c2986967fe9372c80bc24a7434302f72aa.tar.bz2
gentoo-2-cae3d5c2986967fe9372c80bc24a7434302f72aa.zip
new snapshot built against libcxxrt
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxx/ChangeLog8
-rw-r--r--sys-libs/libcxx/libcxx-0.0_p20120528.ebuild (renamed from sys-libs/libcxx/libcxx-0.0_p20120523.ebuild)10
2 files changed, 13 insertions, 5 deletions
diff --git a/sys-libs/libcxx/ChangeLog b/sys-libs/libcxx/ChangeLog
index 4b1f7a0a6c3a..01e1a1456c1e 100644
--- a/sys-libs/libcxx/ChangeLog
+++ b/sys-libs/libcxx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libcxx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.2 2012/05/28 13:59:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.3 2012/05/28 14:03:08 aballier Exp $
+
+*libcxx-0.0_p20120528 (28 May 2012)
+
+ 28 May 2012; Alexis Ballier <aballier@gentoo.org>
+ -libcxx-0.0_p20120523.ebuild, +libcxx-0.0_p20120528.ebuild:
+ new snapshot built against libcxxrt
28 May 2012; Alexis Ballier <aballier@gentoo.org> libcxx-9999.ebuild,
+files/cxxrt.patch:
diff --git a/sys-libs/libcxx/libcxx-0.0_p20120523.ebuild b/sys-libs/libcxx/libcxx-0.0_p20120528.ebuild
index f3c047c6b3c1..7d61fc1bdfb3 100644
--- a/sys-libs/libcxx/libcxx-0.0_p20120523.ebuild
+++ b/sys-libs/libcxx/libcxx-0.0_p20120528.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-0.0_p20120523.ebuild,v 1.1 2012/05/24 03:01:42 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-0.0_p20120528.ebuild,v 1.1 2012/05/28 14:03:08 aballier Exp $
EAPI=4
@@ -8,7 +8,7 @@ ESVN_REPO_URI="http://llvm.org/svn/llvm-project/libcxx/trunk"
[ "${PV%9999}" != "${PV}" ] && SCM="subversion" || SCM=""
-inherit cmake-utils ${SCM} base
+inherit cmake-utils ${SCM} base flag-o-matic
DESCRIPTION="New implementation of the C++ standard library, targeting C++0X"
HOMEPAGE="http://libcxx.llvm.org/"
@@ -27,12 +27,13 @@ else
fi
IUSE=""
-RDEPEND=""
+RDEPEND="sys-libs/libcxxrt"
DEPEND="${RDEPEND}
sys-devel/clang
app-arch/xz-utils"
-PATCHES=( "${FILESDIR}/multilib.patch" )
+PATCHES=( "${FILESDIR}/multilib.patch"
+ "${FILESDIR}/cxxrt.patch" )
DOCS=( "CREDITS.TXT" )
src_prepare() {
@@ -40,6 +41,7 @@ src_prepare() {
}
src_configure() {
+ append-cppflags "-I/usr/include/libcxxrt -DLIBCXXRT"
# Needs to be built with clang. gcc-4.6.3 fails at least.
# TODO: cross-compile ?
export CC=clang