summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-08-03 09:27:32 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-08-03 09:27:32 +0000
commitc7d975f1467e9b763d0d3795afd19938d4f6445d (patch)
tree63a65abf1e9c18dffc79b289b0d1d0f070580fc7 /sys-libs
parentVersion bump (diff)
downloadgentoo-2-c7d975f1467e9b763d0d3795afd19938d4f6445d.tar.gz
gentoo-2-c7d975f1467e9b763d0d3795afd19938d4f6445d.tar.bz2
gentoo-2-c7d975f1467e9b763d0d3795afd19938d4f6445d.zip
Bump to 20110727 SELinux userspace release
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libsepol/ChangeLog7
-rw-r--r--sys-libs/libsepol/libsepol-2.1.0.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/sys-libs/libsepol/ChangeLog b/sys-libs/libsepol/ChangeLog
index 80e1b55a39c4..37117f1c5756 100644
--- a/sys-libs/libsepol/ChangeLog
+++ b/sys-libs/libsepol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsepol
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.41 2011/07/15 21:03:08 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.42 2011/08/03 09:27:32 blueness Exp $
+
+*libsepol-2.1.0 (03 Aug 2011)
+
+ 03 Aug 2011; Anthony G. Basile <blueness@gentoo.org> +libsepol-2.1.0.ebuild:
+ Bump to 20110727 SELinux userspace release
*libsepol-2.0.42 (15 Jul 2011)
diff --git a/sys-libs/libsepol/libsepol-2.1.0.ebuild b/sys-libs/libsepol/libsepol-2.1.0.ebuild
new file mode 100644
index 000000000000..f36c8a4e7cf7
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.1.0.ebuild,v 1.1 2011/08/03 09:27:32 blueness Exp $
+
+EAPI="2"
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20110727/devel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}