summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-08-27 04:57:37 +0000
committerTravis Tilley <lv@gentoo.org>2004-08-27 04:57:37 +0000
commitb5a8a3aabc96062ecb08eab4699f87517a2fd3c4 (patch)
treef1d305a92b749d6ccf392a763618e8e33c6f214d /sys-libs
parentadd some hppa/ia64 loving (Manifest recommit) (diff)
downloadgentoo-2-b5a8a3aabc96062ecb08eab4699f87517a2fd3c4.tar.gz
gentoo-2-b5a8a3aabc96062ecb08eab4699f87517a2fd3c4.tar.bz2
gentoo-2-b5a8a3aabc96062ecb08eab4699f87517a2fd3c4.zip
moved CONF_LIBDIR logic to use $(get_libdir) instead so that the ebuild will still use lib when CONF_LIBDIR is set, but the current version of portage doesnt have CONF_LIBDIR support
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/zlib/ChangeLog7
-rw-r--r--sys-libs/zlib/zlib-1.2.1-r3.ebuild26
2 files changed, 15 insertions, 18 deletions
diff --git a/sys-libs/zlib/ChangeLog b/sys-libs/zlib/ChangeLog
index db5af1869607..d44a1d802703 100644
--- a/sys-libs/zlib/ChangeLog
+++ b/sys-libs/zlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/zlib
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.35 2004/08/27 03:10:51 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.36 2004/08/27 04:57:37 lv Exp $
+
+ 27 Aug 2004; Travis Tilley <lv@gentoo.org> zlib-1.2.1-r3.ebuild:
+ moved CONF_LIBDIR logic to use $(get_libdir) instead so that the ebuild will
+ still use lib when CONF_LIBDIR is set, but the current version of portage
+ doesnt have CONF_LIBDIR support
27 Aug 2004; Bryan Østergaard <kloeri@gentoo.org> zlib-1.2.1-r3.ebuild:
Stable on alpha, bug 61749.
diff --git a/sys-libs/zlib/zlib-1.2.1-r3.ebuild b/sys-libs/zlib/zlib-1.2.1-r3.ebuild
index 55398a9bb6a3..db418d8d0dfc 100644
--- a/sys-libs/zlib/zlib-1.2.1-r3.ebuild
+++ b/sys-libs/zlib/zlib-1.2.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.1-r3.ebuild,v 1.8 2004/08/27 03:10:51 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.1-r3.ebuild,v 1.9 2004/08/27 04:57:37 lv Exp $
inherit eutils flag-o-matic
@@ -31,26 +31,18 @@ src_unpack() {
epatch ${FILESDIR}/${P}-CAN-2004-0797.patch
}
-pkg_setup() {
- # this adds support for installing to lib64/lib32. since only portage
- # 2.0.51 will have this functionality supported in dolib and friends,
- # and since it isnt expected that many profiles will define it, we need
- # to make this variable default to lib.
- [ -z "${CONF_LIBDIR}" ] && export CONF_LIBDIR="lib"
-}
-
src_compile() {
- ./configure --shared --prefix=/usr --libdir=/${CONF_LIBDIR} || die
+ ./configure --shared --prefix=/usr --libdir=/$(get_libdir) || die
emake || die
make test || die
- ./configure --prefix=/usr --libdir=/${CONF_LIBDIR} || die
+ ./configure --prefix=/usr --libdir=/$(get_libdir) || die
emake || die
}
src_install() {
- einstall libdir=${D}/${CONF_LIBDIR} || die
- rm ${D}/${CONF_LIBDIR}/libz.a
+ einstall libdir=${D}/$(get_libdir) || die
+ rm ${D}/$(get_libdir)/libz.a
into /usr
dodir /usr/include
insinto /usr/include
@@ -72,9 +64,9 @@ src_install() {
# for NFS based /usr
into /
dolib libz.so.${PV}
- ( cd ${D}/${CONF_LIBDIR} ; chmod 755 libz.so.* )
- dosym libz.so.${PV} /${CONF_LIBDIR}/libz.so
- dosym libz.so.${PV} /${CONF_LIBDIR}/libz.so.1
+ ( cd ${D}/$(get_libdir) ; chmod 755 libz.so.* )
+ dosym libz.so.${PV} /$(get_libdir)/libz.so
+ dosym libz.so.${PV} /$(get_libdir)/libz.so.1
# with an extra symlink at /usr/lib
- dosym /${CONF_LIBDIR}/libz.so.${PV} /usr/${CONF_LIBDIR}/libz.so
+ dosym /$(get_libdir)/libz.so.${PV} /usr/$(get_libdir)/libz.so
}