summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-14 21:59:47 +0000
committerMike Frysinger <vapier@gentoo.org>2012-04-14 21:59:47 +0000
commita1237075028522c450122082684903089f93165f (patch)
tree61b7b2c17b2bfc31856eb9c5a56960dd65f043d3 /sys-libs
parentAdd ~amd64-linux keyword. (diff)
downloadgentoo-2-a1237075028522c450122082684903089f93165f.tar.gz
gentoo-2-a1237075028522c450122082684903089f93165f.tar.bz2
gentoo-2-a1237075028522c450122082684903089f93165f.zip
Disable building of static ELFs for ia64 cross-compiler targets to workaround a broken gcc-stage1 libgcc #411677 by Michael Kosarev.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/files/eblits/src_compile.eblit12
2 files changed, 17 insertions, 2 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 49ea64e0f67f..9262b8222146 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.830 2012/04/14 02:04:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.831 2012/04/14 21:59:46 vapier Exp $
+
+ 14 Apr 2012; Mike Frysinger <vapier@gentoo.org>
+ files/eblits/src_compile.eblit:
+ Disable building of static ELFs for ia64 cross-compiler targets to workaround
+ a broken gcc-stage1 libgcc #411677 by Michael Kosarev.
14 Apr 2012; Mike Frysinger <vapier@gentoo.org> glibc-2.13-r4.ebuild:
Mark s390 stable #382377.
diff --git a/sys-libs/glibc/files/eblits/src_compile.eblit b/sys-libs/glibc/files/eblits/src_compile.eblit
index 178adbab89c4..e3fe02a31181 100644
--- a/sys-libs/glibc/files/eblits/src_compile.eblit
+++ b/sys-libs/glibc/files/eblits/src_compile.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_compile.eblit,v 1.23 2012/01/17 23:51:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_compile.eblit,v 1.24 2012/04/14 21:59:47 vapier Exp $
glibc_do_configure() {
local myconf
@@ -99,6 +99,16 @@ glibc_do_configure() {
cd "${GBUILDDIR}"
echo "${S}"/configure ${myconf}
"${S}"/configure ${myconf} || die "failed to configure glibc"
+
+ # ia64 static cross-compilers are a pita in so much that they
+ # can't produce static ELFs (as the libgcc.a is broken). so
+ # disable building of the programs for those targets if it
+ # doesn't work.
+ # XXX: We could turn this into a compiler test, but ia64 is
+ # the only one that matters, so this should be fine for now.
+ if is_crosscompile && [[ ${CTARGET} == ia64* ]] ; then
+ sed -i '1i+link-static = touch $@' config.make
+ fi
}
toolchain-glibc_src_compile() {