summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-08-12 06:04:23 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-08-12 06:04:23 +0000
commit9d65530052f709b6fbfd588663bcde60b3b354f8 (patch)
tree7c39f25645055fbc2e34732f10482c69539628c1 /sys-libs
parentadd emotion to DEPEND #60109 (Manifest recommit) (diff)
downloadgentoo-2-9d65530052f709b6fbfd588663bcde60b3b354f8.tar.gz
gentoo-2-9d65530052f709b6fbfd588663bcde60b3b354f8.tar.bz2
gentoo-2-9d65530052f709b6fbfd588663bcde60b3b354f8.zip
Initial ebuild by Robin H. Johnson <robbat2@gentoo.org>, for bug #23789.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/pam_pwdfile/ChangeLog10
-rw-r--r--sys-libs/pam_pwdfile/files/digest-pam_pwdfile-0.991
-rw-r--r--sys-libs/pam_pwdfile/metadata.xml5
-rw-r--r--sys-libs/pam_pwdfile/pam_pwdfile-0.99.ebuild27
4 files changed, 43 insertions, 0 deletions
diff --git a/sys-libs/pam_pwdfile/ChangeLog b/sys-libs/pam_pwdfile/ChangeLog
new file mode 100644
index 000000000000..ec59cbb8be20
--- /dev/null
+++ b/sys-libs/pam_pwdfile/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-libs/pam_pwdfile
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam_pwdfile/ChangeLog,v 1.1 2004/08/12 06:04:23 robbat2 Exp $
+
+*pam_pwdfile-0.99 (11 Aug 2004)
+
+ 11 Aug 2004; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+ +pam_pwdfile-0.99.ebuild:
+ Initial ebuild by Robin H. Johnson <robbat2@gentoo.org>, for bug #23789.
+
diff --git a/sys-libs/pam_pwdfile/files/digest-pam_pwdfile-0.99 b/sys-libs/pam_pwdfile/files/digest-pam_pwdfile-0.99
new file mode 100644
index 000000000000..fe04bec2bf36
--- /dev/null
+++ b/sys-libs/pam_pwdfile/files/digest-pam_pwdfile-0.99
@@ -0,0 +1 @@
+MD5 a05b41f0bd1c0de16bec8aad6b1b30a9 pam_pwdfile-0.99.tar.gz 16994
diff --git a/sys-libs/pam_pwdfile/metadata.xml b/sys-libs/pam_pwdfile/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-libs/pam_pwdfile/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>
diff --git a/sys-libs/pam_pwdfile/pam_pwdfile-0.99.ebuild b/sys-libs/pam_pwdfile/pam_pwdfile-0.99.ebuild
new file mode 100644
index 000000000000..c852ff6d5ae6
--- /dev/null
+++ b/sys-libs/pam_pwdfile/pam_pwdfile-0.99.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam_pwdfile/pam_pwdfile-0.99.ebuild,v 1.1 2004/08/12 06:04:23 robbat2 Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="PAM module for authenticating against passwd-like files."
+HOMEPAGE="http://cpbotha.net/pam_pwdfile.html"
+SRC_URI="http://cpbotha.net/files/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="sys-libs/pam"
+
+src_compile() {
+ # the upstream makefile does CFLAGS in a horrible way
+ # that '-c' is 100% required here
+ append-flags -fPIC -Wall -Wformat-security -D_BSD_SOURCE -c
+ emake -f contrib/Makefile.standalone CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ exeinto /lib/security
+ doexe ${PN}.so
+ dodoc INSTALL README changelog contrib/warwick_duncan-cyrus_without_system_accounts.txt
+}