summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-21 15:56:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-21 15:56:41 +0000
commit98d4f9669891239a9b93d9566a11de49e30e97a9 (patch)
tree49084d5b85192ce322f8358ec33234466384eb93 /sys-libs
parentConvert to multilib and stack it for baselibs -r13. Force libgpm soname for n... (diff)
downloadgentoo-2-98d4f9669891239a9b93d9566a11de49e30e97a9.tar.gz
gentoo-2-98d4f9669891239a9b93d9566a11de49e30e97a9.tar.bz2
gentoo-2-98d4f9669891239a9b93d9566a11de49e30e97a9.zip
Convert to multilib and stack it for baselibs -r13. Bug #480144.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gpm/ChangeLog9
-rw-r--r--sys-libs/gpm/gpm-1.20.7-r2.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/sys-libs/gpm/ChangeLog b/sys-libs/gpm/ChangeLog
index 1557370da72d..f750ea731381 100644
--- a/sys-libs/gpm/ChangeLog
+++ b/sys-libs/gpm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gpm
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.92 2012/12/30 23:53:45 floppym Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.93 2013/08/21 15:56:41 aballier Exp $
+
+*gpm-1.20.7-r2 (21 Aug 2013)
+
+ 21 Aug 2013; Alexis Ballier <aballier@gentoo.org> +gpm-1.20.7-r2.ebuild:
+ Convert to multilib and stack it for baselibs -r13. Bug #480144.
*gpm-1.20.7-r1 (30 Dec 2012)
diff --git a/sys-libs/gpm/gpm-1.20.7-r2.ebuild b/sys-libs/gpm/gpm-1.20.7-r2.ebuild
new file mode 100644
index 000000000000..aae78327641c
--- /dev/null
+++ b/sys-libs/gpm/gpm-1.20.7-r2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.7-r2.ebuild,v 1.1 2013/08/21 15:56:41 aballier Exp $
+
+# emacs support disabled due to #99533 #335900
+
+EAPI="4"
+
+inherit eutils systemd toolchain-funcs autotools multilib-minimal
+
+DESCRIPTION="Console-based mouse driver"
+HOMEPAGE="http://www.nico.schottelius.org/software/gpm/"
+SRC_URI="http://www.nico.schottelius.org/software/${PN}/archives/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux static-libs"
+
+RDEPEND="sys-libs/ncurses[${MULTILIB_USEDEP}]
+ selinux? ( sec-policy/selinux-gpm )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20130224-r12
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="sys-libs/ncurses[${MULTILIB_USEDEP}]
+ app-arch/xz-utils
+ virtual/yacc"
+
+src_prepare() {
+ # fix ABI values
+ sed -i \
+ -e '/^abi_lev=/s:=.*:=1:' \
+ -e '/^abi_age=/s:=.*:=20:' \
+ configure.ac.footer || die
+ sed -i -e '/ACLOCAL/,$d' autogen.sh || die
+ ./autogen.sh
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ --sysconfdir=/etc/gpm \
+ $(use_enable static-libs static) \
+ emacs=/bin/false
+}
+
+multilib_src_compile() {
+ # make sure nothing compiled is left
+ emake clean
+ emake EMACS=: $(multilib_is_native_abi || echo "PROG= ")
+}
+
+multilib_src_install() {
+ emake \
+ DESTDIR="${D}" \
+ EMACS=: ELISP="" \
+ $(multilib_is_native_abi || echo "PROG= ") \
+ install
+
+ dosym libgpm.so.1 /usr/$(get_libdir)/libgpm.so
+ multilib_is_native_abi && gen_usr_ldscript -a gpm
+}
+
+multilib_src_install_all() {
+ insinto /etc/gpm
+ doins conf/gpm-*.conf
+
+ dodoc README TODO
+ dodoc doc/Announce doc/FAQ doc/README*
+
+ newinitd "${FILESDIR}"/gpm.rc6-2 gpm
+ newconfd "${FILESDIR}"/gpm.conf.d gpm
+ systemd_dounit "${FILESDIR}"/gpm.service
+}