summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-09-13 14:04:51 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-09-13 14:04:51 +0000
commit989235fd97c5fd5317813e3139f0ed2529d14af6 (patch)
treedd855a5b737e98cb3aaef6413135b1788d3243b0 /sys-libs
parentrevbump -> EAPI 5, remove old (diff)
downloadgentoo-2-989235fd97c5fd5317813e3139f0ed2529d14af6.tar.gz
gentoo-2-989235fd97c5fd5317813e3139f0ed2529d14af6.tar.bz2
gentoo-2-989235fd97c5fd5317813e3139f0ed2529d14af6.zip
Version bump. Removed old
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/talloc/ChangeLog8
-rw-r--r--sys-libs/talloc/talloc-2.1.0.ebuild (renamed from sys-libs/talloc/talloc-2.0.7.ebuild)25
2 files changed, 19 insertions, 14 deletions
diff --git a/sys-libs/talloc/ChangeLog b/sys-libs/talloc/ChangeLog
index cc9dfe5a5f84..9a37ab00a22e 100644
--- a/sys-libs/talloc/ChangeLog
+++ b/sys-libs/talloc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/talloc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/ChangeLog,v 1.59 2013/09/06 14:59:15 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/ChangeLog,v 1.60 2013/09/13 14:04:51 polynomial-c Exp $
+
+*talloc-2.1.0 (13 Sep 2013)
+
+ 13 Sep 2013; Lars Wendler <polynomial-c@gentoo.org> -talloc-2.0.7.ebuild,
+ +talloc-2.1.0.ebuild:
+ Version bump. Removed old.
06 Sep 2013; Agostino Sarubbo <ago@gentoo.org> talloc-2.0.8.ebuild:
Stable for sparc, wrt bug #466710
diff --git a/sys-libs/talloc/talloc-2.0.7.ebuild b/sys-libs/talloc/talloc-2.1.0.ebuild
index 219adae9832b..8f3efa4a879f 100644
--- a/sys-libs/talloc/talloc-2.0.7.ebuild
+++ b/sys-libs/talloc/talloc-2.1.0.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/talloc-2.0.7.ebuild,v 1.14 2013/03/06 10:27:35 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/talloc-2.1.0.ebuild,v 1.1 2013/09/13 14:04:51 polynomial-c Exp $
-EAPI=3
-PYTHON_DEPEND="python? 2:2.6"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-inherit waf-utils python multilib
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="threads"
+
+inherit waf-utils python-single-r1 multilib
DESCRIPTION="Samba talloc library"
HOMEPAGE="http://talloc.samba.org/"
@@ -13,22 +15,19 @@ SRC_URI="http://samba.org/ftp/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~sparc-solaris"
IUSE="compat python"
-RDEPEND="!!<sys-libs/talloc-2.0.5"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !!<sys-libs/talloc-2.0.5"
DEPEND="${RDEPEND}
dev-libs/libxslt
|| ( dev-lang/python:2.7[threads] dev-lang/python:2.6[threads] )"
WAF_BINARY="${S}/buildtools/bin/waf"
-pkg_setup() {
- # Make sure the build system will use the right python
- python_set_active_version 2
- python_pkg_setup
-}
-
src_configure() {
local extra_opts=""