summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-16 21:28:20 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-16 21:28:20 +0000
commit97b553f2401e2cec6b54619b8094dcc9d9d86b75 (patch)
treec4e7f6c7eab6e0930f7ffffe6c90f249c7aa6a04 /sys-libs
parentbump, display should now be more inline with other Schemes (diff)
downloadgentoo-2-97b553f2401e2cec6b54619b8094dcc9d9d86b75.tar.gz
gentoo-2-97b553f2401e2cec6b54619b8094dcc9d9d86b75.tar.bz2
gentoo-2-97b553f2401e2cec6b54619b8094dcc9d9d86b75.zip
Version bump #262665 by Rodrigo Severo.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/timezone-data/ChangeLog8
-rw-r--r--sys-libs/timezone-data/timezone-data-2009c.ebuild106
2 files changed, 113 insertions, 1 deletions
diff --git a/sys-libs/timezone-data/ChangeLog b/sys-libs/timezone-data/ChangeLog
index 3dabb7a1f648..ee4279026d46 100644
--- a/sys-libs/timezone-data/ChangeLog
+++ b/sys-libs/timezone-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/timezone-data
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.167 2009/03/16 13:37:42 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.168 2009/03/16 21:28:20 vapier Exp $
+
+*timezone-data-2009c (16 Mar 2009)
+
+ 16 Mar 2009; Mike Frysinger <vapier@gentoo.org>
+ +timezone-data-2009c.ebuild:
+ Version bump #262665 by Rodrigo Severo.
16 Mar 2009; Thomas Anderson <gentoofan23@gentoo.org>
timezone-data-2009b.ebuild:
diff --git a/sys-libs/timezone-data/timezone-data-2009c.ebuild b/sys-libs/timezone-data/timezone-data-2009c.ebuild
new file mode 100644
index 000000000000..e54100637b3e
--- /dev/null
+++ b/sys-libs/timezone-data/timezone-data-2009c.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2009c.ebuild,v 1.1 2009/03/16 21:28:20 vapier Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+code_ver=${PV/c/b}
+data_ver=${PV}
+DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
+HOMEPAGE="ftp://elsie.nci.nih.gov/pub/"
+SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${data_ver}.tar.gz
+ ftp://elsie.nci.nih.gov/pub/tzcode${code_ver}.tar.gz
+ mirror://gentoo/tzdata${data_ver}.tar.gz
+ mirror://gentoo/tzcode${code_ver}.tar.gz"
+
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls elibc_FreeBSD elibc_glibc"
+
+RDEPEND="!<sys-libs/glibc-2.3.5"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-2008h-makefile.patch
+ tc-is-cross-compiler && cp -pR "${S}" "${S}"-native
+}
+
+src_compile() {
+ local LDLIBS
+ tc-export CC
+ use elibc_FreeBSD && append-flags -DSTD_INSPIRED #138251
+ if use nls ; then
+ use elibc_glibc || LDLIBS="${LDLIBS} -lintl" #154181
+ export NLS=1
+ else
+ export NLS=0
+ fi
+ # Makefile uses LBLIBS for the libs (which defaults to LDFLAGS)
+ # But it also uses LFLAGS where it expects the real LDFLAGS
+ emake \
+ LDLIBS="${LDLIBS}" \
+ || die "emake failed"
+ if tc-is-cross-compiler ; then
+ emake -C "${S}"-native \
+ CC=$(tc-getBUILD_CC) \
+ CFLAGS="${BUILD_CFLAGS}" \
+ LDFLAGS="${BUILD_LDFLAGS}" \
+ LDLIBS="${LDLIBS}" \
+ zic || die
+ fi
+}
+
+src_install() {
+ local zic=""
+ tc-is-cross-compiler && zic="zic=${S}-native/zic"
+ emake install ${zic} DESTDIR="${D}" || die
+ rm -rf "${D}"/usr/share/zoneinfo-leaps
+ dodoc README Theory
+ dohtml *.htm *.jpg
+}
+
+pkg_config() {
+ # make sure the /etc/localtime file does not get stale #127899
+ local tz src
+
+ if has_version '<sys-apps/baselayout-2' ; then
+ src="/etc/conf.d/clock"
+ tz=$(unset TIMEZONE ; source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE-FOOKABLOIE})
+ else
+ src="/etc/timezone"
+ if [[ -e ${ROOT}/etc/timezone ]] ; then
+ tz=$(<"${ROOT}"/etc/timezone)
+ else
+ tz="FOOKABLOIE"
+ fi
+ fi
+ [[ -z ${tz} ]] && return 0
+
+ if [[ ${tz} == "FOOKABLOIE" ]] ; then
+ elog "You do not have TIMEZONE set in ${src}."
+
+ if [[ ! -e ${ROOT}/etc/localtime ]] ; then
+ cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
+ elog "Setting /etc/localtime to Factory."
+ else
+ elog "Skipping auto-update of /etc/localtime."
+ fi
+ return 0
+ fi
+
+ if [[ ! -e ${ROOT}/usr/share/zoneinfo/${tz} ]] ; then
+ elog "You have an invalid TIMEZONE setting in ${src}"
+ elog "Your /etc/localtime has been reset to Factory; enjoy!"
+ tz="Factory"
+ fi
+ einfo "Updating /etc/localtime with /usr/share/zoneinfo/${tz}"
+ [[ -L ${ROOT}/etc/localtime ]] && rm -f "${ROOT}"/etc/localtime
+ cp -f "${ROOT}"/usr/share/zoneinfo/"${tz}" "${ROOT}"/etc/localtime
+}
+
+pkg_postinst() {
+ pkg_config
+}