summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2012-12-09 19:19:26 +0000
committerSven Vermeulen <swift@gentoo.org>2012-12-09 19:19:26 +0000
commit945d7b67491e43086e13004d7aa71725c60a7d9d (patch)
treeaf95231f4996e96a4a6a76ec99de0e609e2d5df9 /sys-libs
parentRevision bump, fix build with newer boost, wrt bug #425600 (diff)
downloadgentoo-2-945d7b67491e43086e13004d7aa71725c60a7d9d.tar.gz
gentoo-2-945d7b67491e43086e13004d7aa71725c60a7d9d.tar.bz2
gentoo-2-945d7b67491e43086e13004d7aa71725c60a7d9d.zip
Add in proper RANLIB support, fixes bug #444374
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xCDBA2FDB)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libsepol/ChangeLog7
-rw-r--r--sys-libs/libsepol/libsepol-2.1.8-r1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/sys-libs/libsepol/ChangeLog b/sys-libs/libsepol/ChangeLog
index e4210d2d6286..e4223084d4f9 100644
--- a/sys-libs/libsepol/ChangeLog
+++ b/sys-libs/libsepol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsepol
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.52 2012/11/17 16:56:46 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.53 2012/12/09 19:19:26 swift Exp $
+
+*libsepol-2.1.8-r1 (09 Dec 2012)
+
+ 09 Dec 2012; <swift@gentoo.org> +libsepol-2.1.8-r1.ebuild:
+ Adding proper RANLIB support, see bug #444374
17 Nov 2012; <swift@gentoo.org> libsepol-2.1.8.ebuild:
Stabilization
diff --git a/sys-libs/libsepol/libsepol-2.1.8-r1.ebuild b/sys-libs/libsepol/libsepol-2.1.8-r1.ebuild
new file mode 100644
index 000000000000..9816eece2c6e
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.1.8-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.1.8-r1.ebuild,v 1.1 2012/12/09 19:19:26 swift Exp $
+
+EAPI="2"
+
+inherit multilib toolchain-funcs eutils
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20120924/${P}.tar.gz
+ http://dev.gentoo.org/~swift/patches/${PN}/patchbundle-${P}-r1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ EPATCH_MULTI_MSG="Applying libsepol patches ... " \
+ EPATCH_SUFFIX="patch" \
+ EPATCH_SOURCE="${WORKDIR}/gentoo-patches" \
+ EPATCH_FORCE="yes" \
+ epatch
+
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib SHLIBDIR failed."
+
+ epatch_user
+}
+
+src_compile() {
+ tc-export RANLIB;
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}