summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-07-16 03:12:27 +0000
committerMike Frysinger <vapier@gentoo.org>2009-07-16 03:12:27 +0000
commit8d1662601d0ecb10d4f941f8635407d152841fee (patch)
tree152b7079309149643e4a6163fdcc7747e2df150a /sys-libs
parentSparc stable, bug #275997. (diff)
downloadgentoo-2-8d1662601d0ecb10d4f941f8635407d152841fee.tar.gz
gentoo-2-8d1662601d0ecb10d4f941f8635407d152841fee.tar.bz2
gentoo-2-8d1662601d0ecb10d4f941f8635407d152841fee.zip
Version bump #269378 by Matthias Schwarzott.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/e2fsprogs-libs/ChangeLog8
-rw-r--r--sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.8.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/sys-libs/e2fsprogs-libs/ChangeLog b/sys-libs/e2fsprogs-libs/ChangeLog
index 1d61303ee6d4..577a1190c573 100644
--- a/sys-libs/e2fsprogs-libs/ChangeLog
+++ b/sys-libs/e2fsprogs-libs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/e2fsprogs-libs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/ChangeLog,v 1.27 2009/07/01 14:40:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/ChangeLog,v 1.28 2009/07/16 03:12:27 vapier Exp $
+
+*e2fsprogs-libs-1.41.8 (16 Jul 2009)
+
+ 16 Jul 2009; Mike Frysinger <vapier@gentoo.org>
+ +e2fsprogs-libs-1.41.8.ebuild:
+ Version bump #269378 by Matthias Schwarzott.
*e2fsprogs-libs-1.41.7 (01 Jul 2009)
diff --git a/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.8.ebuild b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.8.ebuild
new file mode 100644
index 000000000000..04d119db86de
--- /dev/null
+++ b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.8.ebuild,v 1.1 2009/07/16 03:12:27 vapier Exp $
+
+EAPI="2"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="e2fsprogs libraries (common error and subsystem)"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="elibc_glibc? ( >=sys-libs/glibc-2.6 )
+ !sys-libs/com_err
+ !sys-libs/ss
+ !<sys-fs/e2fsprogs-1.41.8"
+DEPEND="nls? ( sys-devel/gettext )
+ dev-util/pkgconfig
+ sys-devel/bc"
+
+src_prepare() {
+ # stupid configure script clobbers CC for us
+ sed -i '/if test -z "$CC" ; then CC=cc; fi/d' configure
+}
+
+src_configure() {
+ # We want to use the "bsd" libraries while building on Darwin, but while
+ # building on other Gentoo/*BSD we prefer elf-naming scheme.
+ local libtype
+ case ${CHOST} in
+ *-darwin*) libtype=bsd;;
+ *) libtype=elf;;
+ esac
+
+ # we use blkid/uuid from util-linux now
+ ac_cv_path_LDCONFIG=: \
+ econf \
+ --disable-libblkid \
+ --disable-libuuid \
+ --enable-${libtype}-shlibs \
+ $(use_enable !elibc_uclibc tls) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake STRIP=: DESTDIR="${D}" install || die
+
+ set -- "${D}"/usr/$(get_libdir)/*.a
+ set -- ${@/*\/lib}
+ gen_usr_ldscript -a "${@/.a}"
+}