summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2003-05-25 18:49:22 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2003-05-25 18:49:22 +0000
commit89253a0b3ab09f815fe057081eb243c8e4a6cf21 (patch)
treeb26b726bcd16c8f1481893ab09c2a8af19010d88 /sys-libs
parentfix the fix (diff)
downloadgentoo-2-89253a0b3ab09f815fe057081eb243c8e4a6cf21.tar.gz
gentoo-2-89253a0b3ab09f815fe057081eb243c8e4a6cf21.tar.bz2
gentoo-2-89253a0b3ab09f815fe057081eb243c8e4a6cf21.zip
Fix the fact that find doesn't sort
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/Manifest6
-rw-r--r--sys-libs/db/db-3.2.9-r5.ebuild4
-rw-r--r--sys-libs/db/db-4.0.14.ebuild10
-rw-r--r--sys-libs/db/db-4.1.24.ebuild10
4 files changed, 16 insertions, 14 deletions
diff --git a/sys-libs/db/Manifest b/sys-libs/db/Manifest
index b5545afe15e2..31af62a03651 100644
--- a/sys-libs/db/Manifest
+++ b/sys-libs/db/Manifest
@@ -5,9 +5,9 @@ MD5 4be311009c1216a911e76dcf33bb568d db-3.2.9-r1.ebuild 2587
MD5 e03298e927335414c7db1882f24ed8e4 db-3.2.9-r2.ebuild 3221
MD5 af7ea3ee5a3a001d516413c0b9bc52e5 db-3.2.9.ebuild 2464
MD5 2dd3cac46936c5510bf2133977ff5a48 db-3.3.11.ebuild 2408
-MD5 a69a258d7457e4c0a05128c68dc6f622 db-4.1.24.ebuild 2137
-MD5 6a99631bf212d90007d235f33a0ed62b db-4.0.14.ebuild 2291
-MD5 d5acf12d8e38806580ed61a658f6346a db-3.2.9-r5.ebuild 4036
+MD5 f3bfd0cfb4c1930298030a47da11697f db-4.1.24.ebuild 2161
+MD5 3927bde953930936697daac1c16d3f36 db-4.0.14.ebuild 2315
+MD5 aaf980d99e89eb9e6cdb55a5b449c5f0 db-3.2.9-r5.ebuild 4160
MD5 194200b3295b95b46b4564980af27f1f files/db-3.2.9-fix-dep-link.patch 1005
MD5 ecd81fa9868ec49c61306444144d44a9 files/db.1.85.patch 55584
MD5 3057fcc117c33a02bd4c092586a58e49 files/digest-db-1.85-r1 59
diff --git a/sys-libs/db/db-3.2.9-r5.ebuild b/sys-libs/db/db-3.2.9-r5.ebuild
index 8d5902c7a75e..de558fbd9822 100644
--- a/sys-libs/db/db-3.2.9-r5.ebuild
+++ b/sys-libs/db/db-3.2.9-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r5.ebuild,v 1.4 2003/05/25 18:27:25 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r5.ebuild,v 1.5 2003/05/25 18:49:13 pauldv Exp $
IUSE=""
@@ -143,6 +143,8 @@ fix_so () {
[ ${target} ] && ln -sf ${target//.\//} libdb_cxx.so
target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |tail -n 1`
[ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
+ target=`find -type f -maxdepth 1 -name "libdb_java*.so" |tail -n 1`
+ [ ${target} ] && ln -sf ${target//.\//} libdb_java.so
cd -
cd /usr/include
target=`ls -d db? |tail -n 1`
diff --git a/sys-libs/db/db-4.0.14.ebuild b/sys-libs/db/db-4.0.14.ebuild
index 26a766f3907b..68a28de632cf 100644
--- a/sys-libs/db/db-4.0.14.ebuild
+++ b/sys-libs/db/db-4.0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.18 2003/05/25 18:27:25 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.19 2003/05/25 18:49:13 pauldv Exp $
IUSE="tcltk java"
@@ -70,13 +70,13 @@ src_install () {
fix_so () {
cd /usr/lib
- target=`find -type f -maxdepth 1 -name "libdb-*.so" |tail -n 1`
+ target=`find -type f -maxdepth 1 -name "libdb-*.so" |sort |tail -n 1`
[ ${target} ] && ln -sf ${target//.\//} libdb.so
- target=`find -type f -maxdepth 1 -name "libdb_cxx*.so" |tail -n 1`
+ target=`find -type f -maxdepth 1 -name "libdb_cxx*.so" |sort |tail -n 1`
[ ${target} ] && ln -sf ${target//.\//} libdb_cxx.so
- target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |tail -n 1`
+ target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |sort |tail -n 1`
[ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
- target=`find -type f -maxdepth 1 -name "libdb_java*.so" |tail -n 1`
+ target=`find -type f -maxdepth 1 -name "libdb_java*.so" |sort |tail -n 1`
[ ${target} ] && ln -sf ${target//.\//} libdb_java.so
cd -
cd /usr/include
diff --git a/sys-libs/db/db-4.1.24.ebuild b/sys-libs/db/db-4.1.24.ebuild
index 40cacdcbfd65..f8f6eee938e8 100644
--- a/sys-libs/db/db-4.1.24.ebuild
+++ b/sys-libs/db/db-4.1.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.13 2003/05/25 18:27:25 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.14 2003/05/25 18:49:13 pauldv Exp $
IUSE="tcltk java"
@@ -65,13 +65,13 @@ src_install () {
fix_so () {
cd /usr/lib
- target=`find -type f -maxdepth 1 -name "libdb-*.so" |tail -n 1`
+ target=`find -type f -maxdepth 1 -name "libdb-*.so" |sort |tail -n 1`
[ ${target} ] && ln -sf ${target//.\//} libdb.so
- target=`find -type f -maxdepth 1 -name "libdb_cxx*.so" |tail -n 1`
+ target=`find -type f -maxdepth 1 -name "libdb_cxx*.so" |sort |tail -n 1`
[ ${target} ] && ln -sf ${target//.\//} libdb_cxx.so
- target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |tail -n 1`
+ target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |sort |tail -n 1`
[ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
- target=`find -type f -maxdepth 1 -name "libdb_java*.so" |tail -n 1`
+ target=`find -type f -maxdepth 1 -name "libdb_java*.so" |sort |tail -n 1`
[ ${target} ] && ln -sf ${target//.\//} libdb_java.so
cd -
cd /usr/include