summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2006-03-22 16:15:27 +0000
committerHanno Böck <hanno@gentoo.org>2006-03-22 16:15:27 +0000
commit881cac4961ed5757539d391f70d096f18a0817b8 (patch)
treef8fbfbbe0d2124a6f2d845812510d557f8a3414c /sys-libs
parentfix DEPEND; use user CC instead of hard-coded gcc (diff)
downloadgentoo-2-881cac4961ed5757539d391f70d096f18a0817b8.tar.gz
gentoo-2-881cac4961ed5757539d391f70d096f18a0817b8.tar.bz2
gentoo-2-881cac4961ed5757539d391f70d096f18a0817b8.zip
gwenhywfar version bump
(Portage version: 2.1_pre6-r5)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/files/digest-gwenhywfar-2.1.03
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-2.1.0.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index 0a90473247d0..3f133ec9b536 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.25 2006/02/06 17:29:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.26 2006/03/22 16:15:27 hanno Exp $
+
+*gwenhywfar-2.1.0 (22 Mar 2006)
+
+ 22 Mar 2006; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-2.1.0.ebuild:
+ Version bump.
06 Feb 2006; Aron Griffis <agriffis@gentoo.org> gwenhywfar-1.18.0.ebuild:
Mark 1.18.0 stable on alpha/ia64 #113175
diff --git a/sys-libs/gwenhywfar/files/digest-gwenhywfar-2.1.0 b/sys-libs/gwenhywfar/files/digest-gwenhywfar-2.1.0
new file mode 100644
index 000000000000..6ee7dc358107
--- /dev/null
+++ b/sys-libs/gwenhywfar/files/digest-gwenhywfar-2.1.0
@@ -0,0 +1,3 @@
+MD5 b0c4a96a0487e898ad57b5cfbea647ef gwenhywfar-2.1.0.tar.gz 1136406
+RMD160 b038cf8cd78247cd4ff28c2b9e113c26fc312257 gwenhywfar-2.1.0.tar.gz 1136406
+SHA256 24a0187fdaf6bef3d1067365895ffc4ea3807d18e0423ba3c860b0f7554e3e5b gwenhywfar-2.1.0.tar.gz 1136406
diff --git a/sys-libs/gwenhywfar/gwenhywfar-2.1.0.ebuild b/sys-libs/gwenhywfar/gwenhywfar-2.1.0.ebuild
new file mode 100644
index 000000000000..4c944f0948e1
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-2.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-2.1.0.ebuild,v 1.1 2006/03/22 16:15:27 hanno Exp $
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="debug ssl doc ncurses"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ sys-libs/ncurses
+ doc? ( app-doc/doxygen )
+ ncurses? ( sys-libs/ncurses )"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ if use doc; then
+ APIDOC="--with-docpath=/usr/share/doc/${P}/apidoc"
+ fi
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable doc full-doc` \
+ `use_enable ncurses gwenui` \
+ ${APIDOC} || die "configure failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake srcdoc || die "Building the api-doc failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README* AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL TODO
+ if use doc; then
+ make DESTDIR=${D} install-srcdoc || die "Installing the API-Doc failed"
+ fi
+}