summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-08-26 23:37:36 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-08-26 23:37:36 +0000
commit8787e089f9036b7e098bb0a649aa3c66135b4d54 (patch)
tree65228b3b9726e92662ea5ad55e7716e461f40820 /sys-libs
parentdigesto (diff)
downloadgentoo-2-8787e089f9036b7e098bb0a649aa3c66135b4d54.tar.gz
gentoo-2-8787e089f9036b7e098bb0a649aa3c66135b4d54.tar.bz2
gentoo-2-8787e089f9036b7e098bb0a649aa3c66135b4d54.zip
db typo fix
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/db-3.2.3h-r4.ebuild54
1 files changed, 20 insertions, 34 deletions
diff --git a/sys-libs/db/db-3.2.3h-r4.ebuild b/sys-libs/db/db-3.2.3h-r4.ebuild
index ac2363eefd94..7ee9955bc1c6 100644
--- a/sys-libs/db/db-3.2.3h-r4.ebuild
+++ b/sys-libs/db/db-3.2.3h-r4.ebuild
@@ -1,50 +1,36 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.3h-r4.ebuild,v 1.2 2001/06/21 14:08:38 achim Exp $
+# Maintainer: System Team <system@gentoo.org>
+# Author: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.3h-r4.ebuild,v 1.3 2001/08/26 23:37:36 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}/build_unix
DESCRIPTION="Berkeley DB for transaction support in MySQL"
-SRC_URI="ftp://mysql.valueclick.com/mysql/Downloads/db/${A}
- http://download.sourceforge.net/pub/mirrors/mysql/Downloads/db/${A}"
+SRC_URI="ftp://mysql.valueclick.com/mysql/Downloads/db/${P}.tar.gz http://download.sourceforge.net/pub/mirrors/mysql/Downloads/db/${P}.tar.gz"
HOMEPAGE="http://www.mysql.com"
RDEPEND="virtual/glibc"
-DEPEND="$RDEPEND
- =sys-libs/db-1.85-r1"
+DEPEND="$RDEPEND =sys-libs/db-1.85-r1"
src_compile() {
-
- try ../dist/configure --host=${CHOST} \
- --enable-compat185 --enable-dump185 \
- --prefix=/usr \
- --enable-shared --enable-static \
- --enable-cxx
-
+ ../dist/configure --host=${CHOST} --enable-compat185 --enable-dump185 --prefix=/usr --enable-shared --enable-static --enable-cxx || die
#--enable-rpc does not work
-
- echo
- # Parallel make does not work
- echo "Building static libs..."
- make libdb=libdb-3.2.a libdb-3.2.a
- make libcxx=libdb_cxx-3.2.a libdb_cxx-3.2.a
-
- echo
- echo "Building db_dump185..."
-
- try /bin/sh ./libtool --mode=compile cc -c ${CFLAGS} -I/usr/include/db1 -I../dist/../include -D_REENTRANT ../dist/../db_dump185/db_dump185.c
- try gcc -s -static -o db_dump185 db_dump185.lo -L/usr/lib -ldb1
-
- echo
- echo "Building everything else..."
- try make libdb=libdb-3.2.a libcxx=libdb_cxx-3.2.a
-
+ echo
+ # Parallel make does not work
+ echo "Building static libs..."
+ make libdb=libdb-3.2.a libdb-3.2.a || die
+ make libcxx=libdb_cxx-3.2.a libdb_cxx-3.2.a || die
+ echo
+ echo "Building db_dump185..."
+ /bin/sh ./libtool --mode=compile cc -c ${CFLAGS} -I/usr/include/db1 -I../dist/../include -D_REENTRANT ../dist/../db_dump185/db_dump185.c || die
+ gcc -s -static -o db_dump185 db_dump185.lo -L/usr/lib -ldb1 || die
+ echo
+ echo "Building everything else..."
+ make libdb=libdb-3.2.a libcxx=libdb_cxx-3.2.a || die
}
src_install () {
-
- try make libdb=libdb-3.2.a libcxx=libcxx_3.2.a prefix=${D}/usr install
+ make libdb=libdb-3.2.a libcxx=libcxx_3.2.a prefix=${D}/usr install || die
dolib.a libdb-3.2.a libdb_cxx-3.2.a
dolib libdb-3.2.la libdb_cxx-3.2.la