summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-07-23 16:01:24 +0000
committerMike Frysinger <vapier@gentoo.org>2012-07-23 16:01:24 +0000
commit747fbe6a827ad2e94b565a55f1f3b3e7258f77c5 (patch)
tree59c324b7388fd9ab345eb0e6101ee8b2082e6d75 /sys-libs
parentFix building with newer glibc and siginfo changes #427220 by Martin Jansa. (diff)
downloadgentoo-2-747fbe6a827ad2e94b565a55f1f3b3e7258f77c5.tar.gz
gentoo-2-747fbe6a827ad2e94b565a55f1f3b3e7258f77c5.tar.bz2
gentoo-2-747fbe6a827ad2e94b565a55f1f3b3e7258f77c5.zip
Fix building with newer glibc and siginfo changes #427220 by Martin Jansa.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libstdc++-v3/ChangeLog8
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r1.ebuild13
2 files changed, 11 insertions, 10 deletions
diff --git a/sys-libs/libstdc++-v3/ChangeLog b/sys-libs/libstdc++-v3/ChangeLog
index b20512a607e0..4ec3fd5dd602 100644
--- a/sys-libs/libstdc++-v3/ChangeLog
+++ b/sys-libs/libstdc++-v3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/libstdc++-v3
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.64 2011/11/05 16:57:59 vapier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.65 2012/07/23 16:01:24 vapier Exp $
+
+ 23 Jul 2012; Mike Frysinger <vapier@gentoo.org> libstdc++-v3-3.3.6-r1.ebuild:
+ Fix building with newer glibc and siginfo changes #427220 by Martin Jansa.
05 Nov 2011; Mike Frysinger <vapier@gentoo.org> libstdc++-v3-3.3.6.ebuild,
libstdc++-v3-3.3.6-r1.ebuild:
@@ -248,4 +251,3 @@
23 May 2004; Travis Tilley <lv@gentoo.org> +Changelog,
+files/libstdc++_amd64_multilib_hack.patch, +libstdc++-v3-3.3.3.ebuild:
initial commit
-
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r1.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r1.ebuild
index f20000e43a50..77fc48916860 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r1.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r1.ebuild,v 1.2 2011/11/05 16:57:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6-r1.ebuild,v 1.3 2012/07/23 16:01:24 vapier Exp $
inherit eutils flag-o-matic libtool multilib
@@ -104,7 +104,7 @@ do_filter_flags() {
strip-flags
}
-PATCH_VER="1.7"
+PATCH_VER="1.8"
DESCRIPTION="Compatibility package for running binaries linked against a pre gcc 3.4 libstdc++"
HOMEPAGE="http://gcc.gnu.org/libstdc++/"
@@ -126,7 +126,7 @@ src_unpack() {
./contrib/gcc_update --touch
mkdir -p "${WORKDIR}"/build
- if use multilib ; then
+ if use multilib && [[ ${SYMLINK_LIB} == "yes" ]] ; then
# ugh, this shit has to match the way we've hacked gcc else
# the build falls apart #259215
sed -i \
@@ -139,7 +139,7 @@ src_unpack() {
src_compile() {
cd "${WORKDIR}"/build
do_filter_flags
- ECONF_SOURCE=${S}
+ ECONF_SOURCE=${S} \
econf \
--enable-shared \
--with-system-zlib \
@@ -151,8 +151,7 @@ src_compile() {
--enable-__cxa_atexit \
$(use_enable multilib) \
$(use_enable nls) \
- $(use_with !nls included-gettext) \
- || die
+ $(use_with !nls included-gettext)
touch "${S}"/gcc/c-gperf.h