summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-10-28 11:35:56 +0000
committerMike Frysinger <vapier@gentoo.org>2012-10-28 11:35:56 +0000
commit70f11d47422b524dda6ddd87b84bc11de5ddd9ed (patch)
treee86b505a84d1387002af77edab9ad00ac28ef8e0 /sys-libs
parentVersion bump, drop old. (diff)
downloadgentoo-2-70f11d47422b524dda6ddd87b84bc11de5ddd9ed.tar.gz
gentoo-2-70f11d47422b524dda6ddd87b84bc11de5ddd9ed.tar.bz2
gentoo-2-70f11d47422b524dda6ddd87b84bc11de5ddd9ed.zip
Version bump.
(Portage version: 2.2.0_alpha131/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gpm/ChangeLog8
-rw-r--r--sys-libs/gpm/files/gpm.rc6-215
-rw-r--r--sys-libs/gpm/gpm-1.20.7.ebuild64
3 files changed, 80 insertions, 7 deletions
diff --git a/sys-libs/gpm/ChangeLog b/sys-libs/gpm/ChangeLog
index 38f38c3fd60d..11bd93d1caa2 100644
--- a/sys-libs/gpm/ChangeLog
+++ b/sys-libs/gpm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/gpm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.90 2012/10/26 20:45:14 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.91 2012/10/28 11:35:56 vapier Exp $
+
+*gpm-1.20.7 (28 Oct 2012)
+
+ 28 Oct 2012; Mike Frysinger <vapier@gentoo.org> +gpm-1.20.7.ebuild,
+ files/gpm.rc6-2:
+ Version bump.
*gpm-1.20.6-r1 (26 Oct 2012)
diff --git a/sys-libs/gpm/files/gpm.rc6-2 b/sys-libs/gpm/files/gpm.rc6-2
index a93c059d0582..1e0aaf3e1523 100644
--- a/sys-libs/gpm/files/gpm.rc6-2
+++ b/sys-libs/gpm/files/gpm.rc6-2
@@ -1,15 +1,18 @@
#!/sbin/runscript
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/files/gpm.rc6-2,v 1.1 2012/10/26 20:45:14 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/files/gpm.rc6-2,v 1.2 2012/10/28 11:35:56 vapier Exp $
#NB: Config is in /etc/conf.d/gpm
command=/usr/sbin/gpm
-command_args="-m ${MOUSEDEV} -t ${MOUSE} \
-${RESPONSIVENESS:+ -r ${RESPONSIVENESS}} \
-${REPEAT_TYPE:+ -R${REPEAT_TYPE}} \
-${APPEND:+ ${APPEND}}"
+command_args="
+ -m ${MOUSEDEV}
+ -t ${MOUSE}
+ ${RESPONSIVENESS:+ -r ${RESPONSIVENESS}}
+ ${REPEAT_TYPE:+ -R${REPEAT_TYPE}}
+ ${APPEND}
+"
pidfile=/var/run/gpm.pid
@@ -19,7 +22,7 @@ depend() {
}
start_pre() {
- if [ -z "$MOUSEDEV" ] || [ -z "$MOUSE" ] ; then
+ if [ -z "${MOUSEDEV}" ] || [ -z "${MOUSE}" ] ; then
eerror "You need to setup MOUSEDEV and MOUSE in /etc/conf.d/gpm first"
return 1
fi
diff --git a/sys-libs/gpm/gpm-1.20.7.ebuild b/sys-libs/gpm/gpm-1.20.7.ebuild
new file mode 100644
index 000000000000..22df5d47095a
--- /dev/null
+++ b/sys-libs/gpm/gpm-1.20.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.7.ebuild,v 1.1 2012/10/28 11:35:56 vapier Exp $
+
+# emacs support disabled due to #99533 #335900
+
+EAPI="4"
+
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="Console-based mouse driver"
+HOMEPAGE="http://www.nico.schottelius.org/software/gpm/"
+SRC_URI="http://www.nico.schottelius.org/software/${PN}/archives/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux static-libs"
+
+RDEPEND="sys-libs/ncurses
+ selinux? ( sec-policy/selinux-gpm )"
+DEPEND="sys-libs/ncurses
+ app-arch/xz-utils
+ virtual/yacc"
+
+src_prepare() {
+ # fix ABI values
+ sed -i \
+ -e '/^abi_lev=/s:=.*:=1:' \
+ -e '/^abi_age=/s:=.*:=20:' \
+ configure.ac.footer || die
+ sed -i -e '/ACLOCAL/,$d' autogen.sh || die
+ ./autogen.sh
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/gpm \
+ $(use_enable static-libs static) \
+ emacs=/bin/false
+}
+
+src_compile() {
+ # make sure nothing compiled is left
+ emake clean
+ emake EMACS=:
+}
+
+src_install() {
+ emake install DESTDIR="${D}" EMACS=: ELISP=""
+
+ dosym libgpm.so.1 /usr/$(get_libdir)/libgpm.so
+ gen_usr_ldscript -a gpm
+
+ insinto /etc/gpm
+ doins conf/gpm-*.conf
+
+ dodoc README TODO
+ dodoc doc/Announce doc/FAQ doc/README*
+
+ newinitd "${FILESDIR}"/gpm.rc6-2 gpm
+ newconfd "${FILESDIR}"/gpm.conf.d gpm
+}