summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-02-16 00:47:43 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-02-16 00:47:43 +0000
commit704257550b7c903d98141cacbe914814bc7f45ad (patch)
tree958d22bc7d7b84cf51db808f60e865dfd16e4cfd /sys-libs
parentTightened the things up a little more, ion further feedback from (diff)
downloadgentoo-2-704257550b7c903d98141cacbe914814bc7f45ad.tar.gz
gentoo-2-704257550b7c903d98141cacbe914814bc7f45ad.tar.bz2
gentoo-2-704257550b7c903d98141cacbe914814bc7f45ad.zip
new glibc that should fix bug #695 for glibc.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/files/digest-glibc-2.2.5-r12
-rw-r--r--sys-libs/glibc/glibc-2.2.5-r1.ebuild (renamed from sys-libs/glibc/glibc-2.2.5.ebuild)30
2 files changed, 24 insertions, 8 deletions
diff --git a/sys-libs/glibc/files/digest-glibc-2.2.5-r1 b/sys-libs/glibc/files/digest-glibc-2.2.5-r1
new file mode 100644
index 000000000000..acc05c85ba28
--- /dev/null
+++ b/sys-libs/glibc/files/digest-glibc-2.2.5-r1
@@ -0,0 +1,2 @@
+MD5 5be613d02b934d8e305dd2f93062fa6c glibc-2.2.5.tar.bz2 12404613
+MD5 33b9ae01d51263867d338adfba105278 glibc-linuxthreads-2.2.5.tar.bz2 168269
diff --git a/sys-libs/glibc/glibc-2.2.5.ebuild b/sys-libs/glibc/glibc-2.2.5-r1.ebuild
index 58fd2fa2608a..26b1dab453d4 100644
--- a/sys-libs/glibc/glibc-2.2.5.ebuild
+++ b/sys-libs/glibc/glibc-2.2.5-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5.ebuild,v 1.3 2002/02/11 17:28:22 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r1.ebuild,v 1.1 2002/02/16 00:47:43 drobbins Exp $
S=${WORKDIR}/${P}
DESCRIPTION="GNU libc6 (also called glibc2) C library"
@@ -29,13 +29,13 @@ export CFLAGS="$CFLAGS -O2"
export CXXFLAGS="$CFLAGS"
src_unpack() {
- unpack glibc-${PV}.tar.bz2
+ unpack glibc-${PV}.tar.bz2 || die
cd ${S}
#extract pre-made man pages. Otherwise we need perl, which is a no-no.
mkdir man; cd man
- tar xjf ${FILESDIR}/glibc-manpages-${PV}.tar.bz2
+ tar xjf ${FILESDIR}/glibc-manpages-${PV}.tar.bz2 || die
cd ${S}
- unpack glibc-linuxthreads-${PV}.tar.bz2
+ unpack glibc-linuxthreads-${PV}.tar.bz2 || die
# This patch apparently eliminates compiler warnings for some versions of gcc.
# For information about the string2 patch, see:
@@ -111,10 +111,7 @@ src_install() {
mv ${i} ${i%.map}_pic.map
done
fi
- rm ${D}/lib/ld-linux.so.2
- rm ${D}/lib/libc.so.6
- rm ${D}/lib/libpthread.so.0
- #is this next line actually needed or does the makefile get it right.
+ #is this next line actually needed or does the makefile get it right?
#It previously has 0755 perms which was killing things.
chmod 4755 ${D}/usr/lib/misc/pt_chown
rm -f ${D}/etc/ld.so.cache
@@ -127,8 +124,25 @@ src_install() {
dosym /usr/lib/libbsd-compat.a /usr/lib/libbsd.a
}
+pkg_preinst() {
+ #we need to ensure that symlinks are installed *after* the real libraries; otherwise we can get symlink death.
+ #This needs to be generalized into Portage to it automatically works for other packages too.
+ mkdir -f ${T}/symlinks
+ cd ${D}/lib
+ local x
+ for x in *
+ do
+ if [ -L $x ]
+ then
+ mv $x ${T}/symlinks
+ fi
+ done
+}
+
pkg_postinst()
{
+ #restore symlinks
+ mv -f ${T}/symlinks/* ${ROOT}/lib
if [ ! -e ${ROOT}etc/localtime ]
then
echo "Please remember to set your timezone using the zic command."