summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2005-03-29 12:50:19 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2005-03-29 12:50:19 +0000
commit61d477a7e066789697e730786b89d1acbdc4a062 (patch)
treebe51ac42d6973c17b2ac197311d8b9c3d7b2c6a2 /sys-libs
parentRevision bump; updated tar completion so -xf will work with both gzip and bzi... (diff)
downloadgentoo-2-61d477a7e066789697e730786b89d1acbdc4a062.tar.gz
gentoo-2-61d477a7e066789697e730786b89d1acbdc4a062.tar.bz2
gentoo-2-61d477a7e066789697e730786b89d1acbdc4a062.zip
Fix silly cd error
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog16
-rw-r--r--sys-libs/db/db-3.2.9-r10.ebuild4
-rw-r--r--sys-libs/db/db-4.3.27.ebuild122
-rw-r--r--sys-libs/db/files/db-4.3-jarlocation.patch16
-rw-r--r--sys-libs/db/files/db-4.3-libtool.patch47
-rw-r--r--sys-libs/db/files/db-4.3.27-fix-dep-link.patch38
-rw-r--r--sys-libs/db/files/digest-db-4.3.271
7 files changed, 241 insertions, 3 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index c47a534553ce..759883e98674 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/db
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.117 2005/03/28 16:55:33 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.118 2005/03/29 12:50:19 pauldv Exp $
+
+*db-4.3.27 (29 Mar 2005)
+
+ 29 Mar 2005; <pauldv@gentoo.org> +files/db-4.3-jarlocation.patch,
+ +files/db-4.3-libtool.patch, +files/db-4.3.27-fix-dep-link.patch,
+ db-3.2.9-r10.ebuild, +db-4.3.27.ebuild:
+ Fix silly cd error
28 Mar 2005; Jason Wever <weeve@gentoo.org> db-3.2.9-r10.ebuild:
Marked as ~sparc because this ebuild is brand new, improperly marked stable,
@@ -18,6 +25,13 @@
19 Mar 2005; Bryan Østergaard <kloeri@gentoo.org> db-4.1.25_p1-r4.ebuild:
Stable on alpha.
+*db-4.3.27 (02 Feb 2005)
+
+ 02 Feb 2005; <pauldv@gentoo.org> +files/db-4.3-jarlocation.patch,
+ +files/db-4.3-libtool.patch, +files/db-4.3.27-fix-dep-link.patch,
+ +db-4.3.27.ebuild:
+ A new upstream version. The patches are updated to apply again.
+
30 Jan 2005; Paul de Vrieze <pauldv@gentoo.org> db-1.85-r1.ebuild,
db-1.85-r2.ebuild, db-3.2.9-r10.ebuild, db-3.2.9-r7.ebuild,
db-4.0.14-r2.ebuild, db-4.0.14-r3.ebuild, db-4.1.25_p1-r3.ebuild,
diff --git a/sys-libs/db/db-3.2.9-r10.ebuild b/sys-libs/db/db-3.2.9-r10.ebuild
index 83dc0adf2535..799bb2fccdaa 100644
--- a/sys-libs/db/db-3.2.9-r10.ebuild
+++ b/sys-libs/db/db-3.2.9-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r10.ebuild,v 1.19 2005/03/28 16:55:33 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r10.ebuild,v 1.20 2005/03/29 12:50:19 pauldv Exp $
inherit gnuconfig libtool eutils db
@@ -55,9 +55,9 @@ src_unpack() {
rm -f config.guess
sed -i "s,\(-D_GNU_SOURCE\),\1 ${CFLAGS}," configure
+ cd ${S}
epatch ${FILESDIR}/${P}-jarlocation.patch
epatch ${FILESDIR}/db-3.2.9-java15.patch
- cd ${S}
gnuconfig_update
}
diff --git a/sys-libs/db/db-4.3.27.ebuild b/sys-libs/db/db-4.3.27.ebuild
new file mode 100644
index 000000000000..72643f512c33
--- /dev/null
+++ b/sys-libs/db/db-4.3.27.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.3.27.ebuild,v 1.1 2005/03/29 12:50:19 pauldv Exp $
+
+inherit eutils gnuconfig db
+
+#Number of official patches
+#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
+PATCHNO=${PV/*.*.*_p}
+if [ "${PATCHNO}" == "${PV}" ]; then
+ MY_PV=${PV}
+ MY_P=${P}
+ PATCHNO=0
+else
+ MY_PV=${PV/_p${PATCHNO}}
+ MY_P=${PN}-${MY_PV}
+fi
+
+S=${WORKDIR}/${MY_P}/build_unix
+DESCRIPTION="Berkeley DB"
+HOMEPAGE="http://www.sleepycat.com/"
+SRC_URI="ftp://ftp.sleepycat.com/releases/${MY_P}.tar.gz"
+for (( i=1 ; i<=$PATCHNO ; i++ )) ; do
+ export SRC_URI="${SRC_URI} http://www.sleepycat.com/update/${MY_PV}/patch.${MY_PV}.${i}"
+done
+
+LICENSE="DB"
+SLOT="4.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="tcltk java doc nocxx bootstrap"
+
+DEPEND="tcltk? ( >=dev-lang/tcl-8.4 )
+ java? ( virtual/jdk )"
+RDEPEND="tcltk? ( dev-lang/tcl )
+ java? ( virtual/jre )"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd ${WORKDIR}/${MY_P}
+ for (( i=1 ; i<=$PATCHNO ; i++ ))
+ do
+ epatch ${DISTDIR}/patch.${MY_PV}.${i}
+ done
+ epatch ${FILESDIR}/${PN}-${SLOT}-jarlocation.patch
+ epatch ${FILESDIR}/${PN}-${SLOT}-libtool.patch
+
+ epatch ${FILESDIR}/${PN}-4.3.27-fix-dep-link.patch
+
+ gnuconfig_update "${S}/../dist"
+}
+
+src_compile() {
+ addwrite /proc/self/maps
+
+ local myconf=""
+
+ use amd64 && myconf="${myconf} --with-mutex=x86/gcc-assembly"
+
+ use bootstrap \
+ && myconf="${myconf} --disable-cxx" \
+ || myconf="${myconf} $(use_enable !nocxx cxx)"
+
+ use tcltk \
+ && myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
+ || myconf="${myconf} --disable-tcl"
+
+ myconf="${myconf} $(use_enable java)"
+ if use java && [[ -n ${JAVAC} ]] ; then
+ export PATH=`dirname ${JAVAC}`:${PATH}
+ export JAVAC=`basename ${JAVAC}`
+ fi
+
+ [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
+
+ ../dist/configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --libdir=/usr/$(get_libdir) \
+ --enable-compat185 \
+ --without-uniquename \
+ --enable-rpc \
+ --host=${CHOST} \
+ ${myconf} || die "configure failed"
+
+ emake || make || die "make failed"
+}
+
+src_install() {
+
+ einstall libdir="${D}/usr/$(get_libdir)" || die
+
+ db_src_install_usrbinslot
+
+ db_src_install_headerslot
+
+ db_src_install_doc
+
+ db_src_install_usrlibcleanup
+
+ dodir /usr/sbin
+ mv ${D}/usr/bin/berkeley_db_svc ${D}/usr/sbin/berkeley_db42_svc
+
+ if use java; then
+ mkdir -p ${D}/usr/share/db
+ cat <<EOF >${D}/usr/share/db/package.env
+DESCRIPTION=The java bindings for berkeley db version ${MY_PV}
+CLASSPATH=:/usr/lib/db-${SLOT}.jar
+EOF
+ fi
+}
+
+pkg_postinst () {
+ db_fix_so
+}
+
+pkg_postrm () {
+ db_fix_so
+}
diff --git a/sys-libs/db/files/db-4.3-jarlocation.patch b/sys-libs/db/files/db-4.3-jarlocation.patch
new file mode 100644
index 000000000000..17a342a7fca3
--- /dev/null
+++ b/sys-libs/db/files/db-4.3-jarlocation.patch
@@ -0,0 +1,16 @@
+diff -ur db-4.1.25.old/dist/Makefile.in db-4.1.25/dist/Makefile.in
+--- db-4.1.25.old/dist/Makefile.in 2003-10-18 02:15:45.000000000 -0700
++++ db-4.1.25/dist/Makefile.in 2003-10-18 02:13:47.000000000 -0700
+@@ -107,9 +107,9 @@
+ JAVA_EXDIR= $(JAVA_SRCDIR)/$(JAVA_EXREL)
+ JAVA_RPCDIR= $(srcdir)/rpc_server/java
+
+-libj_jarfile= db.jar
+-libj_exjarfile= dbexamples.jar
+-rpc_jarfile= dbsvc.jar
++libj_jarfile= db-4.3.jar
++libj_exjarfile= dbexamples-4.3.jar
++rpc_jarfile= dbsvc-4.3.jar
+ libjso_base= libdb_java
+ libjso= $(libjso_base)-$(SOVERSION).@JMODSUFFIX@
+ libjso_static= $(libjso_base)-$(SOVERSION).a
diff --git a/sys-libs/db/files/db-4.3-libtool.patch b/sys-libs/db/files/db-4.3-libtool.patch
new file mode 100644
index 000000000000..426fd519f714
--- /dev/null
+++ b/sys-libs/db/files/db-4.3-libtool.patch
@@ -0,0 +1,47 @@
+--- dist/configure.orig 2005-02-02 11:22:49.596096072 +0100
++++ dist/configure 2005-02-02 11:23:46.749407448 +0100
+@@ -5684,7 +5684,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ # I'd rather use --version here, but apparently some GNU ld's only accept -v.
+-case `$LD -v 2>&1 </dev/null` in
++case `"$LD" -v 2>&1 </dev/null` in
+ *GNU* | *'with BFD'*)
+ lt_cv_prog_gnu_ld=yes
+ ;;
+@@ -8461,7 +8461,7 @@
+ tmp_archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+ archive_cmds="$tmp_archive_cmds"
+ supports_anon_versioning=no
+- case `$LD -v 2>/dev/null` in
++ case `"$LD" -v 2>/dev/null` in
+ *\ 01.* | *\ 2.[0-9].* | *\ 2.10.*) ;; # catch versions < 2.11
+ *\ 2.11.93.0.2\ *) supports_anon_versioning=yes ;; # RH7.3 ...
+ *\ 2.11.92.0.12\ *) supports_anon_versioning=yes ;; # Mandrake 8.2 ...
+@@ -11383,7 +11383,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ # I'd rather use --version here, but apparently some GNU ld's only accept -v.
+-case `$LD -v 2>&1 </dev/null` in
++case `"$LD" -v 2>&1 </dev/null` in
+ *GNU* | *'with BFD'*)
+ lt_cv_prog_gnu_ld=yes
+ ;;
+@@ -15353,7 +15353,7 @@
+ tmp_archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+ archive_cmds_F77="$tmp_archive_cmds"
+ supports_anon_versioning=no
+- case `$LD -v 2>/dev/null` in
++ case `"$LD" -v 2>/dev/null` in
+ *\ 01.* | *\ 2.[0-9].* | *\ 2.10.*) ;; # catch versions < 2.11
+ *\ 2.11.93.0.2\ *) supports_anon_versioning=yes ;; # RH7.3 ...
+ *\ 2.11.92.0.12\ *) supports_anon_versioning=yes ;; # Mandrake 8.2 ...
+@@ -17695,7 +17695,7 @@
+ tmp_archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+ archive_cmds_GCJ="$tmp_archive_cmds"
+ supports_anon_versioning=no
+- case `$LD -v 2>/dev/null` in
++ case `"$LD" -v 2>/dev/null` in
+ *\ 01.* | *\ 2.[0-9].* | *\ 2.10.*) ;; # catch versions < 2.11
+ *\ 2.11.93.0.2\ *) supports_anon_versioning=yes ;; # RH7.3 ...
+ *\ 2.11.92.0.12\ *) supports_anon_versioning=yes ;; # Mandrake 8.2 ...
diff --git a/sys-libs/db/files/db-4.3.27-fix-dep-link.patch b/sys-libs/db/files/db-4.3.27-fix-dep-link.patch
new file mode 100644
index 000000000000..1d14e83d078c
--- /dev/null
+++ b/sys-libs/db/files/db-4.3.27-fix-dep-link.patch
@@ -0,0 +1,38 @@
+--- db-4.3.27/dist/Makefile.in.chris 2005-02-01 23:40:34.447945464 +0100
++++ db-4.3.27/dist/Makefile.in 2005-02-01 23:42:21.635650456 +0100
+@@ -58,7 +58,7 @@
+ LDFLAGS= @LDFLAGS@
+ LIBS= @LIBS@
+ TEST_LIBS= @TEST_LIBS@
+-LIBSO_LIBS= @LIBSO_LIBS@
++LIBSO_LIBS= @LIBSO_LIBS@ $(LIBS)
+
+ libdb_base= libdb
+ libdb= $(libdb_base).a
+@@ -77,7 +77,7 @@
+ CXX= @MAKEFILE_CXX@
+ CXXLINK= @MAKEFILE_CXXLINK@ @CXXFLAGS@
+ XSOLINK= @MAKEFILE_XSOLINK@ @CXXFLAGS@
+-LIBXSO_LIBS= @LIBXSO_LIBS@
++LIBXSO_LIBS= @LIBXSO_LIBS@ $(LIBS)
+
+ libcxx_base= libdb_cxx
+ libcxx= $(libcxx_base).a
+@@ -93,7 +93,7 @@
+ # Java support is optional and requires shared librarires.
+ ##################################################
+ CLASSPATH= $(JAVA_CLASSTOP)
+-LIBJSO_LIBS= @LIBJSO_LIBS@
++LIBJSO_LIBS= @LIBJSO_LIBS@ $(LIBS)
+
+ JAR= @JAR@
+ JAVAC= env CLASSPATH="$(CLASSPATH)" @JAVAC@
+@@ -126,7 +126,7 @@
+ # Tcl support is optional and requires shared libraries.
+ ##################################################
+ TCFLAGS= @TCFLAGS@
+-LIBTSO_LIBS= @LIBTSO_LIBS@
++LIBTSO_LIBS= @LIBTSO_LIBS@ $(LIBS)
+ libtso_base= libdb_tcl
+ libtso= $(libtso_base)-$(LIBVERSION)@MODSUFFIX@
+ libtso_static= $(libtso_base)-$(LIBVERSION).a
diff --git a/sys-libs/db/files/digest-db-4.3.27 b/sys-libs/db/files/digest-db-4.3.27
new file mode 100644
index 000000000000..3089181ae1af
--- /dev/null
+++ b/sys-libs/db/files/digest-db-4.3.27
@@ -0,0 +1 @@
+MD5 fcc481d52c3b80e20a328f8c0cb042bd db-4.3.27.tar.gz 5921872