summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-02-27 08:09:09 +0000
committerMike Frysinger <vapier@gentoo.org>2015-02-27 08:09:09 +0000
commit61b90e8bda6cef61a8953dfe33f2956f3c6ebb1c (patch)
treefecd1778ad9ffb40b23096b724d9a06515acd995 /sys-libs
parentUse more readable CTARGET setup logic. (diff)
downloadgentoo-2-61b90e8bda6cef61a8953dfe33f2956f3c6ebb1c.tar.gz
gentoo-2-61b90e8bda6cef61a8953dfe33f2956f3c6ebb1c.tar.bz2
gentoo-2-61b90e8bda6cef61a8953dfe33f2956f3c6ebb1c.zip
Use more readable CTARGET setup logic.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libspe2/ChangeLog8
-rw-r--r--sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild9
-rw-r--r--sys-libs/libspe2/libspe2-2.3.0_p135.ebuild9
3 files changed, 14 insertions, 12 deletions
diff --git a/sys-libs/libspe2/ChangeLog b/sys-libs/libspe2/ChangeLog
index d5265f3c9aba..f5b585cf41ec 100644
--- a/sys-libs/libspe2/ChangeLog
+++ b/sys-libs/libspe2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libspe2
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libspe2/ChangeLog,v 1.6 2012/09/14 22:44:47 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libspe2/ChangeLog,v 1.7 2015/02/27 08:09:09 vapier Exp $
+
+ 27 Feb 2015; Mike Frysinger <vapier@gentoo.org> libspe2-2.2.80_p95-r1.ebuild,
+ libspe2-2.3.0_p135.ebuild:
+ Use more readable CTARGET setup logic.
14 Sep 2012; Agostino Sarubbo <ago@gentoo.org> libspe2-2.2.80_p95-r1.ebuild,
libspe2-2.3.0_p135.ebuild:
diff --git a/sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild b/sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild
index 1e9a6e8ef5be..49d55245afee 100644
--- a/sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild
+++ b/sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild,v 1.4 2012/09/14 22:44:47 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild,v 1.5 2015/02/27 08:09:09 vapier Exp $
inherit eutils
MY_P=${P/_p/-}
@@ -22,10 +22,9 @@ RDEPEND="!sys-libs/libspe"
export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}
-
if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
fi
fi
diff --git a/sys-libs/libspe2/libspe2-2.3.0_p135.ebuild b/sys-libs/libspe2/libspe2-2.3.0_p135.ebuild
index 26cf96d8e40b..33e80607eb04 100644
--- a/sys-libs/libspe2/libspe2-2.3.0_p135.ebuild
+++ b/sys-libs/libspe2/libspe2-2.3.0_p135.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libspe2/libspe2-2.3.0_p135.ebuild,v 1.2 2012/09/14 22:44:47 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libspe2/libspe2-2.3.0_p135.ebuild,v 1.3 2015/02/27 08:09:09 vapier Exp $
inherit eutils
MY_P=${P/_p/.}
@@ -22,10 +22,9 @@ RDEPEND="!sys-libs/libspe"
export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}
-
if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
fi
fi