summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-01-21 21:01:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-01-21 21:01:49 +0000
commit5c15a42b6cf630f0a102575e3147f855fb16e8d5 (patch)
tree67ee64a2292584e094cbe62ff7027bab0a7a9d06 /sys-libs
parentRename dev-perl/sdl-perl to dev-perl/SDL. (diff)
downloadgentoo-2-5c15a42b6cf630f0a102575e3147f855fb16e8d5.tar.gz
gentoo-2-5c15a42b6cf630f0a102575e3147f855fb16e8d5.tar.bz2
gentoo-2-5c15a42b6cf630f0a102575e3147f855fb16e8d5.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/freeipmi/ChangeLog10
-rw-r--r--sys-libs/freeipmi/files/freeipmi-1.1.1-strictaliasing.patch13
-rw-r--r--sys-libs/freeipmi/freeipmi-1.1.1.ebuild73
3 files changed, 94 insertions, 2 deletions
diff --git a/sys-libs/freeipmi/ChangeLog b/sys-libs/freeipmi/ChangeLog
index c26100f25456..8ebeb88cc2ae 100644
--- a/sys-libs/freeipmi/ChangeLog
+++ b/sys-libs/freeipmi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/freeipmi
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/freeipmi/ChangeLog,v 1.45 2011/12/14 03:58:02 flameeyes Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/freeipmi/ChangeLog,v 1.46 2012/01/21 21:01:48 robbat2 Exp $
+
+*freeipmi-1.1.1 (21 Jan 2012)
+
+ 21 Jan 2012; Robin H. Johnson <robbat2@gentoo.org>
+ +files/freeipmi-1.1.1-strictaliasing.patch, +freeipmi-1.1.1.ebuild:
+ Version bump.
*freeipmi-1.0.10 (14 Dec 2011)
diff --git a/sys-libs/freeipmi/files/freeipmi-1.1.1-strictaliasing.patch b/sys-libs/freeipmi/files/freeipmi-1.1.1-strictaliasing.patch
new file mode 100644
index 000000000000..ecbb77f216fb
--- /dev/null
+++ b/sys-libs/freeipmi/files/freeipmi-1.1.1-strictaliasing.patch
@@ -0,0 +1,13 @@
+diff -Nuar freeipmi-1.1.1.orig/libfreeipmi/Makefile.am freeipmi-1.1.1/libfreeipmi/Makefile.am
+--- freeipmi-1.1.1.orig/libfreeipmi/Makefile.am 2012-01-02 19:26:00.000000000 +0000
++++ freeipmi-1.1.1/libfreeipmi/Makefile.am 2012-01-21 20:26:26.957801741 +0000
+@@ -25,7 +25,8 @@
+ -DIPMI_IPCKEY=\"$(localstatedir)/lib/$(PACKAGE_NAME)/ipckey\" \
+ -DIPMI_DEBUG_IPCKEY=\"$(top_builddir)/libfreeipmi/driver/ipmi-semaphores.h\" \
+ -D_GNU_SOURCE \
+- -D_REENTRANT
++ -D_REENTRANT \
++ -fno-strict-aliasing
+
+ libfreeipmi_la_LDFLAGS = \
+ -version-info @LIBFREEIPMI_VERSION_INFO@ $(VERSION_FLAGS) \
diff --git a/sys-libs/freeipmi/freeipmi-1.1.1.ebuild b/sys-libs/freeipmi/freeipmi-1.1.1.ebuild
new file mode 100644
index 000000000000..4a177a531d36
--- /dev/null
+++ b/sys-libs/freeipmi/freeipmi-1.1.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/freeipmi/freeipmi-1.1.1.ebuild,v 1.1 2012/01/21 21:01:48 robbat2 Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="Provides Remote-Console and System Management Software as per IPMI v1.5/2.0"
+HOMEPAGE="http://www.gnu.org/software/freeipmi/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ http://ftp.gluster.com/pub/${PN}/${PV}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/libgcrypt"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+RDEPEND="${RDEPEND}
+ sys-apps/openrc"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.1-strictaliasing.patch
+
+ AT_M4DIR="config" eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ --disable-static \
+ --disable-init-scripts \
+ --enable-logrotate-config \
+ --localstatedir=/var
+}
+
+# There are no tests
+src_test() { :; }
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install || die "emake install failed"
+ find "${D}" -name '*.la' -delete
+
+ # freeipmi by defaults install _all_ commands to /usr/sbin, but
+ # quite a few can be run remotely as standard user, so move them
+ # in /usr/bin afterwards.
+ dodir /usr/bin
+ for file in ipmi{detect,ping,power,console}; do
+ mv "${D}"/usr/{s,}bin/${file} || die
+
+ # The default install symlinks these commands to add a dash
+ # after the ipmi prefix; we repeat those after move for
+ # consistency.
+ rm "${D}"/usr/sbin/${file/ipmi/ipmi-}
+ dosym ${file} /usr/bin/${file/ipmi/ipmi-}
+ done
+
+ dodoc AUTHORS ChangeLog* DISCLAIMER* NEWS README* TODO doc/*.txt
+
+ keepdir \
+ /var/cache/ipmimonitoringsdrcache \
+ /var/lib/freeipmi \
+ /var/log/{freeipmi,ipmiconsole}
+
+ newinitd "${FILESDIR}"/ipmidetectd.initd.3 ipmidetectd
+
+ newinitd "${FILESDIR}"/bmc-watchdog.initd.3 bmc-watchdog
+ newconfd "${FILESDIR}"/bmc-watchdog.confd bmc-watchdog
+}