summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-04-06 09:59:53 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-04-06 09:59:53 +0000
commit5397885135862ee184148edb1f0da52a9ab635e2 (patch)
tree8580229584a68947ab0ee18699145ea309f59553 /sys-libs
parent"TV fonts installed this time" (diff)
downloadgentoo-2-5397885135862ee184148edb1f0da52a9ab635e2.tar.gz
gentoo-2-5397885135862ee184148edb1f0da52a9ab635e2.tar.bz2
gentoo-2-5397885135862ee184148edb1f0da52a9ab635e2.zip
*** empty log message ***
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog13
-rw-r--r--sys-libs/glibc/files/2.3.2/glibc-2.3.2-dl-reloc-calc-fix.patch44
-rw-r--r--sys-libs/glibc/files/digest-glibc-2.3.2-r157
-rw-r--r--sys-libs/glibc/glibc-2.3.1-r2.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.1-r3.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.1-r4.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r1.ebuild499
-rw-r--r--sys-libs/glibc/glibc-2.3.2.ebuild7
8 files changed, 636 insertions, 5 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 3dda3df52cd3..f7446f6554e7 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.54 2003/04/06 03:11:16 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.55 2003/04/06 09:59:53 azarah Exp $
+
+ 06 Apr 2003; Martin Schlemmer <azarah@gentoo.org> :
+ Fix all 2.3 ebuild to install timezone data if 'build' in USE, bug #16530.
+
+*glibc-2.3.2-r1 (06 Apr 2003)
+
+ 06 Apr 2003; Martin Schlemmer <azarah@gentoo.org> glibc-2.3.2-r1.ebuild :
+ Fix calculation problems in allocate_static_tls that caused a TLS
+ enabled app that loads libGL.so to segfault. Thanks to Gareth Hughes
+ from NVidia for pointing me in the right direction. This patch is
+ from glibc CVS.
30 Mar 2003; Martin Schlemmer <azarah@gentoo.org> glibc-2.3.2.ebuild :
Update NPTL version to 0.29. As it is not used by many (or I cannot
diff --git a/sys-libs/glibc/files/2.3.2/glibc-2.3.2-dl-reloc-calc-fix.patch b/sys-libs/glibc/files/2.3.2/glibc-2.3.2-dl-reloc-calc-fix.patch
new file mode 100644
index 000000000000..f7456821f477
--- /dev/null
+++ b/sys-libs/glibc/files/2.3.2/glibc-2.3.2-dl-reloc-calc-fix.patch
@@ -0,0 +1,44 @@
+===================================================================
+RCS file: /cvs/glibc/libc/elf/dl-reloc.c,v
+retrieving revision 1.82
+retrieving revision 1.83
+diff -u -r1.82 -r1.83
+--- libc/elf/dl-reloc.c 2003/01/30 17:36:11 1.82
++++ libc/elf/dl-reloc.c 2003/03/01 22:31:52 1.83
+@@ -44,23 +44,31 @@
+ static void __attribute_noinline__
+ allocate_static_tls (struct link_map *map)
+ {
+- size_t offset = roundup (GL(dl_tls_static_used), map->l_tls_align);
+- if (offset + map->l_tls_blocksize
++ size_t offset, used, check;
++
+ # if TLS_TCB_AT_TP
+- + TLS_TCB_SIZE
++ offset = roundup (GL(dl_tls_static_used) + map->l_tls_blocksize,
++ map->l_tls_align);
++ used = offset;
++ check = offset + TLS_TCB_SIZE;
+ # elif TLS_DTV_AT_TP
++ offset = roundup (GL(dl_tls_static_used), map->l_tls_align);
++ used = offset + map->l_tls_blocksize;
++ check = used;
+ /* dl_tls_static_used includes the TCB at the beginning. */
+ # else
+ # error "Either TLS_TCB_AT_TP or TLS_DTV_AT_TP must be defined"
+ # endif
+- > GL(dl_tls_static_size))
++
++ if (check > GL(dl_tls_static_size))
+ {
+ const char *errstring = N_("\
+ shared object cannot be dlopen()ed: static TLS memory too small");
+ INTUSE(_dl_signal_error) (0, (map)->l_name, NULL, errstring);
+ }
++
+ map->l_tls_offset = offset;
+- GL(dl_tls_static_used) = offset + map->l_tls_blocksize;
++ GL(dl_tls_static_used) = used;
+ }
+ #endif
+
diff --git a/sys-libs/glibc/files/digest-glibc-2.3.2-r1 b/sys-libs/glibc/files/digest-glibc-2.3.2-r1
new file mode 100644
index 000000000000..d069bcc71e37
--- /dev/null
+++ b/sys-libs/glibc/files/digest-glibc-2.3.2-r1
@@ -0,0 +1,57 @@
+MD5 52cfc7627fc62dfb26d8d163aac361f6 /files/glibc-2.2.2-test-lfs-timeout.patch 320
+MD5 135f8145885a2f4f9876fe973f33ddf6 /files/glibc-2.2.4-string2.h.diff 5221
+MD5 b712a49b5113fccb4c8b0ada2a30d390 /files/glibc-manpages-2.2.5.tar.bz2 14610
+MD5 c02420990c4908a6336d81ea5192a37e /files/glibc-manpages-2.3.1.tar.bz2 14755
+MD5 82be016c42c7cc353ee563fcbcbc4769 /files/nscd 840
+MD5 d8830438ea871dbfd1acf7a3d0299159 /files/test-__thread.c 53
+MD5 184eddb92615fb991dce41b9edbfa690 /files/glibc-manpages-2.3.2.tar.bz2 14700
+MD5 d688e44731d6e4b757382d7646c492c3 /files/glibc-xdr_security.patch 6612
+MD5 f75ebd335c4b882013cc12229d39c9f7 /files/2.2.5/glibc-2.2.5-alpha-gcc3-fix.diff 475
+MD5 843eaa26ae2c49e894aa365b6f463546 /files/2.2.5/glibc-2.2.5-alpha-pcdyn-fix.diff 471
+MD5 93c2f3cb1c07d9a39da245b065c74f6c /files/2.2.5/glibc-2.2.5-divdi3.diff 9752
+MD5 b12e1a7de85cd82bcb341863643c9ffd /files/2.2.5/glibc-2.2.5-dns-network-overflow.diff 365
+MD5 7481046043f42ecf4ac0a218abc896fc /files/2.2.5/glibc-2.2.5-gcc311.patch 534
+MD5 b07a316cbba4ddc1e1bb094a3056f12f /files/2.2.5/glibc-2.2.5-ppc-semctl.diff 1337
+MD5 c34a3c6bf21274a506090f05b7ea60ff /files/2.2.5/glibc-2.2.5-ppc-sqrtl.diff 715
+MD5 c7783e49497814c3d86bd63bbed2a9b3 /files/2.2.5/glibc-2.2.5-sandbox.diff 438
+MD5 a12b84b5af2808f5c0223259f7a9610c /files/2.2.5/glibc-2.2.5-sparc-mathinline.patch 1014
+MD5 6bdfb930ffdfdeb6b2ee823fefe42513 /files/2.2.5/glibc-2.2.5-sparc-misc.diff 12252
+MD5 96914104dbdc2807c84549c3d20cb47c /files/2.2.5/glibc-2.2.5-sparc32-semctl.patch 6311
+MD5 6afbd6fe65c0e2034587ba6d1da427a3 /files/2.2.5/glibc-2.2.5-sparc64-fixups.diff 1407
+MD5 e6dc1e4d7839d2bb08c6865466791183 /files/2.2.5/glibc-2.2.5-sunrpc-overflow.diff 2460
+MD5 993732f56fdecf36f672198112fc5d5c /files/2.2.5/glibc-2.2.5-threadsig.diff 636
+MD5 a50da56218f9aabc347d7e1130961cec /files/2.2.5/glibc-2.2.5.divbyzero.patch 1694
+MD5 e9d9d086e8ed29ed49252d4cd0050f66 /files/2.2.5/glibc-2.2.5.restrict_arr.patch 762
+MD5 5182f441608833569cb9e78536baf8af /files/2.2.5/glibc-2.2.5-arm-errlist-fix.diff 2210
+MD5 56a7a0273e0666eb40b0c6b45d62881d /files/2.2.5/glibc-2.2.5-arm-sysdeps-fix.diff 362
+MD5 21506827cc2094c80d3c0c0e8ef3569c /files/2.3.1/glibc-2.3.1-ctype-compat-v2.patch 1468
+MD5 66d8b78875e17e2d385a4d52af9698c4 /files/2.3.1/glibc-2.3.1-ctype-compat.patch 728
+MD5 1c4e567ed001f9489e11ee06c1ced0b7 /files/2.3.1/glibc-2.3.1-libc_wait-compat.patch 1053
+MD5 cdbf2aacfaae7737f89ae733f148169c /files/2.3.1/glibc-2.3.1-prelinkfix.patch 5005
+MD5 d84791059f1b4e7b157b3bbefe783208 /files/2.3.1/glibc-2.3.1-stack_end-compat.patch 751
+MD5 941f13d27badc76c1e3704c59acaff26 /files/2.3.1/glibc-2.3.1-ctype-compat-v3.patch 2823
+MD5 4f8ecd70003c5ca153ff7c204c54c1cf /files/2.3.1/glibc-2.3.1-elf-machine-rela-mips.patch 1246
+MD5 afaf2540d2803ac066eb2555f2019a6f /files/2.3.1/glibc-2.3.1-exit-syscall-mips.patch 633
+MD5 67b125cec4f1f0d26ce4df706451fee6 /files/2.3.1/glibc-2.3.1-fpu-cw-mips.patch 433
+MD5 235976914abfab3408d8d63cb4ffebe2 /files/2.3.1/glibc-2.3.1-inline-syscall-mips.patch 7753
+MD5 23bbb51d1008f3009e6f1867b284c9bc /files/2.3.1/glibc-2.3.1-libgcc-compat-mips.patch 5222
+MD5 f15c6dec40cefa86dae48a7dcb3b779a /files/2.3.1/glibc-2.3.1-librt-mips.patch 396
+MD5 2474bda0015ede78a23190c3051a599b /files/2.3.1/glibc-2.3.1-tst-rndseek-mips.patch 446
+MD5 e1cbb66f3d9823cf5a05ce52b2223acf /files/2.3.1/glibc-2.3.1-ulps-mips.patch 27618
+MD5 1968bc39ae8224c1dee9534781203d2e /files/2.3.1/glibc-2.3.1-locale.patch 8666
+MD5 5a528678247e6bafe92d2483383afd5b /files/2.3.1/glibc23-00-hppa-pthreads.dpatch 29951
+MD5 b8f6b8b0ed8649fc9af439adef7472f2 /files/2.3.1/glibc23-01-hppa-dl-machine.dpatch 12226
+MD5 7f8ec486f1669036429acc8b272c453e /files/2.3.1/glibc23-02-hppa-min-kern-unwind-fde.dpatch 1728
+MD5 a49946706c7f248294896eeb64308a09 /files/2.3.1/glibc23-03-hppa-mcontext.dpatch 1402
+MD5 035d42c51f2397339c1518baa06e3a81 /files/2.3.1/glibc23-04-hppa-fcntl64.dpatch 2085
+MD5 a91843899c8ef4b59341313915f177b4 /files/2.3.1/glibc23-05-hppa-buildhack.dpatch 1134
+MD5 2b746db4988cf7f5c6824302561b7eb5 /files/2.3.1/glibc23-06-hppa-tests.dpatch 21021
+MD5 dc18731db5bd28b8bd2074fc9177fd35 /files/2.3.1/glibc23-07-hppa-atomicity.dpatch 2519
+MD5 41599dc27ba12b5f2428056dc0ebb1d1 /files/2.3.1/glibc23-08-hppa-configure.dpatch 4704
+MD5 1e95cbf4aed1619831947cdd35c73108 /files/2.3.1/glibc23-hppa-shmlba.dpatch 1754
+MD5 75983ceba061c090373c14394d08d32c /files/2.3.1/glibc-2.3.1-typeo_dl-runtime_c.patch 848
+MD5 1a926f1adc2f321abb31b1e11024e3ac /files/2.3.2/glibc-2.3.2-dl-reloc-calc-fix.patch 1405
+MD5 20f25afeb0e636de2dadedd49f3517a9 /glibc-2.3.2-r1.ebuild 14484
+MD5 ede969aad568f48083e413384f20753c glibc-2.3.2.tar.bz2 13377170
+MD5 894b8969cfbdf787c73e139782167607 glibc-linuxthreads-2.3.2.tar.bz2 216310
+MD5 d1f6f3b48ab60c753b6bdeec9208d393 nptl-0.29.tar.bz2 152937
diff --git a/sys-libs/glibc/glibc-2.3.1-r2.ebuild b/sys-libs/glibc/glibc-2.3.1-r2.ebuild
index 57e8d50eb8c2..1c0ecf861a44 100644
--- a/sys-libs/glibc/glibc-2.3.1-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r2.ebuild,v 1.20 2003/03/11 11:34:14 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r2.ebuild,v 1.21 2003/04/06 09:59:53 azarah Exp $
IUSE="nls pic build"
@@ -238,6 +238,11 @@ src_install() {
NEWS NOTES PROJECTS README*
else
rm -rf ${D}/usr/share ${D}/usr/lib/gconv
+
+ einfo "Installing Timezone data..."
+ make PARALLELMFLAGS="${MAKEOPTS}" \
+ install_root=${D} \
+ timezone/install-others -C buildhere || die
fi
if [ "`use pic`" ]
diff --git a/sys-libs/glibc/glibc-2.3.1-r3.ebuild b/sys-libs/glibc/glibc-2.3.1-r3.ebuild
index be6d580f54dd..56ccd08fbaae 100644
--- a/sys-libs/glibc/glibc-2.3.1-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.3.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r3.ebuild,v 1.8 2003/03/11 11:34:14 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r3.ebuild,v 1.9 2003/04/06 09:59:53 azarah Exp $
IUSE="nls pic build"
@@ -248,6 +248,11 @@ src_install() {
NEWS NOTES PROJECTS README*
else
rm -rf ${D}/usr/share ${D}/usr/lib/gconv
+
+ einfo "Installing Timezone data..."
+ make PARALLELMFLAGS="${MAKEOPTS}" \
+ install_root=${D} \
+ timezone/install-others -C buildhere || die
fi
if [ "`use pic`" ]
diff --git a/sys-libs/glibc/glibc-2.3.1-r4.ebuild b/sys-libs/glibc/glibc-2.3.1-r4.ebuild
index 6510d308e2a3..c17e6b1e787e 100644
--- a/sys-libs/glibc/glibc-2.3.1-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.3.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r4.ebuild,v 1.4 2003/04/06 02:58:19 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r4.ebuild,v 1.5 2003/04/06 09:59:53 azarah Exp $
IUSE="nls pic build"
@@ -251,6 +251,11 @@ src_install() {
NEWS NOTES PROJECTS README*
else
rm -rf ${D}/usr/share ${D}/usr/lib/gconv
+
+ einfo "Installing Timezone data..."
+ make PARALLELMFLAGS="${MAKEOPTS}" \
+ install_root=${D} \
+ timezone/install-others -C buildhere || die
fi
if [ "`use pic`" ]
diff --git a/sys-libs/glibc/glibc-2.3.2-r1.ebuild b/sys-libs/glibc/glibc-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..9380b348d9b0
--- /dev/null
+++ b/sys-libs/glibc/glibc-2.3.2-r1.ebuild
@@ -0,0 +1,499 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r1.ebuild,v 1.1 2003/04/06 09:59:53 azarah Exp $
+
+IUSE="nls pic build nptl"
+
+inherit eutils flag-o-matic gcc
+
+filter-flags "-fomit-frame-pointer -malign-double"
+
+# Recently there has been a lot of stability problem in Gentoo-land. Many
+# things can be the cause to this, but I believe that it is due to gcc3
+# still having issues with optimizations, or with it not filtering bad
+# combinations (protecting the user maybe from himeself) yet.
+#
+# This can clearly be seen in large builds like glibc, where too aggressive
+# CFLAGS cause the tests to fail miserbly.
+#
+# Quote from Nick Jones <carpaski@gentoo.org>, who in my opinion
+# knows what he is talking about:
+#
+# People really shouldn't force code-specific options on... It's a
+# bad idea. The -march options aren't just to look pretty. They enable
+# options that are sensible (and include sse,mmx,3dnow when apropriate).
+#
+# The next command strips CFLAGS and CXXFLAGS from nearly all flags. If
+# you do not like it, comment it, but do not bugreport if you run into
+# problems.
+#
+# <azarah@gentoo.org> (13 Oct 2002)
+strip-flags
+
+# Lock glibc at -O2 -- linuxthreads needs it and we want to be conservative here
+export CFLAGS="${CFLAGS//-O?} -O2"
+export CXXFLAGS="${CFLAGS}"
+
+NPTL_VER="0.29"
+
+# Minimum kernel version for --enable-kernel
+export MIN_KV="2.4.1"
+# Minimum kernel version for enabling TLS and NPTL ...
+# NOTE: do not change this if you do not know what
+# you are doing !
+export MIN_NPTL_KV="2.5.50"
+
+MY_PV="${PV/_}"
+S="${WORKDIR}/${P%_*}"
+DESCRIPTION="GNU libc6 (also called glibc2) C library"
+SRC_URI="http://ftp.gnu.org/gnu/glibc/glibc-${MY_PV}.tar.bz2
+ ftp://sources.redhat.com/pub/glibc/snapshots/glibc-${MY_PV}.tar.bz2
+ http://ftp.gnu.org/gnu/glibc/glibc-linuxthreads-${MY_PV}.tar.bz2
+ ftp://sources.redhat.com/pub/glibc/snapshots/glibc-linuxthreads-${MY_PV}.tar.bz2
+ nptl? ( http://people.redhat.com/drepper/nptl/nptl-${NPTL_VER}.tar.bz2 )"
+HOMEPAGE="http://www.gnu.org/software/libc/libc.html"
+
+KEYWORDS="~x86 ~ppc -sparc ~alpha ~hppa ~arm"
+# Is 99% compadible, just some .a's bork
+SLOT="2.2"
+LICENSE="GPL-2"
+
+# Portage-1.8.9 needed for smart library merging feature (avoids segfaults on glibc upgrade)
+# Drobbins, 18 Mar 2002: we now rely on the system profile to select the correct linus-headers
+DEPEND=">=sys-devel/gcc-3.2.2
+ nptl? ( >=sys-devel/gcc-3.2.2-r1 )
+ >=sys-devel/binutils-2.13.90.0.18
+ virtual/os-headers
+ nls? ( sys-devel/gettext )"
+RDEPEND="virtual/os-headers
+ sys-apps/baselayout
+ nls? ( sys-devel/gettext )
+ build? ( >=sys-apps/portage-1.9.0 )"
+
+PROVIDE="virtual/glibc"
+
+
+# Convert a string type kernel version (2.4.0) to an int (132096)
+# for easy compairing or versions ...
+KV_to_int() {
+ [ -z "$1" ] && return 1
+
+ local KV="`echo $1 | \
+ awk '{ tmp = $0; gsub(/^[0-9\.]*/, "", tmp); sub(tmp, ""); print }'`"
+ local KV_MAJOR="`echo "${KV}" | cut -d. -f1`"
+ local KV_MINOR="`echo "${KV}" | cut -d. -f2`"
+ local KV_MICRO="`echo "${KV}" | cut -d. -f3`"
+ local KV_int="$((KV_MAJOR * 65536 + KV_MINOR * 256 + KV_MICRO))"
+
+ # We make version 2.2.0 the minimum version we will handle as
+ # a sanity check ... if its less, we fail ...
+ if [ "${KV_int}" -ge "131584" ]
+ then
+ echo "${KV_int}"
+
+ return 0
+ else
+ return 1
+ fi
+}
+
+get_KV() {
+ local KV="`uname -r`"
+
+ echo "`KV_to_int ${KV}`"
+
+ return $?
+}
+
+# Try to get a kernel source tree with version equal or greater
+# than $1. We basically just try a few default locations. The
+# version need to be that which KV_to_int() returns ...
+get_KHV() {
+ local headers=""
+
+ [ -z "$1" ] && return 1
+
+ # - First check if linux-headers are installed (or symlink
+ # to current kernel ...)
+ # - Ok, do we have access to the current kernel's headers ?
+ # - Last option ... maybe its a weird bootstrap with /lib
+ # binded to the chroot ...
+
+ # We do not really support more than 2 arguments ...
+ if [ -n "$2" ]
+ then
+ headers="$2"
+ else
+ # We try to find the current kernel's headers first,
+ # as we would rather build against linux 2.5 headers ...
+ headers="/lib/modules/`uname -r`/build/include \
+ ${ROOT}/lib/modules/`uname -r`/build/include \
+ /usr/src/linux/include \
+ ${ROOT}/usr/src/linux/include \
+ ${ROOT}/usr/include"
+ fi
+
+ for x in ${headers}
+ do
+ local header="${x}/linux/version.h"
+
+ if [ -f ${header} ]
+ then
+
+ local version="`grep 'LINUX_VERSION_CODE' ${header} | \
+ sed -e 's:^.*LINUX_VERSION_CODE[[:space:]]*::'`"
+
+ if [ "${version}" -ge "$1" ]
+ then
+ echo "${x}"
+
+ return 0
+ fi
+ fi
+ done
+
+ return 1
+}
+
+use_nptl() {
+ # Enable NPTL support if:
+ # - We have 'nptl' in USE
+ # - We have 'x86' in USE
+ # - We have linux-2.4 or later kernel (should prob check for 2.4.20 ...)
+ # - We have a CHOST of "i686-pc-linux-gnu"
+ if [ -n "`use nptl`" -a "`use x86`" -a \
+ "`get_KV`" -ge "`KV_to_int ${MIN_NPTL_KV}`" -a "${CHOST/-*}" = "i686" ]
+ then
+ return 0
+ else
+ return 1
+ fi
+}
+
+pkg_setup() {
+ # We need gcc 3.2 or later ...
+ if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]
+ then
+ echo
+ eerror "As of glibc-2.3, gcc-3.2 or later is needed"
+ eerror "for the build to succeed."
+ die "GCC too old"
+ fi
+
+ if use_nptl
+ then
+ echo
+
+ # The use_nptl should have already taken care of kernel version,
+ # arch and CHOST, so now just check if we can find suitable kernel
+ # source tree or headers ....
+ einfon "Checking for sufficient version kernel headers ... "
+ if ! get_KHV "`KV_to_int ${MIN_NPTL_KV}`" &> /dev/null
+ then
+ echo "no"
+ echo
+ eerror "Could not find a kernel source tree or headers with"
+ eerror "version ${MIN_NPTL_KV} or later! Please correct this"
+ eerror "and try again."
+ die "Insufficient kernel headers present!"
+ else
+ echo "yes"
+ fi
+
+ einfon "Checking gcc for __thread support ... "
+ if ! gcc -c ${FILESDIR}/test-__thread.c -o ${T}/test.o &> /dev/null
+ then
+ echo "no"
+ echo
+ eerror "Could not find a gcc that supports the __thread directive!"
+ eerror "please update to gcc-3.2.2-r1 or later, and try again."
+ die "No __thread support in gcc!"
+ else
+ echo "yes"
+ fi
+
+ # Default disclaimer ...
+ echo
+ ewarn "Please note that NPTL support is still very experimental,"
+ ewarn "and could break your system! Press ^C now if you do not know"
+ ewarn "what you are doing, and remove \"nptl\" from your USE ..."
+ echo
+ ewarn "As a final note ... it does NOT work with NVidia GLX!!"
+ sleep 5
+
+ elif use nptl &> /dev/null
+ then
+ # Just tell the user not to expect too much ...
+ ewarn "You have \"nptl\" in your USE, but your kernel version or"
+ ewarn "architecture do not support it!"
+ fi
+}
+
+src_unpack() {
+ unpack glibc-${MY_PV}.tar.bz2
+
+ # Extract pre-made man pages. Otherwise we need perl, which is a no-no.
+ mkdir -p ${S}/man; cd ${S}/man
+ use_nptl || tar xjf ${FILESDIR}/glibc-manpages-${MY_PV}.tar.bz2
+
+ cd ${S}
+ # Extract our threads package ...
+ if use_nptl
+ then
+ unpack nptl-${NPTL_VER}.tar.bz2
+ else
+ unpack glibc-linuxthreads-${MY_PV}.tar.bz2
+ fi
+
+ # This next patch fixes a test that will timeout due to ReiserFS' slow handling of sparse files
+# cd ${S}/io; epatch ${FILESDIR}/glibc-2.2.2-test-lfs-timeout.patch
+
+ # This add back glibc 2.2 compadibility. See bug #8766 and #9586 for more info,
+ # and also:
+ #
+ # http://lists.debian.org/debian-glibc/2002/debian-glibc-200210/msg00093.html
+ #
+ # We should think about remoing it in the future after things have settled.
+ #
+ # Thanks to Jan Gutter <jangutter@tuks.co.za> for reporting it.
+ #
+ # <azarah@gentoo.org> (26 Oct 2002).
+ cd ${S}; epatch ${FILESDIR}/2.3.1/${PN}-2.3.1-ctype-compat-v3.patch
+
+ # One more compat issue which breaks sun-jdk-1.3.1. See bug #8766 for more
+ # info, and also:
+ #
+ # http://sources.redhat.com/ml/libc-alpha/2002-04/msg00143.html
+ #
+ # Thanks to Jan Gutter <jangutter@tuks.co.za> for reporting it.
+ #
+ # <azarah@gentoo.org> (30 Oct 2002).
+ cd ${S}; epatch ${FILESDIR}/2.3.1/${PN}-2.3.1-libc_wait-compat.patch
+
+ # One more compat issue ... libc_stack_end is missing from ld.so.
+ # Got this one from diffing redhat glibc tarball .. would help if
+ # they used patches and not modified tarball ...
+ #
+ # <azarah@gentoo.org> (7 Nov 2002).
+ cd ${S}; epatch ${FILESDIR}/2.3.1/${PN}-2.3.1-stack_end-compat.patch
+
+ # Fix calculation problems in allocate_static_tls that caused a TLS
+ # enabled app that loads libGL.so to segfault. Thanks to Gareth Hughes
+ # from NVidia for pointing me in the right direction. This patch is
+ # from glibc CVS.
+ #
+ # <azarah@gentoo.org> (6 Apr 2003).
+ cd ${S}; epatch ${FILESDIR}/${PV}/${P}-dl-reloc-calc-fix.patch
+}
+
+setup_flags() {
+ # -freorder-blocks for all but ia64 s390 s390x
+ use ppc || append-flags "-freorder-blocks"
+
+ # Sparc support ...
+ replace-flags "-mcpu=ultrasparc" "-mcpu=v8 -mtune=ultrasparc"
+ replace-flags "-mcpu=v9" "-mcpu=v8 -mtune=v9"
+
+ # -mvis for sparc64 (should this be always, or only with 64bit userspace ?
+ [ "${PROFILE_ARCH}" = "sparc64" ] && append-flags "-mvis"
+
+ # -fcall-used-g7 for sparc and sparc64
+ use sparc && append-flags "-fcall-used-g7"
+}
+
+src_compile() {
+ local myconf=""
+ local myconf_nptl=""
+
+ setup_flags
+
+ # These should not be set, else the
+ # zoneinfo do not always get installed ...
+ unset LANGUAGE LANG LC_ALL
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ if use_nptl
+ then
+ local kernelheaders="$(get_KHV "`KV_to_int ${MIN_NPTL_KV}`")"
+
+ # NTPL and Thread Local Storage support.
+ myconf="${myconf} --with-tls --with-__thread \
+ --enable-add-ons=nptl \
+ --enable-kernel=${MIN_NPTL_KV} \
+ --with-headers=${kernelheaders}"
+ else
+ myconf="${myconf} --without-tls --without-__thread \
+ --enable-add-ons=linuxthreads"
+
+ # If we build for the build system we use the kernel headers from the target
+ # We also now set it without "build" as well, else it might use the
+ # current kernel's headers, which might just fail (the linux-headers
+ # package is usually well tested...)
+# ( use build || use sparc ) \
+# && myconf="${myconf} --with-headers=${ROOT}usr/include"
+ myconf="${myconf} --with-headers=${ROOT}usr/include"
+
+ # If kernel version and headers in ${ROOT}/usr/include are ok,
+ # then enable --enable-kernel=${MIN_KV} ...
+ if [ "`get_KV`" -ge "`KV_to_int ${MIN_KV}`" -a \
+ -n "$(get_KHV "`KV_to_int ${MIN_KV}`" "${ROOT}/usr/include")" ]
+ then
+ myconf="${myconf} --enable-kernel=${MIN_KV}"
+ else
+ myconf="${myconf} --enable-kernel=2.2.5"
+ fi
+ fi
+
+ einfo "Configuring GLIBC..."
+ rm -rf ${S}/buildhere
+ mkdir -p ${S}/buildhere
+ cd ${S}/buildhere
+ ../configure --build=${CHOST} \
+ --host=${CHOST} \
+ --with-gd=no \
+ --without-cvs \
+ --disable-profile \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --libexecdir=/usr/lib/misc \
+ ${myconf} || die
+
+ einfo "Building GLIBC..."
+ cd ${S}/buildhere
+ make PARALLELMFLAGS="${MAKEOPTS}" || die
+# einfo "Doing GLIBC checks..."
+# make check
+}
+
+src_install() {
+ local buildtarget="buildhere"
+
+ setup_flags
+
+ # These should not be set, else the
+ # zoneinfo do not always get installed ...
+ unset LANGUAGE LANG LC_ALL
+
+ einfo "Installing GLIBC..."
+ make PARALLELMFLAGS="${MAKEOPTS}" \
+ install_root=${D} \
+ install -C ${buildtarget} || die
+
+ # If librt.so is a symlink, change it into linker script (Redhat)
+ if [ -L ${D}/usr/lib/librt.so ]
+ then
+ local LIBRTSO="`cd ${D}/lib; echo librt.so.*`"
+ local LIBPTHREADSO="`cd ${D}/lib; echo libpthread.so.*`"
+
+ rm -f ${D}/usr/lib/librt.so
+ cat > ${D}/usr/lib/librt.so <<EOF
+/* GNU ld script
+ librt.so.1 needs libpthread.so.0 to come before libc.so.6*
+ in search scope. */
+EOF
+ grep "OUTPUT_FORMAT" ${D}/usr/lib/libc.so >> ${D}/usr/lib/librt.so
+ echo "GROUP ( /lib/${LIBPTHREADSO} /lib/${LIBRTSO} )" \
+ >> ${D}/usr/lib/librt.so
+ fi
+
+ if [ -z "`use build`" ]
+ then
+ einfo "Installing Info pages..."
+ make PARALLELMFLAGS="${MAKEOPTS}" \
+ install_root=${D} \
+ info -C ${buildtarget} || die
+
+ einfo "Installing Locale data..."
+ make PARALLELMFLAGS="${MAKEOPTS}" \
+ install_root=${D} \
+ localedata/install-locales -C ${buildtarget} || die
+
+ # Compatibility hack: this locale has vanished from glibc,
+ # but some other programs are still using it.
+ keepdir /usr/lib/locale/ru_RU/LC_MESSAGES
+
+ einfo "Installing man pages and docs..."
+ # Install linuxthreads man pages
+ use_nptl || {
+ dodir /usr/share/man/man3
+ doman ${S}/man/*.3thr
+ }
+
+ # Install nscd config file
+ insinto /etc
+ doins ${FILESDIR}/nscd.conf
+
+ dodoc BUGS ChangeLog* CONFORMANCE COPYING* FAQ INTERFACE \
+ NEWS NOTES PROJECTS README*
+ else
+ rm -rf ${D}/usr/share ${D}/usr/lib/gconv
+
+ einfo "Installing Timezone data..."
+ make PARALLELMFLAGS="${MAKEOPTS}" \
+ install_root=${D} \
+ timezone/install-others -C ${buildtarget} || die
+ fi
+
+ if [ "`use pic`" ]
+ then
+ find ${S}/${buildtarget}/ -name "soinit.os" -exec cp {} ${D}/lib/soinit.o \;
+ find ${S}/${buildtarget}/ -name "sofini.os" -exec cp {} ${D}/lib/sofini.o \;
+ find ${S}/${buildtarget}/ -name "*_pic.a" -exec cp {} ${D}/lib \;
+ find ${S}/${buildtarget}/ -name "*.map" -exec cp {} ${D}/lib \;
+ for i in ${D}/lib/*.map
+ do
+ mv ${i} ${i%.map}_pic.map
+ done
+ fi
+
+ # Is this next line actually needed or does the makefile get it right?
+ # It previously has 0755 perms which was killing things.
+ fperms 4755 /usr/lib/misc/pt_chown
+
+ # Currently libraries in /usr/lib/gconv do not get loaded if not
+ # in search path ...
+# insinto /etc/env.d
+# doins ${FILESDIR}/03glibc
+
+ rm -f ${D}/etc/ld.so.cache
+
+ # Prevent overwriting of the /etc/localtime symlink. We'll handle the
+ # creation of the "factory" symlink in pkg_postinst().
+ rm -f ${D}/etc/localtime
+
+ # Some things want this, notably ash.
+ dosym /usr/lib/libbsd-compat.a /usr/lib/libbsd.a
+}
+
+pkg_postinst() {
+ # Correct me if I am wrong here, but my /etc/localtime is a file
+ # created by zic ....
+ # I am thinking that it should only be recreated if no /etc/localtime
+ # exists, or if it is an invalid symlink.
+ #
+ # For invalid symlink:
+ # -f && -e will fail
+ # -L will succeed
+ #
+ if [ ! -e ${ROOT}/etc/localtime ]
+ then
+ echo "Please remember to set your timezone using the zic command."
+ rm -f ${ROOT}/etc/localtime
+ ln -s ../usr/share/zoneinfo/Factory ${ROOT}/etc/localtime
+ fi
+
+ if [ -x ${ROOT}/usr/sbin/iconvconfig ]
+ then
+ # Generate fastloading iconv module configuration file.
+ ${ROOT}/usr/sbin/iconvconfig --prefix=${ROOT}
+ fi
+
+ # Reload init ...
+ if [ "${ROOT}" = "/" ]
+ then
+ /sbin/init U &> /dev/null
+ fi
+}
+
diff --git a/sys-libs/glibc/glibc-2.3.2.ebuild b/sys-libs/glibc/glibc-2.3.2.ebuild
index bb85184d8238..f5ff6f8f2709 100644
--- a/sys-libs/glibc/glibc-2.3.2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2.ebuild,v 1.4 2003/04/06 03:08:14 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2.ebuild,v 1.5 2003/04/06 09:59:53 azarah Exp $
IUSE="nls pic build nptl"
@@ -421,6 +421,11 @@ EOF
NEWS NOTES PROJECTS README*
else
rm -rf ${D}/usr/share ${D}/usr/lib/gconv
+
+ einfo "Installing Timezone data..."
+ make PARALLELMFLAGS="${MAKEOPTS}" \
+ install_root=${D} \
+ timezone/install-others -C ${buildtarget} || die
fi
if [ "`use pic`" ]