summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2012-03-31 11:03:00 +0000
committerSven Vermeulen <swift@gentoo.org>2012-03-31 11:03:00 +0000
commit51d2e821a4d6b5f710b57fb86ee7e6a2a6e450df (patch)
tree7b13cebdcb3c238917f4992b7a9a706d57a1a1c1 /sys-libs
parentUpdating SELinux userspace utilities to support pending 2.20120215 policies (diff)
downloadgentoo-2-51d2e821a4d6b5f710b57fb86ee7e6a2a6e450df.tar.gz
gentoo-2-51d2e821a4d6b5f710b57fb86ee7e6a2a6e450df.tar.bz2
gentoo-2-51d2e821a4d6b5f710b57fb86ee7e6a2a6e450df.zip
Updating SELinux userspace utilities to support pending 2.20120215 policies
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libsemanage/ChangeLog9
-rw-r--r--sys-libs/libsemanage/libsemanage-2.1.6.ebuild129
2 files changed, 136 insertions, 2 deletions
diff --git a/sys-libs/libsemanage/ChangeLog b/sys-libs/libsemanage/ChangeLog
index 36c1fd911a25..000a6ae2be47 100644
--- a/sys-libs/libsemanage/ChangeLog
+++ b/sys-libs/libsemanage/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsemanage
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.44 2011/11/12 16:58:49 swift Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.45 2012/03/31 11:03:00 swift Exp $
+
+*libsemanage-2.1.6 (31 Mar 2012)
+
+ 31 Mar 2012; <swift@gentoo.org> +libsemanage-2.1.6.ebuild:
+ Bump to version 2.1.6
12 Nov 2011; <swift@gentoo.org> -libsemanage-2.0.45.ebuild,
-libsemanage-2.0.46.ebuild:
diff --git a/sys-libs/libsemanage/libsemanage-2.1.6.ebuild b/sys-libs/libsemanage/libsemanage-2.1.6.ebuild
new file mode 100644
index 000000000000..902328ef2bfe
--- /dev/null
+++ b/sys-libs/libsemanage/libsemanage-2.1.6.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/libsemanage-2.1.6.ebuild,v 1.1 2012/03/31 11:03:00 swift Exp $
+
+EAPI="3"
+# Support for 4 depends on python.eclass
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit multilib python toolchain-funcs eutils
+
+SEPOL_VER="2.1.4"
+SELNX_VER="2.1.9"
+
+DESCRIPTION="SELinux kernel and policy management library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20120216/${P}.tar.gz
+ http://dev.gentoo.org/~swift/patches/libsemanage/libsemanage-2.1.6-nolevel.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python ruby"
+
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=sys-libs/libselinux-${SELNX_VER}
+ dev-libs/ustr
+ ruby? ( dev-lang/ruby )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ ruby? ( dev-lang/swig )
+ python? ( dev-lang/swig )"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ echo "# Set this to true to save the linked policy." >> "${S}/src/semanage.conf"
+ echo "# This is normally only useful for analysis" >> "${S}/src/semanage.conf"
+ echo "# or debugging of policy." >> "${S}/src/semanage.conf"
+ echo "save-linked=false" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Set this to 0 to disable assertion checking." >> "${S}/src/semanage.conf"
+ echo "# This should speed up building the kernel policy" >> "${S}/src/semanage.conf"
+ echo "# from policy modules, but may leave you open to" >> "${S}/src/semanage.conf"
+ echo "# dangerous rules which assertion checking" >> "${S}/src/semanage.conf"
+ echo "# would catch." >> "${S}/src/semanage.conf"
+ echo "expand-check=1" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Modules in the module store can be compressed" >> "${S}/src/semanage.conf"
+ echo "# with bzip2. Set this to the bzip2 blocksize" >> "${S}/src/semanage.conf"
+ echo "# 1-9 when compressing. The higher the number," >> "${S}/src/semanage.conf"
+ echo "# the more memory is traded off for disk space." >> "${S}/src/semanage.conf"
+ echo "# Set to 0 to disable bzip2 compression." >> "${S}/src/semanage.conf"
+ echo "bzip-blocksize=0" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Reduce memory usage for bzip2 compression and" >> "${S}/src/semanage.conf"
+ echo "# decompression of modules in the module store." >> "${S}/src/semanage.conf"
+ echo "bzip-small=true" >> "${S}/src/semanage.conf"
+
+ # Apply patch to support non-leveled types (like strict or targeted)
+ epatch "${DISTDIR}/libsemanage-2.1.6-nolevel.patch.gz"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" all || die
+
+ if use python; then
+ python_copy_sources src
+ building() {
+ emake CC="$(tc-getCC)" PYLIBVER="python$(python_get_version)" PYPREFIX="python-$(python_get_version)" "$@"
+ }
+ python_execute_function -s --source-dir src building -- swigify
+ python_execute_function -s --source-dir src building -- pywrap
+ fi
+
+ if use ruby; then
+ emake -C src CC="$(tc-getCC)" rubywrap || die
+ fi
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ LIBDIR="${D}usr/$(get_libdir)" \
+ SHLIBDIR="${D}$(get_libdir)" \
+ install || die
+ dosym "../../$(get_libdir)/libsemanage.so.1" "/usr/$(get_libdir)/libsemanage.so" || die
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PYLIBVER="python$(python_get_version)" \
+ PYPREFIX="python-$(python_get_version)" \
+ LIBDIR="${D}usr/$(get_libdir)" \
+ install-pywrap
+ }
+ python_execute_function -s --source-dir src installation
+ fi
+
+ if use ruby; then
+ emake -C src \
+ DESTDIR="${D}" \
+ LIBDIR="${D}usr/$(get_libdir)" \
+ install-rubywrap || die
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize semanage.py
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup semanage.py
+ fi
+}