summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2010-06-16 01:43:37 +0000
committerMagnus Granberg <zorry@gentoo.org>2010-06-16 01:43:37 +0000
commit41a24ab671f105e31a49028e3c4a81aa9bc52141 (patch)
treebf06809bf9470750c0bc23734046e445faed6559 /sys-libs
parentDelete call to deprecated python_version(). (diff)
downloadgentoo-2-41a24ab671f105e31a49028e3c4a81aa9bc52141.tar.gz
gentoo-2-41a24ab671f105e31a49028e3c4a81aa9bc52141.tar.bz2
gentoo-2-41a24ab671f105e31a49028e3c4a81aa9bc52141.zip
bug #293721 support for >=gcc 4.2 SSP support
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog5
-rw-r--r--sys-libs/glibc/files/eblits/common.eblit6
2 files changed, 7 insertions, 4 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index c8dd1c64ec3c..acb8c9560dcb 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.687 2010/06/12 05:06:40 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.688 2010/06/16 01:43:37 zorry Exp $
+
+ 16 Jun 2010; Magnus Granberg <zorry@gentoo.org> files/eblits/common.eblit:
+ bug #293721 to support >=gcc 4.2 SSP support
12 Jun 2010; Joshua Kinard <kumba@gentoo.org> glibc-2.11-r1.ebuild:
~mipsify glibc-2.11-r1. Runs OK on O2 so far...
diff --git a/sys-libs/glibc/files/eblits/common.eblit b/sys-libs/glibc/files/eblits/common.eblit
index cfdfd039c6d5..985457e71313 100644
--- a/sys-libs/glibc/files/eblits/common.eblit
+++ b/sys-libs/glibc/files/eblits/common.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/common.eblit,v 1.10 2009/12/01 04:57:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/common.eblit,v 1.11 2010/06/16 01:43:37 zorry Exp $
# We need to be able to set alternative headers for
# compiling for non-native platform
@@ -169,8 +169,8 @@ setup_flags() {
# building glibc with SSP is fraught with difficulty, especially
# due to __stack_chk_fail_local which would mean significant changes
- # to the glibc build process. See bug #94325
- filter-flags -fstack-protector
+ # to the glibc build process. See bug #94325 #293721
+ use hardened && gcc-specs-ssp && append-cflags $(test-flags-CC -fno-stack-protector)
if use hardened && gcc-specs-pie ; then
# Force PIC macro definition for all compilations since they're all