summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-04-13 07:01:45 +0000
committerHanno Böck <hanno@gentoo.org>2005-04-13 07:01:45 +0000
commit3faa2ba5f1f3b9a1b8315672ef4058ab89c85e62 (patch)
tree1e6c16ed0ece5d033af8ec8cd5748ef8d0c95ab7 /sys-libs
parentrepoman: Trim trailing whitespace (diff)
downloadgentoo-2-3faa2ba5f1f3b9a1b8315672ef4058ab89c85e62.tar.gz
gentoo-2-3faa2ba5f1f3b9a1b8315672ef4058ab89c85e62.tar.bz2
gentoo-2-3faa2ba5f1f3b9a1b8315672ef4058ab89c85e62.zip
gwenhywfar version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/files/digest-gwenhywfar-1.11.01
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-1.11.0.ebuild41
3 files changed, 48 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index ecf13649900f..d2cd362f2452 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.10 2005/03/13 22:36:15 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.11 2005/04/13 07:01:45 hanno Exp $
+
+*gwenhywfar-1.11.0 (13 Apr 2005)
+
+ 13 Apr 2005; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-1.11.0.ebuild:
+ Version bump.
*gwenhywfar-1.9.0 (13 Mar 2005)
diff --git a/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.11.0 b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.11.0
new file mode 100644
index 000000000000..9783c3b36268
--- /dev/null
+++ b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.11.0
@@ -0,0 +1 @@
+MD5 ffba97ac3f020d150307b16719c273e5 gwenhywfar-1.11.0.tar.gz 1070108
diff --git a/sys-libs/gwenhywfar/gwenhywfar-1.11.0.ebuild b/sys-libs/gwenhywfar/gwenhywfar-1.11.0.ebuild
new file mode 100644
index 000000000000..3f48bdb32c7c
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-1.11.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-1.11.0.ebuild,v 1.1 2005/04/13 07:01:45 hanno Exp $
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc ~alpha ~ppc"
+
+IUSE="debug ssl doc"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ sys-libs/ncurses
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ if use doc; then
+ APIDOC="--with-docpath=/usr/share/doc/${P}/apidoc"
+ fi
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable doc full-doc` \
+ ${APIDOC} || die "configure failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake srcdoc || die "Building the api-doc failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README* AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL TODO
+ if use doc; then
+ make DESTDIR=${D} install-srcdoc || die "Installing the API-Doc failed"
+ fi
+}