summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-02-27 20:31:27 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-02-27 20:31:27 +0000
commit272a233aefa78122bcfd30786b0d957bc4eb3c19 (patch)
tree54a9d2da03df2090d610712808db0a052034a873 /sys-libs
parentBump 4.4.20 to _p4 (diff)
downloadgentoo-2-272a233aefa78122bcfd30786b0d957bc4eb3c19.tar.gz
gentoo-2-272a233aefa78122bcfd30786b0d957bc4eb3c19.tar.bz2
gentoo-2-272a233aefa78122bcfd30786b0d957bc4eb3c19.zip
removing a few stale ebuilds, including 4.3.27 which isn't available anymore
(Portage version: 2.1.2-r12)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog6
-rw-r--r--sys-libs/db/db-4.3.27.ebuild124
-rw-r--r--sys-libs/db/db-4.3.29.ebuild138
-rw-r--r--sys-libs/db/db-4.4.20_p2.ebuild138
-rw-r--r--sys-libs/db/files/digest-db-4.3.273
-rw-r--r--sys-libs/db/files/digest-db-4.3.293
-rw-r--r--sys-libs/db/files/digest-db-4.4.20_p29
7 files changed, 5 insertions, 416 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 9d7bd566d0e7..ea76e7e72b95 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.195 2007/02/27 20:28:23 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.196 2007/02/27 20:31:27 caleb Exp $
+
+ 27 Feb 2007; Caleb Tennis <caleb@gentoo.org> -db-4.3.27.ebuild,
+ -db-4.3.29.ebuild, -db-4.4.20_p2.ebuild:
+ removing a few stale ebuilds, including 4.3.27 which isn't available anymore
*db-4.4.20_p4 (27 Feb 2007)
diff --git a/sys-libs/db/db-4.3.27.ebuild b/sys-libs/db/db-4.3.27.ebuild
deleted file mode 100644
index 62d580332f06..000000000000
--- a/sys-libs/db/db-4.3.27.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.3.27.ebuild,v 1.9 2006/11/26 12:30:30 vapier Exp $
-
-inherit eutils gnuconfig db
-
-#Number of official patches
-#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
-PATCHNO=${PV/*.*.*_p}
-if [ "${PATCHNO}" == "${PV}" ]; then
- MY_PV=${PV}
- MY_P=${P}
- PATCHNO=0
-else
- MY_PV=${PV/_p${PATCHNO}}
- MY_P=${PN}-${MY_PV}
-fi
-
-S=${WORKDIR}/${MY_P}/build_unix
-DESCRIPTION="Berkeley DB"
-HOMEPAGE="http://www.sleepycat.com/"
-SRC_URI="ftp://ftp.sleepycat.com/releases/${MY_P}.tar.gz"
-for (( i=1 ; i<=$PATCHNO ; i++ )) ; do
- export SRC_URI="${SRC_URI} http://www.sleepycat.com/update/${MY_PV}/patch.${MY_PV}.${i}"
-done
-
-LICENSE="DB"
-SLOT="4.3"
-KEYWORDS="~amd64 ~arm ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="tcl java doc nocxx bootstrap"
-
-DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
- java? ( virtual/jdk )"
-RDEPEND="tcl? ( dev-lang/tcl )
- java? ( virtual/jre )"
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- cd ${WORKDIR}/${MY_P}
- for (( i=1 ; i<=$PATCHNO ; i++ ))
- do
- epatch ${DISTDIR}/patch.${MY_PV}.${i}
- done
- epatch ${FILESDIR}/${PN}-${SLOT}-jarlocation.patch
- epatch ${FILESDIR}/${PN}-${SLOT}-libtool.patch
-
- epatch ${FILESDIR}/${PN}-4.3.27-fix-dep-link.patch
-
- gnuconfig_update "${S}/../dist"
-
- sed -i -e "s,\(ac_compiler\|\${MAKEFILE_CC}\|\${MAKEFILE_CXX}\|\$CC\)\( *--version\),\1 -dumpversion,g" ${S}/../dist/configure
-}
-
-src_compile() {
- addwrite /proc/self/maps
-
- local myconf=""
-
- use amd64 && myconf="${myconf} --with-mutex=x86/gcc-assembly"
-
- use bootstrap \
- && myconf="${myconf} --disable-cxx" \
- || myconf="${myconf} $(use_enable !nocxx cxx)"
-
- use tcl \
- && myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
- || myconf="${myconf} --disable-tcl"
-
- myconf="${myconf} $(use_enable java)"
- if use java && [[ -n ${JAVAC} ]] ; then
- export PATH=`dirname ${JAVAC}`:${PATH}
- export JAVAC=`basename ${JAVAC}`
- fi
-
- [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
-
- ../dist/configure \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --libdir=/usr/$(get_libdir) \
- --enable-compat185 \
- --without-uniquename \
- --enable-rpc \
- --host=${CHOST} \
- ${myconf} || die "configure failed"
-
- emake -j1 || die "make failed"
-}
-
-src_install() {
-
- einstall libdir="${D}/usr/$(get_libdir)" strip="${D}/bin/strip" || die
-
- db_src_install_usrbinslot
-
- db_src_install_headerslot
-
- db_src_install_doc
-
- db_src_install_usrlibcleanup
-
- dodir /usr/sbin
- mv ${D}/usr/bin/berkeley_db_svc ${D}/usr/sbin/berkeley_db43_svc
-
- if use java; then
- mkdir -p ${D}/usr/share/db
- cat <<EOF >${D}/usr/share/db/package.env
-DESCRIPTION=The java bindings for berkeley db version ${MY_PV}
-CLASSPATH=:/usr/lib/db-${SLOT}.jar
-EOF
- fi
-}
-
-pkg_postinst () {
- db_fix_so
-}
-
-pkg_postrm () {
- db_fix_so
-}
diff --git a/sys-libs/db/db-4.3.29.ebuild b/sys-libs/db/db-4.3.29.ebuild
deleted file mode 100644
index 762306af4142..000000000000
--- a/sys-libs/db/db-4.3.29.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.3.29.ebuild,v 1.10 2006/11/26 12:30:30 vapier Exp $
-
-inherit eutils gnuconfig db flag-o-matic
-
-#Number of official patches
-#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
-PATCHNO=${PV/*.*.*_p}
-if [ "${PATCHNO}" == "${PV}" ]; then
- MY_PV=${PV}
- MY_P=${P}
- PATCHNO=0
-else
- MY_PV=${PV/_p${PATCHNO}}
- MY_P=${PN}-${MY_PV}
-fi
-
-S=${WORKDIR}/${MY_P}/build_unix
-DESCRIPTION="Berkeley DB"
-HOMEPAGE="http://www.sleepycat.com/"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-#SRC_URI="ftp://ftp.sleepycat.com/releases/${MY_P}.tar.gz"
-for (( i=1 ; i<=$PATCHNO ; i++ )) ; do
- export SRC_URI="${SRC_URI} http://www.sleepycat.com/update/${MY_PV}/patch.${MY_PV}.${i}"
-done
-
-LICENSE="DB"
-SLOT="4.3"
-KEYWORDS="~amd64 ~arm ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="tcl java doc nocxx bootstrap"
-
-DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
- java? ( virtual/jdk )
- >=sys-devel/binutils-2.16.1"
-RDEPEND="tcl? ( dev-lang/tcl )
- java? ( virtual/jre )"
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- cd ${WORKDIR}/${MY_P}
- for (( i=1 ; i<=$PATCHNO ; i++ ))
- do
- epatch ${DISTDIR}/patch.${MY_PV}.${i}
- done
- epatch ${FILESDIR}/${PN}-${SLOT}-jarlocation.patch
- epatch ${FILESDIR}/${PN}-${SLOT}-libtool.patch
-
- epatch ${FILESDIR}/${PN}-4.3.27-fix-dep-link.patch
-
- gnuconfig_update "${S}/../dist"
-
- sed -i -e "s,\(ac_compiler\|\${MAKEFILE_CC}\|\${MAKEFILE_CXX}\|\$CC\)\( *--version\),\1 -dumpversion,g" ${S}/../dist/configure
-}
-
-src_compile() {
- addwrite /proc/self/maps
-
- local myconf=""
-
- use amd64 && myconf="${myconf} --with-mutex=x86/gcc-assembly"
-
- use bootstrap \
- && myconf="${myconf} --disable-cxx" \
- || myconf="${myconf} $(use_enable !nocxx cxx)"
-
- use tcl \
- && myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
- || myconf="${myconf} --disable-tcl"
-
- myconf="${myconf} $(use_enable java)"
- if use java && [[ -n ${JAVAC} ]] ; then
- export PATH=`dirname ${JAVAC}`:${PATH}
- export JAVAC=`basename ${JAVAC}`
- fi
-
- [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
-
- # the entire testsuite needs the TCL functionality
- if use tcl && has test $FEATURES ; then
- myconf="${myconf} --enable-test"
- else
- myconf="${myconf} --disable-test"
- fi
-
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU; then
- append-ldflags -Wl,--default-symver
- fi
-
- ../dist/configure \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --libdir=/usr/$(get_libdir) \
- --enable-compat185 \
- --without-uniquename \
- --enable-rpc \
- --host=${CHOST} \
- ${myconf} || die "configure failed"
-
- emake -j1 || die "make failed"
-}
-
-src_install() {
- einstall libdir="${D}/usr/$(get_libdir)" strip="${D}/bin/strip" || die
-
- db_src_install_usrbinslot
-
- db_src_install_headerslot
-
- db_src_install_doc
-
- db_src_install_usrlibcleanup
-
- dodir /usr/sbin
- mv ${D}/usr/bin/berkeley_db_svc ${D}/usr/sbin/berkeley_db43_svc
-
- if use java; then
- mkdir -p ${D}/usr/share/db
- cat <<EOF >${D}/usr/share/db/package.env
-DESCRIPTION=The java bindings for berkeley db version ${MY_PV}
-CLASSPATH=:/usr/lib/db-${SLOT}.jar
-EOF
- fi
-}
-
-pkg_postinst () {
- db_fix_so
-}
-
-pkg_postrm () {
- db_fix_so
-}
diff --git a/sys-libs/db/db-4.4.20_p2.ebuild b/sys-libs/db/db-4.4.20_p2.ebuild
deleted file mode 100644
index 00e8b6b6a168..000000000000
--- a/sys-libs/db/db-4.4.20_p2.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.4.20_p2.ebuild,v 1.7 2006/11/26 12:30:30 vapier Exp $
-
-inherit eutils gnuconfig db flag-o-matic java-pkg-opt-2
-
-#Number of official patches
-#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
-PATCHNO=${PV/*.*.*_p}
-if [[ ${PATCHNO} == "${PV}" ]] ; then
- MY_PV=${PV}
- MY_P=${P}
- PATCHNO=0
-else
- MY_PV=${PV/_p${PATCHNO}}
- MY_P=${PN}-${MY_PV}
-fi
-
-S="${WORKDIR}/${MY_P}/build_unix"
-DESCRIPTION="Berkeley DB"
-HOMEPAGE="http://www.sleepycat.com/"
-SRC_URI="ftp://ftp.sleepycat.com/releases/${MY_P}.tar.gz"
-for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
- export SRC_URI="${SRC_URI} http://www.sleepycat.com/update/${MY_PV}/patch.${MY_PV}.${i}"
-done
-
-LICENSE="DB"
-SLOT="4.4"
-KEYWORDS="~amd64 ~arm ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="tcl java doc nocxx bootstrap"
-
-DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
- java? ( >=virtual/jdk-1.4 )
- >=sys-devel/binutils-2.16.1"
-RDEPEND="tcl? ( dev-lang/tcl )
- java? ( >=virtual/jre-1.4 )"
-
-src_unpack() {
- unpack "${MY_P}".tar.gz
- cd "${WORKDIR}"/"${MY_P}"
- for (( i=1 ; i<=${PATCHNO} ; i++ ))
- do
- epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
- done
- epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-libtool.patch
-
- # use the includes from the prefix
- epatch "${FILESDIR}"/"${PN}"-4.3-jni-check-prefix-first.patch
- epatch "${FILESDIR}"/"${PN}"-4.3-listen-to-java-options.patch
-
- gnuconfig_update "${S}"/../dist
-
- sed -i \
- -e "s,\(ac_compiler\|\${MAKEFILE_CC}\|\${MAKEFILE_CXX}\|\$CC\)\( *--version\),\1 -dumpversion,g" \
- "${S}"/../dist/configure
-}
-
-src_compile() {
- local myconf=""
-
- use amd64 && myconf="${myconf} --with-mutex=x86/gcc-assembly"
-
- use bootstrap \
- && myconf="${myconf} --disable-cxx" \
- || myconf="${myconf} $(use_enable !nocxx cxx)"
-
- use tcl \
- && myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
- || myconf="${myconf} --disable-tcl"
-
- myconf="${myconf} $(use_enable java)"
- if use java; then
- myconf="${myconf} --with-java-prefix=${JAVA_HOME}"
- # Can't get this working any other way, since it returns spaces, and
- # bash doesn't seem to want to pass correctly in any way i try
- local javaconf="-with-javac-flags=$(java-pkg_javac-args)"
- fi
-
- [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
-
- # the entire testsuite needs the TCL functionality
- if use tcl && has test $FEATURES ; then
- myconf="${myconf} --enable-test"
- else
- myconf="${myconf} --disable-test"
- fi
-
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU; then
- append-ldflags -Wl,--default-symver
- fi
-
- ../dist/configure \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --libdir=/usr/"$(get_libdir)" \
- --enable-compat185 \
- --without-uniquename \
- --enable-rpc \
- --host="${CHOST}" \
- ${myconf} "${javaconf}" || die "configure failed"
-
- emake -j1 || die "make failed"
-}
-
-src_install() {
- einstall libdir="${D}/usr/$(get_libdir)" strip="${D}/bin/strip" || die
-
- db_src_install_usrbinslot
-
- db_src_install_headerslot
-
- db_src_install_doc
-
- db_src_install_usrlibcleanup
-
- dodir /usr/sbin
- mv "${D}"/usr/bin/berkeley_db_svc "${D}"/usr/sbin/berkeley_db44_svc
-
- if use java; then
- java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
- java-pkg_dojar "${D}"/usr/"$(get_libdir)"/*.jar
- rm -f "${D}"/usr/"$(get_libdir)"/*.jar
- fi
-}
-
-pkg_postinst() {
- db_fix_so
-}
-
-pkg_postrm() {
- db_fix_so
-}
diff --git a/sys-libs/db/files/digest-db-4.3.27 b/sys-libs/db/files/digest-db-4.3.27
deleted file mode 100644
index 98339c5e87bd..000000000000
--- a/sys-libs/db/files/digest-db-4.3.27
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 fcc481d52c3b80e20a328f8c0cb042bd db-4.3.27.tar.gz 5921872
-RMD160 711129871c7edd840184bd5a87fb7bf93c8bb953 db-4.3.27.tar.gz 5921872
-SHA256 6f09e04c5811ad72a2a5c99459340cb2c635e6553520af76fc9e717dd6207244 db-4.3.27.tar.gz 5921872
diff --git a/sys-libs/db/files/digest-db-4.3.29 b/sys-libs/db/files/digest-db-4.3.29
deleted file mode 100644
index 8b53cf06bcf3..000000000000
--- a/sys-libs/db/files/digest-db-4.3.29
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 13585a20ce32f113b8e8cdb57f52e3bb db-4.3.29.tar.gz 6103264
-RMD160 fac910828a74087124e9cc3cad99c6a6dc88c14b db-4.3.29.tar.gz 6103264
-SHA256 db3e762d819f9a31bc4ebf5ecada53e9787aeb26fc92fa6064b2ba57df806af4 db-4.3.29.tar.gz 6103264
diff --git a/sys-libs/db/files/digest-db-4.4.20_p2 b/sys-libs/db/files/digest-db-4.4.20_p2
deleted file mode 100644
index f52a67467c0f..000000000000
--- a/sys-libs/db/files/digest-db-4.4.20_p2
+++ /dev/null
@@ -1,9 +0,0 @@
-MD5 33851f01b455cca48aa601956de93c6f db-4.4.20.tar.gz 8112163
-RMD160 1e62a7583c8064f1e8533e188db4644d6d047f66 db-4.4.20.tar.gz 8112163
-SHA256 56442966cf51a6eb81272f4ab4cec929dcb695a5081b187215afdc7cf7629a57 db-4.4.20.tar.gz 8112163
-MD5 66584d621355df055b6e05b4a02e9c3e patch.4.4.20.1 867
-RMD160 57ecff5ecb934e1eb771c49e4e67246d579702b2 patch.4.4.20.1 867
-SHA256 4eeb18450b88703282251c386405bf7c9efa053a42d1dda97603ee8039ee5869 patch.4.4.20.1 867
-MD5 85df93a0867f6cace3501671cdeb6ed1 patch.4.4.20.2 721
-RMD160 e560b07cc20dbd6865d8aad91941515f8fb031c1 patch.4.4.20.2 721
-SHA256 45949e288482736bbc27bd62c854a99fad4b3e55103897eafd62bce1d5629bbc patch.4.4.20.2 721