summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-01-12 11:42:33 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-01-12 11:42:33 +0000
commit2188f9ca1bf4c520a5bf5703d8ea85eada7f2580 (patch)
tree68440c66515c0e5679b66f8c308b76cd152111bd /sys-libs
parentFix tests (bug #298323). (diff)
downloadgentoo-2-2188f9ca1bf4c520a5bf5703d8ea85eada7f2580.tar.gz
gentoo-2-2188f9ca1bf4c520a5bf5703d8ea85eada7f2580.tar.bz2
gentoo-2-2188f9ca1bf4c520a5bf5703d8ea85eada7f2580.zip
Version bump, bug #298540.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libxcrypt/ChangeLog11
-rw-r--r--sys-libs/libxcrypt/libxcrypt-2.4.ebuild28
2 files changed, 37 insertions, 2 deletions
diff --git a/sys-libs/libxcrypt/ChangeLog b/sys-libs/libxcrypt/ChangeLog
index 07e199ed8878..c1f1fdcaf2e3 100644
--- a/sys-libs/libxcrypt/ChangeLog
+++ b/sys-libs/libxcrypt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/libxcrypt
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libxcrypt/ChangeLog,v 1.7 2007/09/01 11:58:58 phreak Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libxcrypt/ChangeLog,v 1.8 2010/01/12 11:42:33 phajdan.jr Exp $
+
+*libxcrypt-2.4 (12 Jan 2010)
+
+ 12 Jan 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +libxcrypt-2.4.ebuild:
+ Version bump (bug #298540). Also install into /lib to make it safe for tcb
+ and others to use libxcrypt.
01 Sep 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing method from metadata due to his retirement (see #175298 for
diff --git a/sys-libs/libxcrypt/libxcrypt-2.4.ebuild b/sys-libs/libxcrypt/libxcrypt-2.4.ebuild
new file mode 100644
index 000000000000..5a106bc3acaa
--- /dev/null
+++ b/sys-libs/libxcrypt/libxcrypt-2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libxcrypt/libxcrypt-2.4.ebuild,v 1.1 2010/01/12 11:42:33 phajdan.jr Exp $
+
+EAPI=2
+
+inherit multilib
+
+DESCRIPTION="A replacement for libcrypt with DES, MD5 and blowfish support"
+SRC_URI="mirror://debian/pool/main/libx/${PN}/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://packages.debian.org/sid/libxcrypt1"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_configure() {
+ # Do not install into /usr so that tcb and pam can use us.
+ econf --libdir=/$(get_libdir)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+
+ # Remove unneeded files from /
+ rm -f "${D}"/$(get_libdir)/"${PN}".{a,la} || die "rm failed"
+}