summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-11-25 17:19:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-11-25 17:19:15 +0000
commit1e3e4a8c57bf69d5630be0b5d7459b2547ad53d5 (patch)
treeeed8a80f51dc00e1b9ade0437aa594e37e8e11cd /sys-libs
parentVersion Bump, #346773 (diff)
downloadgentoo-2-1e3e4a8c57bf69d5630be0b5d7459b2547ad53d5.tar.gz
gentoo-2-1e3e4a8c57bf69d5630be0b5d7459b2547ad53d5.tar.bz2
gentoo-2-1e3e4a8c57bf69d5630be0b5d7459b2547ad53d5.zip
Version bump, thanks to Gary Macindoe in bug #346517. Fixes build with linux-headers 2.6.36.1.
(Portage version: 2.2.0_alpha5/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcap-ng/ChangeLog9
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.6.5.ebuild111
2 files changed, 119 insertions, 1 deletions
diff --git a/sys-libs/libcap-ng/ChangeLog b/sys-libs/libcap-ng/ChangeLog
index 1256f0b2f924..735d3ab9ab78 100644
--- a/sys-libs/libcap-ng/ChangeLog
+++ b/sys-libs/libcap-ng/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/libcap-ng
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.21 2010/11/01 12:26:06 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.22 2010/11/25 17:19:15 flameeyes Exp $
+
+*libcap-ng-0.6.5 (25 Nov 2010)
+
+ 25 Nov 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +libcap-ng-0.6.5.ebuild:
+ Version bump, thanks to Gary Macindoe in bug #346517. Fixes build with
+ linux-headers 2.6.36.1.
01 Nov 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
libcap-ng-0.6.4.ebuild:
diff --git a/sys-libs/libcap-ng/libcap-ng-0.6.5.ebuild b/sys-libs/libcap-ng/libcap-ng-0.6.5.ebuild
new file mode 100644
index 000000000000..e0bc79e6e52e
--- /dev/null
+++ b/sys-libs/libcap-ng/libcap-ng-0.6.5.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/libcap-ng-0.6.5.ebuild,v 1.1 2010/11/25 17:19:15 flameeyes Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils autotools flag-o-matic python
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="http://people.redhat.com/sgrubb/libcap-ng/"
+SRC_URI="http://people.redhat.com/sgrubb/libcap-ng/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+
+RDEPEND="sys-apps/attr
+ python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ python? ( dev-lang/swig )"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ # Disable byte-compilation of Python modules.
+ echo "#!/bin/sh" > py-compile
+
+ # Python bindings are built/tested/installed manually.
+ sed -e "/^SUBDIRS/s/ python//" -i bindings/Makefile.am
+
+ eautoreconf
+
+ use sparc && replace-flags -O? -O0
+}
+
+src_configure() {
+ econf $(use_with python)
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources bindings/python
+
+ building() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir bindings/python building
+ fi
+}
+
+src_test() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ ewarn "Skipping tests due to root permissions."
+ return
+ fi
+
+ default
+
+ if use python; then
+ testing() {
+ emake \
+ PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ TESTS_ENVIRONMENT="PYTHONPATH=..:../.libs" \
+ check
+ }
+ python_execute_function -s --source-dir bindings/python testing
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir bindings/python installation
+
+ python_clean_installation_image
+ fi
+
+ dodoc ChangeLog README
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize capng.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup capng.py
+}