summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-10-25 18:02:48 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-10-25 18:02:48 +0000
commit1829d27e12a8f352e896cbcf9eb3f904b143175d (patch)
tree84aee71048459edb3f86177cf1176b062d242d5f /sys-libs
parentia64 stable wrt #192247 (diff)
downloadgentoo-2-1829d27e12a8f352e896cbcf9eb3f904b143175d.tar.gz
gentoo-2-1829d27e12a8f352e896cbcf9eb3f904b143175d.tar.bz2
gentoo-2-1829d27e12a8f352e896cbcf9eb3f904b143175d.zip
Restored removed version since it broke deps on mips and hppa.
(Portage version: 2.1.3.9)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog5
-rw-r--r--sys-libs/db/db-3.2.9-r10.ebuild165
-rw-r--r--sys-libs/db/files/digest-db-3.2.9-r103
3 files changed, 172 insertions, 1 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 78cc66628b5b..55c14f3f27f3 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.228 2007/10/25 07:03:32 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.229 2007/10/25 18:02:47 mr_bones_ Exp $
+
+ 25 Oct 2007; Michael Sterrett <mr_bones_@gentoo.org> +db-3.2.9-r10.ebuild:
+ Restored removed version since it broke deps on mips and hppa.
25 Oct 2007; Torsten Veller <tove@gentoo.org> db-3.2.9-r11.ebuild:
Added a missing quote (#196944)
diff --git a/sys-libs/db/db-3.2.9-r10.ebuild b/sys-libs/db/db-3.2.9-r10.ebuild
new file mode 100644
index 000000000000..fbafdaef94b1
--- /dev/null
+++ b/sys-libs/db/db-3.2.9-r10.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r10.ebuild,v 1.30 2007/10/25 18:02:47 mr_bones_ Exp $
+
+inherit gnuconfig libtool eutils db java-pkg
+
+DESCRIPTION="Berkeley DB for transaction support in MySQL"
+HOMEPAGE="http://www.sleepycat.com/"
+SRC_URI="ftp://ftp.sleepycat.com/releases/${P}.tar.gz"
+
+LICENSE="DB"
+SLOT="3"
+# This ebuild is to be the compatibility ebuild for when db4 is put
+# in the tree.
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+IUSE="doc java"
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ =sys-libs/db-1.85*
+ sys-devel/libtool
+ sys-devel/m4
+ java? ( virtual/jdk )"
+# We need m4 too else build fails without config.guess
+
+# This doesn't build without exceptions
+export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
+
+pkg_setup() {
+ use java && java-pkg_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+
+ chmod -R ug+w *
+
+ cd ${WORKDIR}/${P}
+ epatch ${FILESDIR}/patch.3.2.9.1
+ epatch ${FILESDIR}/patch.3.2.9.2
+
+ # Get db to link libdb* to correct dependencies ... for example if we use
+ # NPTL or NGPT, db detects usable mutexes, and should link against
+ # libpthread, but does not do so ...
+ # <azarah@gentoo.org> (23 Feb 2003)
+ epatch ${FILESDIR}/${P}-fix-dep-link.patch
+
+ # We should get dump185 to link against system db1 ..
+ # <azarah@gentoo.org> (23 Feb 2003)
+ mv ${S}/dist/Makefile.in ${S}/dist/Makefile.in.orig
+ sed -e 's:DB185INC=:DB185INC= -I/usr/include/db1:' \
+ -e 's:DB185LIB=:DB185LIB= -ldb1:' \
+ ${S}/dist/Makefile.in.orig > ${S}/dist/Makefile.in || die "Failed to sed"
+
+ # Fix invalid .la files
+ cd ${WORKDIR}/${P}/dist
+ rm -f ltversion.sh
+ # remove config.guess else we have problems with gcc-3.2
+ rm -f config.guess
+ sed -i "s,\(-D_GNU_SOURCE\),\1 ${CFLAGS}," configure
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-jarlocation.patch
+ epatch ${FILESDIR}/db-3.2.9-java15.patch
+ gnuconfig_update
+}
+
+src_compile() {
+ local conf=
+ local conf_shared=
+ local conf_static=
+
+ use java && export JAVACABS="${JAVAC}"
+
+ conf="${conf}
+ --host=${CHOST} \
+ --build=${CHOST} \
+ --enable-cxx \
+ --enable-compat185 \
+ --enable-dump185 \
+ --prefix=/usr"
+
+ # --enable-rpc DOES NOT BUILD
+ # Robin H. Johnson <robbat2@gentoo.org> (18 Oct 2003)
+
+ conf_shared="${conf_shared}
+ `use_enable java`
+ --enable-dynamic"
+
+ # TCL support is also broken
+ # Robin H. Johnson <robbat2@gentoo.org> (18 Oct 2003)
+ # conf_shared="${conf_shared}
+ # `use_enable tcl tcl`
+ # `use_with tcl tcl /usr/lib`"
+
+ # NOTE: we should not build both shared and static versions
+ # of the libraries in the same build root!
+
+ einfo "Configuring ${P} (static)..."
+ mkdir -p ${S}/build-static
+ cd ${S}/build-static
+ ../dist/configure ${conf} ${conf_static} \
+ --libdir=/usr/$(get_libdir) \
+ --enable-static || die
+
+ einfo "Configuring ${P} (shared)..."
+ mkdir -p ${S}/build-shared
+ cd ${S}/build-shared
+ ../dist/configure ${conf} ${conf_shared} \
+ --libdir=/usr/$(get_libdir) \
+ --enable-shared || die
+
+ # Parallel make does not work
+ MAKEOPTS="${MAKEOPTS} -j1"
+ einfo "Building ${P} (static)..."
+ cd ${S}/build-static
+ emake || die "Static build failed"
+ einfo "Building ${P} (shared)..."
+ cd ${S}/build-shared
+ emake || die "Shared build failed"
+}
+
+src_install () {
+ cd ${S}/build-shared
+ make libdb=libdb-3.2.a \
+ libcxx=libcxx_3.2.a \
+ prefix=${D}/usr \
+ libdir=${D}/usr/$(get_libdir) \
+ install || die
+
+ cd ${S}/build-static
+ newlib.a libdb.a libdb-3.2.a || die "failed to package static libraries!"
+ newlib.a libdb_cxx.a libdb_cxx-3.2.a || die "failed to package static libraries!"
+
+ db_src_install_headerslot || die "db_src_install_headerslot failed!"
+
+ # this is now done in the db eclass, function db_fix_so and db_src_install_usrlibcleanup
+ #cd ${D}/usr/lib
+ #ln -s libdb-3.2.so libdb.so.3
+
+ # For some reason, db.so's are *not* readable by group or others,
+ # resulting in no one but root being able to use them!!!
+ # This fixes it -- DR 15 Jun 2001
+ cd ${D}/usr/$(get_libdir)
+ chmod go+rx *.so
+ # The .la's aren't readable either
+ chmod go+r *.la
+
+ cd ${S}
+ dodoc README LICENSE
+
+ db_src_install_doc || die "db_src_install_doc failed!"
+
+ db_src_install_usrbinslot || die "db_src_install_usrbinslot failed!"
+
+ db_src_install_usrlibcleanup || die "db_src_install_usrlibcleanup failed!"
+}
+
+pkg_postinst () {
+ db_fix_so
+}
+
+pkg_postrm () {
+ db_fix_so
+}
diff --git a/sys-libs/db/files/digest-db-3.2.9-r10 b/sys-libs/db/files/digest-db-3.2.9-r10
new file mode 100644
index 000000000000..94bf83c2428a
--- /dev/null
+++ b/sys-libs/db/files/digest-db-3.2.9-r10
@@ -0,0 +1,3 @@
+MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238
+RMD160 c2c5cdb3ec0e99e5687c0861dfbf76b8878f27cb db-3.2.9.tar.gz 2085238
+SHA256 3eccaec87bca4ca0f5728cf4579650da9d12e331187f1e98321e5c9e9e04b108 db-3.2.9.tar.gz 2085238