summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-02-20 15:54:59 +0000
committerAron Griffis <agriffis@gentoo.org>2002-02-20 15:54:59 +0000
commit136bf72ce33293105f9fd2678d42c1b7768232e6 (patch)
tree6de15b4810e473a4c354719d33614127e924c0d4 /sys-libs
parentinitial ebuild (diff)
downloadgentoo-2-136bf72ce33293105f9fd2678d42c1b7768232e6.tar.gz
gentoo-2-136bf72ce33293105f9fd2678d42c1b7768232e6.tar.bz2
gentoo-2-136bf72ce33293105f9fd2678d42c1b7768232e6.zip
Updated to 1.4.5
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/slang/ChangeLog24
-rw-r--r--sys-libs/slang/files/digest-slang-1.4.51
-rw-r--r--sys-libs/slang/slang-1.4.5.ebuild28
3 files changed, 45 insertions, 8 deletions
diff --git a/sys-libs/slang/ChangeLog b/sys-libs/slang/ChangeLog
index 76fd55f8e770..8167cde030ab 100644
--- a/sys-libs/slang/ChangeLog
+++ b/sys-libs/slang/ChangeLog
@@ -1,13 +1,21 @@
# ChangeLog for sys-libs/slang
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.1 2002/02/01 21:53:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.2 2002/02/20 15:54:59 agriffis Exp $
+
+*slang-1.4.5 (20 Feb 2002)
+
+ 20 Feb 2002; Aron Griffis <agriffis@gentoo.org> slang-1.4.5.ebuild :
+
+ Updated to 1.4.5. Removed setting of ELF_CFLAGS since our CFLAGS are
+ picked up anyway. This seems a safer approach.
*slang-1.4.4-r1 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ portage repository.
diff --git a/sys-libs/slang/files/digest-slang-1.4.5 b/sys-libs/slang/files/digest-slang-1.4.5
new file mode 100644
index 000000000000..1d09a4387cf2
--- /dev/null
+++ b/sys-libs/slang/files/digest-slang-1.4.5
@@ -0,0 +1 @@
+MD5 9e597a0d3d07465e1014d5e020087e44 slang-1.4.5.tar.gz 757822
diff --git a/sys-libs/slang/slang-1.4.5.ebuild b/sys-libs/slang/slang-1.4.5.ebuild
new file mode 100644
index 000000000000..0e5149892b21
--- /dev/null
+++ b/sys-libs/slang/slang-1.4.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.5.ebuild,v 1.1 2002/02/20 15:54:59 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Console display library used by most text viewer"
+SRC_URI="ftp://space.mit.edu/pub/davis/slang/v1.4/${P}.tar.gz"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr || die "./configure failed"
+ # emake doesn't work well with slang, so just use normal make.
+ make all elf || die "make failed"
+}
+
+src_install() {
+ make install install-elf DESTDIR=${D} || die "make install failed"
+ # remove the documentation... we want to install it ourselves
+ rm -rf ${D}/usr/share
+ dodoc COPYING* NEWS README *.txt
+ dodoc doc/*.txt doc/internal/*.txt doc/text/*.txt
+ docinto html
+ dodoc doc/*.html
+}