summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-06 13:17:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-06 13:17:36 +0000
commit0ddd9eae1936985da358c9e4a67af0d4bc2833ad (patch)
treebf00eb5edd057338ab9ec4893a01d6638bcb4ce9 /sys-libs
parentchanged path/link for a better work with vdr-image plugin (diff)
downloadgentoo-2-0ddd9eae1936985da358c9e4a67af0d4bc2833ad.tar.gz
gentoo-2-0ddd9eae1936985da358c9e4a67af0d4bc2833ad.tar.bz2
gentoo-2-0ddd9eae1936985da358c9e4a67af0d4bc2833ad.zip
Don't try to execute -fPIC, append that afterward to make NetBSD work _and_ PIC being used, or it will build only static libraries on PIC arches.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/zlib/ChangeLog7
-rw-r--r--sys-libs/zlib/files/zlib-1.2.1-fPIC.patch5
2 files changed, 9 insertions, 3 deletions
diff --git a/sys-libs/zlib/ChangeLog b/sys-libs/zlib/ChangeLog
index d26ac489eeff..3c345df85a72 100644
--- a/sys-libs/zlib/ChangeLog
+++ b/sys-libs/zlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/zlib
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.56 2006/02/21 23:55:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.57 2006/03/06 13:17:36 flameeyes Exp $
+
+ 06 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ files/zlib-1.2.1-fPIC.patch:
+ Don't try to execute -fPIC, append that afterward to make NetBSD work _and_
+ PIC being used, or it will build only static libraries on PIC arches.
21 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+files/zlib-1.2.3-bsd-soname.patch, zlib-1.2.3.ebuild:
diff --git a/sys-libs/zlib/files/zlib-1.2.1-fPIC.patch b/sys-libs/zlib/files/zlib-1.2.1-fPIC.patch
index 3a38ad924340..5ccbddfd0fbe 100644
--- a/sys-libs/zlib/files/zlib-1.2.1-fPIC.patch
+++ b/sys-libs/zlib/files/zlib-1.2.1-fPIC.patch
@@ -1,6 +1,6 @@
--- zlib-1.2.1/configure
+++ zlib-1.2.1/configure
-@@ -73,7 +73,11 @@
+@@ -73,7 +73,12 @@
if test "$gcc" -eq 1 && ($cc -c $cflags $test.c) 2>/dev/null; then
CC="$cc"
@@ -9,7 +9,8 @@
+ # the above is horribly wrong on a few archs where -fPIC should ALWAYS be
+ # used in the creation of shared libraries. without the following, the
+ # shared lib test will sometimes fail even when shared libs -can- be created.
-+ SFLAGS=${CFLAGS-"-O3"} -fPIC
++ SFLAGS=${CFLAGS-"-O3"}
++ SFLAGS="${SFLAGS} -fPIC"
CFLAGS="$cflags"
case `(uname -s || echo unknown) 2>/dev/null` in
Linux | linux | GNU | GNU/*)