summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-15 03:14:58 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-15 03:14:58 +0000
commit0a7241981f404282e57b39ba40e7b166d031d471 (patch)
tree1f67b49de5c6e34ff004ddc6794d6199005dcc09 /sys-libs
parentOld. (diff)
downloadgentoo-2-0a7241981f404282e57b39ba40e7b166d031d471.tar.gz
gentoo-2-0a7241981f404282e57b39ba40e7b166d031d471.tar.bz2
gentoo-2-0a7241981f404282e57b39ba40e7b166d031d471.zip
Respect CC.
(Portage version: 2.2.0_alpha30/cvs/Linux i686)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libkudzu/ChangeLog7
-rw-r--r--sys-libs/libkudzu/libkudzu-1.1.62-r1.ebuild56
-rw-r--r--sys-libs/libkudzu/libkudzu-1.2.57.1.ebuild5
3 files changed, 8 insertions, 60 deletions
diff --git a/sys-libs/libkudzu/ChangeLog b/sys-libs/libkudzu/ChangeLog
index c2b7c01967cf..5c1a782d3372 100644
--- a/sys-libs/libkudzu/ChangeLog
+++ b/sys-libs/libkudzu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/libkudzu
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libkudzu/ChangeLog,v 1.36 2009/01/11 19:08:13 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libkudzu/ChangeLog,v 1.37 2011/04/15 03:14:58 jer Exp $
+
+ 15 Apr 2011; Jeroen Roovers <jer@gentoo.org> libkudzu-1.2.57.1.ebuild:
+ Respect CC.
11 Jan 2009; Markus Meier <maekke@gentoo.org> libkudzu-1.2.57.1.ebuild:
amd64 stable, bug #208956
diff --git a/sys-libs/libkudzu/libkudzu-1.1.62-r1.ebuild b/sys-libs/libkudzu/libkudzu-1.1.62-r1.ebuild
deleted file mode 100644
index 6341b775d85d..000000000000
--- a/sys-libs/libkudzu/libkudzu-1.1.62-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libkudzu/libkudzu-1.1.62-r1.ebuild,v 1.20 2008/02/29 01:34:03 wolf31o2 Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="Red Hat Hardware detection tools"
-SRC_URI="http://www.ibiblio.org/onebase/devbase/app-packs/kudzu-${PV}.tar.bz2"
-HOMEPAGE="http://rhlinux.redhat.com/kudzu/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 -mips ppc ppc64 sparc x86"
-IUSE="zlib"
-
-RDEPEND="${DEPEND}
- sys-apps/hwdata-gentoo
- !sys-apps/kudzu"
-DEPEND="dev-libs/popt
- zlib? ( sys-libs/zlib )
- sys-apps/pciutils"
-
-S=${WORKDIR}/kudzu-${PV}
-
-src_unpack() {
- unpack ${A}
- epatch \
- "${FILESDIR}"/sunlance.patch \
- "${FILESDIR}"/ppc.patch \
- "${FILESDIR}"/typedef_byte.patch
-}
-
-src_compile() {
- if use zlib
- then
- append-ldflags -lz
- elif built_with_use --missing false sys-apps/pciutils zlib
- then
- die "You need to build with USE=zlib to match sys-apps/pcituils"
- fi
- # Fix the modules directory to match Gentoo layout.
- perl -pi -e 's|/etc/modutils/kudzu|/etc/modules.d/kudzu|g' *.*
-
- if use ppc && [ "$(tc-arch-kernel)" != "ppc" ]; then
- emake libkudzu.a ARCH="ppc" RPM_OPT_FLAGS="${CFLAGS}" || die
- else
- emake libkudzu.a ARCH=$(tc-arch-kernel) RPM_OPT_FLAGS="${CFLAGS}" || die
- fi
-}
-
-src_install() {
- keepdir /etc/sysconfig
- insinto /usr/include/kudzu
- doins *.h
- dolib.a libkudzu.a
-}
diff --git a/sys-libs/libkudzu/libkudzu-1.2.57.1.ebuild b/sys-libs/libkudzu/libkudzu-1.2.57.1.ebuild
index d48dd4eec958..6fd7af2598b1 100644
--- a/sys-libs/libkudzu/libkudzu-1.2.57.1.ebuild
+++ b/sys-libs/libkudzu/libkudzu-1.2.57.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libkudzu/libkudzu-1.2.57.1.ebuild,v 1.14 2009/01/11 19:08:13 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libkudzu/libkudzu-1.2.57.1.ebuild,v 1.15 2011/04/15 03:14:58 jer Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -31,6 +31,7 @@ src_unpack() {
}
src_compile() {
+ tc-export CC
if use zlib
then
perl -pi -e 's| -lpci| -lz -lpci|g' Makefile